Vidéos visibles que sur Youtube

Bonjour tout le monde,

Comme le titre l’indique, je ne peux visionner les vidéos dans un navigateur que sur Youtube.
Sur les autres sites, je n’ai que l’emplacement de la vidéo noir ou blanc.

Ma version Debian est 7.6, DebianEdu/Skolelinux, Wheezy.
(Linux nom_machine 3.2.0-4-amd64 #1 SMP Debian 3.2.60-1+deb7u3 x86_64 GNU/Linux
(Mon processeur est un 64 bits)

J’utilise Iceweasel (24.7.0). J’avais téléchargé Opera pour tester, mais c’est la même chose.
Le plugin flash est Shockwave Flash 10.1 r999. Gnash 0.8.11dev.

Ma carte graphique est 01:00.0 VGA compatible controller: NVIDIA Corporation GF108 [GeForce GT 430] (rev a1).

Quand je lance Iceweasel dans un terminal en root, exemple sur Dailymotion vers une page pour visualiser une vidéo,
j’obtiens dans le terminal :

code: GnomeUI-WARNING **: While connecting to session manager:
Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed.

(iceweasel:6578): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(iceweasel:6578): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(iceweasel:6578): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(iceweasel:6578): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

LoadPlugin: failed to initialize shared library libXt.so [libXt.so: Ne peut ouvrir le fichier d’objet partagé: Aucun fichier ou dossier de ce type]
LoadPlugin: failed to initialize shared library /usr/lib/mozilla/plugins/libflashplayer.so [/usr/lib/mozilla/plugins/libflashplayer.so: mauvaise classe ELF : ELFCLASS32]
WARNING: gnome-keyring:: couldn’t connect to: /home/alain/.cache/keyring-TupOWK/pkcs11: Aucun fichier ou dossier de ce type[/code]
J’ai le fichier /var/lib/dbus/machine-id.

Merci à vous,
Cordialement.

Salut,

Il semblerait que ta librairie libflashplayer.so ne soit pas correcte.
As-tu essayé de télécharger le plugin chez Adobe et de copier le libflashplayer.so dans /usr/lib/mozilla/plugins/ ?

Merci pour ta réponse,

J’ai une erreur en essayant de télécharger du site adobe :

GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark._pk_5ftransaction_5ferror.Code20: MIME type not supported /tmp/user/1000/adobe-release-x86_64-1.0-1.noarch.rpm

J’ai déjà libflashplayer.so dans :

/usr/lib/flashplayer-mozilla/libflashplayer.so /usr/lib/mozilla/plugins/libflashplayer.so

Essaye plutôt de télécharger la version tarball.

Bonjour,

Pourquoi vous faites pas simplement en root (NB: il faut avoir contrib dans /etc/apt/sources.list):

# aptitude install flashplugin-nonfree
# update-flashplugin-nonfree --install

Normalement la deuxième commande est pas utile lors de la première install,
ça se fait tout seul. Verif:

# update-flashplugin-nonfree --status

Qui devrait sortir quelque chose comme :

Flash Player version installed on this system  : 11.2.202.400
Flash Player version available on upstream site: 11.2.202.400
flash-mozilla.so - auto mode
  link currently points to /usr/lib/flashplugin-nonfree/libflashplayer.so
/usr/lib/flashplugin-nonfree/libflashplayer.so - priority 50
Current 'best' version is '/usr/lib/flashplugin-nonfree/libflashplayer.so'

Le contenu de /etc/apt/sources.list :

[code]deb http://ftp.fr.debian.org/debian/ wheezy main
deb-src http://ftp.fr.debian.org/debian/ wheezy main

deb http://security.debian.org/ wheezy/updates main contrib non-free
deb-src http://security.debian.org/ wheezy/updates main contrib non-free

wheezy-updates, previously known as ‘volatile’

deb http://ftp.fr.debian.org/debian/ wheezy-updates main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ wheezy-updates main contrib non-free

multimedia

deb http://www.deb-multimedia.org stable main contrib non-free[/code]
Le aptitude install flashplugin-nonfree ne donne rien :

Pas de version candidate trouvée pour flashplugin-nonfree Aucun paquet ne va être installé, mis à jour ou enlevé.

Il faut que tu changes:

deb http://ftp.fr.debian.org/debian/ wheezy main
deb-src http://ftp.fr.debian.org/debian/ wheezy main

en

deb http://ftp.fr.debian.org/debian/ wheezy main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ wheezy main contrib non-free

puis en root:

# apt-get update

Et après tu pourras l’avoir (packages.debian.org/fr/wheezy/w … in-nonfree)

Effectivement, c’était sans doute les videos en HTML5 qui parvenaient à être lues sur Youtube.

Par défaut, gnash (remplacement libre du plugin flash, émulation limitée) est installé (quand on choisit d’installer Gnome).

mais autant gnash fonctionne bien avec Youtube, autant il a du mal avec la plupart des autres sites de vidéo (qui font ch*er aussi de ne pas proposer leurs vidéos au format HTML5)

Super quand on peut visionner les vidéos !!! :041

Merci à vous pour vos réponses.

Les suggestions de Knucky ont permis de résoudre mon soucis :

  • Ajouter contrib non-free dans /etc/apt/sources.list
  • aptitude install flashplugin-nonfree

Quant au update-flashplugin-nonfree --status, le résultat est :

Flash Player version installed on this system : 11.2.202.400 Flash Player version available on upstream site: 11.2.202.400 flash-mozilla.so - auto mode link currently points to /usr/lib/flashplugin-nonfree/libflashplayer.so /usr/lib/flashplugin-nonfree/libflashplayer.so - priority 50 /usr/lib/gnash/libgnashplugin.so - priority 10 Current 'best' version is '/usr/lib/flashplugin-nonfree/libflashplayer.so'.
J’ai la ligne /usr/lib/gnash/libgnashplugin.so - priority 10 en plus, mais cela fonctionne.

Encore merci alex6, Knucky, Zbf et agentsteel.

Cordialement