Virtualbox et noyau linux-image-5.10.0-15-amd64 " 5.10.120-1 incompatible

Bonjour,
Suite a une mise a jour du noyau Linux de la version 5.10.0-14-amd64 vers 5.10.0-15-amd64 sur l’hôte plus aucune de mes machines VirtualBox ne démarre, que ce soit de VM Ubuntu ou Windows, en redémarrant l’hôte sur la version 5.10.0-14 je n’ai pas de problème?
Visiblement, la dernière version est incompatible avec VirtualBox version 6.1.34 r150636.
Peut-on espérer une mise a jour fiable prochainement?

Généralement, oui !
Mais, parfois, il faut être patient…

As tu installé tes modules vbox* par dkms? Ont-ils été recompilés?

L’installation a été faite par dkms mais cela fait déjà un certain temps.
J’ai eu un problème lors d’une mise a jour de virtualbox en avril mais aujourd’hui c’est suite a une mise a jour de Debian.
J’utilise VirtualBox depuis près de 10 ans sur Ubuntu et j’ai rarement eu des problèmes .
Je suis novice sur Debian. Et sous le noyau 5.10.0-14 no problemo.

Regarde si tu as les modules dans l’arborescence:

find /lib/modules -name vbox*ko*

Mais, il me semble que quand le module noyau est installé via dkms, il est recompilé automatiquement à chaque mise à jour du noyau.
Je dis ça parce que j’utilise wireguard qui a un module installé en dkms et je n’ai pas ce problème, mais je me rends bien compte que le module wireguard ne fonctionne « pas vraiment » comme celui de VirtualBox.

Mais il est possible que la compilation ne se soit pas bien passé, ,il faut regarder si ces modules y sont.

Bonjour
Je vais essayer de décrire mon problème.
Lorsque je lance ma VM debian si j’utilise firefox ou thunderbird, je boucle sur ma demande de mot de passe.
Si je lance ma VM Ubuntu le bureau s’affiche mais aucune application ne se lance.
Si je lance une VM Windows j’ai un message d’erreur Windows ne peut être démarré.
Ces problèmes n’apparaissent pas si je démarre l’hôte avec la version 5.10.0.14.
@Almtesh lors de l’installation d’un nouveau noyau il y a effectivement un process qui se lance !ors de la première utilisation de Debian et il faut attendre la fin sinon Impossible de lancer une VM Je suppose qu’il y a recompilation.

Oui DKMS compile à la volée les modules nécessaires en cas d’installation d’un nouveau noyau.
Reste à voir mais je pense que le nouveau noyau n’a pas les modules de compilé correctement.

Bonjour
Alors que dois-je faire : désinstaller VirtualBox ou recompiler mais alors comment faire car pour l’instant la version 5.10.0-14 fonctionne parfaitement et je n’ai pas envie de passer trop de temps sans avoir un système fonctionnel. Il fait trop chaud pour rester enfermé.

@fran.b bonjour,
Malgré la chaleur, j’ai allumé le PC donc voici le résultat de la commande

michel@DEBIAN-HOTE:~$ find /lib/modules -name vbox*ko*
/lib/modules/5.10.0-13-amd64/misc/vboxnetflt.ko
/lib/modules/5.10.0-13-amd64/misc/vboxnetadp.ko
/lib/modules/5.10.0-13-amd64/misc/vboxdrv.ko
/lib/modules/5.10.0-13-amd64/kernel/drivers/virt/vboxguest/vboxguest.ko
/lib/modules/5.10.0-13-amd64/kernel/drivers/gpu/drm/vboxvideo/vboxvideo.ko
/lib/modules/5.10.0-13-amd64/kernel/fs/vboxsf/vboxsf.ko
/lib/modules/5.10.0-15-amd64/misc/vboxnetflt.ko
/lib/modules/5.10.0-15-amd64/misc/vboxnetadp.ko
/lib/modules/5.10.0-15-amd64/misc/vboxdrv.ko
/lib/modules/5.10.0-15-amd64/kernel/drivers/virt/vboxguest/vboxguest.ko
/lib/modules/5.10.0-15-amd64/kernel/drivers/gpu/drm/vboxvideo/vboxvideo.ko
/lib/modules/5.10.0-15-amd64/kernel/fs/vboxsf/vboxsf.ko
/lib/modules/5.10.0-14-amd64/misc/vboxnetflt.ko
/lib/modules/5.10.0-14-amd64/misc/vboxnetadp.ko
/lib/modules/5.10.0-14-amd64/misc/vboxdrv.ko
/lib/modules/5.10.0-14-amd64/kernel/drivers/virt/vboxguest/vboxguest.ko
/lib/modules/5.10.0-14-amd64/kernel/drivers/gpu/drm/vboxvideo/vboxvideo.ko
/lib/modules/5.10.0-14-amd64/kernel/fs/vboxsf/vboxsf.ko
michel@DEBIAN-HOTE:~$ 

Si comme je suppose .ko veut dire KO alors la compile n’a pas fonctionné.
Donc qu’est-ce qui a pu foirer?
J’ai vu sur un forum un signalement d’un problème de compile fait le 12 juin ce serait dû a un problème de version de GCC a-t-on une information quelque part la dessus.

Non ko c’est juste l’extension de fichier

Non, visiblement les modules se sont bien compilés. Mais vu que tes VMs démarrent, c’est cohérent… Dans ce que je vois, on dirait un souci de clavier/souris. Mais là, avec ce que tu dis, je ne vois pas…

Bonsoir
Problème de clavier!!! pourquoi cela fonctionne depuis le noyau 5.10.0-14?

En fait, « ko », ça veut dire « kernel object », c’est le format des modules du noyau.
Si ça ne fonctionne pas, ce n’est pas indiqué ici, mais plutôt dans le retour d’erreur de la compilation et/ou dans les journaux du système.

Ce que je veux dire, c’est que tout se passe comme si la machine virtuelle avait un souci de souris et surtout de clavier… Sinon, reste avec le noyau précédent.