Visionner un DVD sur une autre machine


#1

Bonjour,
ce soir, je me proposais de regarder un DVD, quand je me suis apercu que je n’avais pas de lecteur sur la machine que j’utilise dans le salon, mais sur l’autre, qui est dans le bureau.
Ma machine de salon ayant dèjà tous les IDE pleins, je me demandais si quelqu’un avait une idée pour lire le DVD dans le bureau et l’afficher dans le salon (sachant que j’ai bien sûr un réseau).
J’avais pensé à mythtv, ou vlc, qui ont je crois des fonctionnalités de streaming, mais mythtv est un peu lourd, et je ne connais pas les fonctionnalités avancées de vlc.
Que me conseillez vous pour que je puisse vite fait regarder “pirates des caraibes” avec ma douce ?


#2

et bien je ne suis pas un expert du reseau mais ne serait-ce pas une solution envisageable de faire un mount depuis une autre machine ou comme on dit sous windows de faire un partage de dossier / lecteur???

ce n’est pas la solution (streaming) que tu recherches mais ça a le merite d’etre simple et rapide (normallement …)


#3

Sur ton poste au salon, tu as tous les lecteurs multimédia disponibles, je suppose ? Donc, pourquoi pas un partage NFS ?
Je le fais souvent, mon “usine d’encodage” étant au sous-sol, je partage le disque qui contient les films encodés. Ca a un double avantage:

  1. Etant très flemmard, :blush: ca m’évite de re-transférer les vidéos retraitées sur mon PC freevo.
  2. Souvent, quand je regarde un film, j’en enregistre 1 ou 2 autres en même temps… Donc, ca répartit la charge, les disques de mon PC ne moulinent pas trop fort, du fait que ma séance ciné est lue sur le partage NFS.

#4

j’etais en train de le faire, mais mon alim a cramé :frowning:
Alors je ne pratique pas spécialement nfs, mais j’en étais à essayer de comprendre pourquoi quand le dvd n’etait pas monté, il acceptait le mount, mais pas quand le dvd etait monté. Sans doutes un pb de droits mal configurés.
Enfin sinon, Jabba, il faut l’option async, à ton avis ?


#5

[quote=“MattOTop”]j’etais en train de le faire, mais mon alim a cramé :frowning:
Alors je ne pratique pas spécialement nfs, mais j’en étais à essayer de comprendre pourquoi quand le dvd n’etait pas monté, il acceptait le mount, mais pas quand le dvd etait monté. Sans doutes un pb de droits mal configurés.
Enfin sinon, Jabba, il faut l’option async, à ton avis ?[/quote]

Tu as les droits positionnés de quelle manière ?
Chez moi, rien de spécial, un share NFS tout à fait standard:
Le Serveur:

jeannot@teloche:~$ cat /etc/exports
# /etc/exports: the access control list for filesystems which may be exported
#               to NFS clients.  See exports(5).
/freevo         192.168.0.2(ro)
/freevo/DVD     192.168.0.2(ro)
/freevo/TV      192.168.0.2(ro)
/media/cdrom0   192.168.0.2(ro)
jeannot@teloche:~$ ls -ld /media/cdrom0
dr-xr-xr-x  1 root root 2048 2001-11-29 00:21 /media/cdrom0
jeannot@teloche:~$

Le Client:

burp:/home/jeannot# showmount -e teloche
Export list for teloche:
/freevo       burp.cave.maison
/freevo/TV    burp.cave.maison
/freevo/DVD   burp.cave.maison
/media/cdrom0 burp.cave.maison
burp:/home/jeannot# df -h -t nfs
Sys. de fich.         Tail. Occ. Disp. %Occ. Monté sur
teloche:/freevo/TV    111G  6,7G   98G   7% /teloche
teloche:/media/cdrom0
                      7,6G  7,6G     0 100% /DVD
burp:/home/jeannot# ls -ld /DVD
dr-xr-xr-x  1 root root 2048 2001-11-29 00:21 /DVD
burp:/home/jeannot#

Bon, dans cet exemple, tout est en root mais ça marche aussi sans problème si le monte en user standard.

Sinon, pour l’option “async” je ne m’en suis pas préocuppé et ca fonctionne quand même sans problème, malgré un message au moment du redémarrage du serveur NFS:

teloche:/etc/freevo# /etc/init.d/nfs-kernel-server restart
...
exportfs: /etc/exports [6]: No 'sync' or 'async' option specified for export "192.168.0.2:/media/cdrom0".
  Assuming default behaviour ('sync').
  NOTE: this default has changed from previous versions
done.
Starting NFS kernel daemon: nfsd mountd.

Un truc auquel il faut faire attention: si tu visionnes ton DVD avec mplayer, il faut lui donner au miminum 8 MB de cache sinon la lecture sera saccadée.

Ah bon … Moi qui croyait que c’étaient seulement les bagnoles qui cramaient en France … :laughing:
Bon, ok j’ai compris, ne recommençons pas avec les sujets qui fâchent … :blush:


#6

OK Jabba: la partie nfs, c’est règlé, j’ai bien accés.
Par contre, j’ai configuré xine pour prendre son entrée DVD sur le mount, et sous kaffeine ca marche pas.
Mais si tu me dis que toi tu utilises mplayer, je vais plutot essayer ça.