Wheezy non Pae


#1

Bonjour,
Que ce soit avec la dernière version d’ Ubuntu ou Wheezy, je suis embété car mon processeur ne supporte pas les noyaux PAE.
Pour le moment, ces 2 versions tournent en machine virtuelle sur mon portable, donc le problème est contournable, mais comment faire pour une installation en dur, ce que je vais peut etre faire avec Wheezy lorsqu’ elle sera stable. Pour Ubuntu, j’ ai cru comprendre qu’ un upgrade depuis ma version actuelle est possible (j’ ai l’ ancienne Lts Lucid) de plus une version non pae a été crée. Mais avec Wheezy ?
Merci à tous pour votre aide.


#2

le noyau “486” ne fait pas l’affaire ?


#3

Normalement si, mais revers de la médaille, le noyau 486 ne supporte pas le SMP (multi-processeur). Cela implique que si le processeur a l’hyperthreading et/ou plusieurs coeurs, ce noyau n’en tire pas parti (sans parler des optimisations spécifiques pour 686 et au-delà, mais il paraît que l’impact est minime). Cela peut être l’occasion de compiler son propre noyau sans PAE mais adapté au processeur.


#4

Bonjour et merci pour vos réponses.
Mon processeur est un simple coeur, voici ces caractéristiques :

*-cpu product: Intel(R) Celeron(R) M CPU 440 @ 1.86GHz vendor: Intel Corp. physical id: 1 bus info: cpu@0 version: 6.14.12 serial: 0000-06EC-0000-0000-0000-0000 size: 100MHz width: 32 bits
Donc la version 486 devrait convenir ? Et la version 386 ?
Merci, bonne soirée.


#5

Oui, le noyau linux-image-486 conviendra très bien.

Il n’y a plus de noyau Debian -386 car, bien que “i386” soit resté comme nom de code pour l’architecture Intel 32 bits (x86), les processeurs i386 ne sont plus supportés par les versions actuelles de Debian. Il faut au minimum un processeur i486.


#6

Parfait, merci beaucoup à vous pour votre aide, bon Dimanche.


#7

Salut,
Ce n’est pas très grave, mais j’aime bien la coche verte moi…

regles-d-usage-du-forum-t28179.html

Et puis avec plus de 600 messages tu devrais le savoir quand même! :wink:


#8

Salut,
Oui désolé, je ne sais pas pourquoi j’ ai mis résolu…
Bon Dimanche.


#9

[quote=“PascalHambourg”]Oui, le noyau linux-image-486 conviendra très bien.

Il n’y a plus de noyau Debian -386 car, bien que “i386” soit resté comme nom de code pour l’architecture Intel 32 bits (x86), les processeurs i386 ne sont plus supportés par les versions actuelles de Debian. Il faut au minimum un processeur i486.[/quote]

Bonjour je reviens vers vous,
Je n’ ai donc qu’ une version 386 ici : cdimage.debian.org/cdimage/weekly-builds/, ou pas de version 486, ou puis je la trouver, j’ ai beau chercher je ne la trouve pas.
Merci de votre aide.


#10

salut ungars !!

n’as tu pas penser au kernel RT (realtime)?

[quote=“ungars”][quote=“PascalHambourg”]Oui, le noyau linux-image-486 conviendra très bien.

Il n’y a plus de noyau Debian -386 car, bien que “i386” soit resté comme nom de code pour l’architecture Intel 32 bits (x86), les processeurs i386 ne sont plus supportés par les versions actuelles de Debian. Il faut au minimum un processeur i486.[/quote]

Bonjour je reviens vers vous,
Je n’ ai donc qu’ une version 386 ici : cdimage.debian.org/cdimage/weekly-builds/, ou pas de version 486, ou puis je la trouver, j’ ai beau chercher je ne la trouve pas.
Merci de votre aide.[/quote]

regarde la sortie console :

p   linux-image-3.2.0-3-486                                     - Linux 3.2 for older PCs                                              
i   linux-image-3.2.0-3-686-pae                                 - Linux 3.2 for modern PCs                                             
p   linux-image-3.2.0-3-686-pae-dbg                             - Debugging infos for Linux 3.2.0-3-686-pae                            
p   linux-image-3.2.0-3-amd64                                   - Linux 3.2 for 64-bit PCs                                             
p   linux-image-3.2.0-3-rt-686-pae                              - Linux 3.2 for modern PCs, PREEMPT_RT                                 
p   linux-image-3.2.0-3-rt-686-pae-dbg                          - Debugging infos for Linux 3.2.0-3-rt-686-pae                         
p   linux-image-486                                             - Linux for older PCs (meta-package)                                   
p   linux-image-686                                             - Linux for modern PCs (dummy package)                                 
p   linux-image-686-bigmem                                      - Linux for PCs with 4GB+ RAM (dummy package)                          
p   linux-image-686-pae                                         - Linux pour PC modernes - métapaquet                                  
p   linux-image-amd64                                           - Linux for 64-bit PCs (meta-package)                                  
p   linux-image-openvz-686                                      - Linux for modern PCs (meta-package), OpenVZ support                  
p   linux-image-rt-686-pae                                      - Linux for modern PCs (meta-package), PREEMPT_RT                      
p   linux-image-vserver-686                                     - Linux for modern PCs (meta-package), Linux-VServer support           
p   linux-image-vserver-686-bigmem                              - Linux for PCs with 4GB+ RAM (meta-package), Linux-VServer support    
p   linux-image-xen-686                                         - Linux for modern PCs (meta-package), Xen dom0 support           

donc : p linux-image-486 - Linux for older PCs (meta-package)


Oh no! Something's gone wrong
#11

Salut,
Mais on doit s’ y prendre commment alors pour l’ installer ? Cette option est proposée lors de l’ installation ?


#12

apres install , en console …depuis le temps que tu fais linux quand meme !! :005

aptitude install linux-image blhablha :wink:


#13

Oui mais j’ ai un kernel non pae. Pour l’ installer, il va bien falloir que je me serve d’ un cd pour kernel non pae.


#14

je n’ai jamais fait ça! mais je pense qu’une netinstall doit être capable d’aller chercher le noyau qui convient


#15

je pensais plus a cela en effet ;p


#16

Je tente ça demain,
Merci bonne soirée, je vous tiens au courant.

Edit : je n’ ai pas trouvé de netinstall en testing : cdimage.debian.org/cdimage/weekl … 86/iso-cd/


#17

Une autre solution possible si tu es vraiment coincé avec l’installeur Debian : réaliser l’installation avec debootstrap à partir d’une machine fonctionnelle.


#18

[quote=“ungars”]
je n’ ai pas trouvé de netinstall en testing : cdimage.debian.org/cdimage/weekl … 86/iso-cd/[/quote]
debian.org/devel/debian-installer/


#19

Merci pour le lien. Je viens donc d’ installer une wheezy sans problème sur mon pc dont le processeur n’ est pas PAE. C’ est un soulagement.
Je découvre la nouvelle version de Gnome, moi qui n’ aime pas trop le changement… Mais tout a l’ air bien ergonomique, je m’ y retrouve pas trop mal.
Merci à tous pour votre aide.