Woody sur Apple PPC 7300


#1

Bonjour,
Nouveau née sur Linux, je tente l’installation d’une Debian Woody sur un Apple PPC 7300 en suivant cette méthode: people.via.ecp.fr/~alexis/formation-linux/

Je n’ai eu aucun problème, jusqu’à l’installation des packages requis pour la compilation du noyau:

[quote]Enfin, il faut installer le package module-init-tools et mettre à jour le package modutils :

Méthode 6 disquettes ou 1 mini-CD ou 1 CD : ajoutez la ligne suivante à la fin du fichier /etc/apt/sources.list :

deb backports.org/debian/ stable module-init-tools

Puis installez les deux packages requis :

apt-get update

apt-get install module-init-tools modutils

Une fois que l’installation des packages est finie, vous pouvez retirer la ligne que vous avez ajouté au fichier /etc/apt/sources.list.

Méthode 7 CDs / 1 DVD : commençez par décompresser le fichier packages-2.6.tar.gz dans le home du root :

cd

tar xvzf packages-2.6.tar.gz

Ensuite, ajoutez la ligne suivante à la fin du fichier /etc/apt/sources.list :

deb file:/root/packages-2.6 ./

Puis installez les deux packages requis :

apt-get update

apt-get install module-init-tools modutils

Une fois que l’installation des packages est finie, vous pouvez retirer la ligne que vous avez ajouté au fichier /etc/apt/sources.list.[/quote]

Pas de problème pour modutils,
mais impossible de trouver le package module-init-tools pour Debian sur PPC.

D’autre part, je me demandais si ce noyau: linux-2.6.9 serait adapté aux PPC.
N’y a t’il pas un packages linux-2.6.9.PPC ?

Merci… à plus…


#2

si tu es dans l’architecture “ppc” les paquets kernel image sont adaptés a ton architecture, sans que ça soit “noté” dans le nom.

Pour la debian woody, il n’existe pas module-init-tools, et la debian woody est la debian stable, donc c’est illogique d’utiliser un 2.6 qui est encore un peu jeunot.

Pour utiliser un noyau 2.6, préférez une debian sarge (vous pouvez mettre a jour directement votre woody en sarge).


#3

Arf…
Pourtant dans la formation d’Alexis, il parle bien de la Woody

[code]2.3.4. Méthode 7 CDs / 1 DVD

Il faut que vous vous procuriez les 7 CDs ou le DVD (si vous avez un lecteur de DVD) de la Debian version 3.0r0, 3.0r1, 3.0r2 ou 3.0r3 alias Woody.[/code]

Il est vrai qu’il dit aussi:

Mais je suppose que la manip devrait être la même pour une architecture PowerPC.
D’ailleurs, je n’ai eu aucun problème jusque là.

J’ai donc installé une Sarge sur mon G4…Et…
Même problème qu’avec la Woody.
Le module-init-tools pour PowerPC reste introuvable.
De même en passant sur la Sid.

Pour ce qui est des packages:
Tu me dis:

Et je lis sur la formation:

[quote]2.2.1. Qu’est-ce qu’un package ?

Un package est un logiciel ou une partie d’un logiciel que l’on a mis dans un paquet. Ce paquet prend la forme d’un fichier avec un nom particulier : nom-du-logiciel_numéro-de-version_nom-de-l’architecture.deb (par exemple le fichier apache_1.3.24_i386.deb contient la version 1.3.24 du programme Apache pour processeurs Intel). [/quote]
Arf… Où est cette architecture “ppc” ?

Je ne suis pas la seule personne à avoir installé une Debian sur un Mac NewWorld, et pourtant il me semble être le seul à avoir ce problème lol.

En tous cas, merci de ton aide.

A plus…


#4

il y a peut etre des sources particulières ‘ppc’, comme il y a alioth pour le 64 bits ? tu as regardé si les spécificités d’install du 64bits pouvaient t’aider.
sinon, avec une tite requète sur google, j’ai trouvé ca:
debian.org/ports/powerpc/inst/install


#5

Bonjour,

Spécificité du 64 bits sur un 7300 ???
Cela me semble un peu illogique.
histoire-apple.com/quickgall … =7300.html
Explique moi, s’il te plait.

Oui, j’avais aussi vu cette page avec google. :wink:
Mais elle parle surtout du boot sur les OldWorld.
Et là pas de prob.
Mon problème est de trouver le binaire Debian “module-init-tools” pour PowerPC,
afin de recompiler le noyau.
Et par la même d’apprendre à le faire.

Merci. A plus…