Wpa_supplicant

Tags: #<Tag:0x00007efedeb44ba8>

Bonjour,

J’ai configuré ma carte wifi en mode nomade avec wpasupplicant, ma configuration fonctionne très bien mais à chaque démarrage je dois lancer la commande dhclient pour récupérer une adresse IP.
Ce comportement est normale au vue de ma configuration, je voudrais savoir s’il y avait une directive ou un paramètre à positionner pour récupérer cette adresse en automatique.

Ci-dessous mes fichiers interfaces et wpa_supplicant.conf

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback

auto wlo1
iface wlo1 inet manual
	wpa-driver nl80211
	wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf

ctrl_interface=/var/run/wpa_supplicant
update_config=1

network={
	ssid="ZEOP-8a555b"
	psk=xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
	key_mgmt=WPA-PSK
	priority=2
}   

network={
	ssid="mangoustan"
	psk=xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
	key_mgmt=WPA-PSK
	priority=1
}

Merci.

Willy

Il faut remplacer manual par dhcp dans /etc/network/interfaces.

J’ai déjà testé cette option mais ça ne fonctionne pas, ci-dessous les logs du système :

systemctl status networking.service

● networking.service - Raise network interfaces
   Loaded: loaded (/lib/systemd/system/networking.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Fri 2020-03-06 17:13:11 +04; 42s ago
     Docs: man:interfaces(5)
  Process: 706 ExecStart=/sbin/ifup -a --read-environment (code=exited, status=1/FAILURE)
 Main PID: 706 (code=exited, status=1/FAILURE)

mars 06 17:13:10 neptune systemd[1]: Starting Raise network interfaces...
mars 06 17:13:10 neptune ifup[706]: /etc/network/if-pre-up.d/wpasupplicant: 120: /etc/network/if-pre-up.d/wpasupplicant:
mars 06 17:13:10 neptune ifup[706]: run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1
mars 06 17:13:10 neptune ifup[706]: ifup: failed to bring up wlo1
mars 06 17:13:11 neptune systemd[1]: networking.service: Main process exited, code=exited, status=1/FAILURE
mars 06 17:13:11 neptune systemd[1]: networking.service: Failed with result 'exit-code'.
mars 06 17:13:11 neptune systemd[1]: Failed to start Raise network interfaces.
root@neptune:~# journalctl -p err-- Logs begin at Fri 2020-03-06 17:17:22 +04, end at Fri 2020-03-06 17:18:00 +04
mars 06 17:17:24 neptune systemd[1]: Failed to start Raise network interfaces.

J’ai l’impression qu’avec wpasupplicant on ne peut pas utiliser l’option dhcp, dans tous les tutos que j’ai regardé on utilise l’option manual.

Merci.

Willy

Je ne comprends pas pourquoi la méthode “dhcp” interfèrerait avec wpasupplicant, la phase de configuration IP via DHCP se déroule après la phase d’association au point d’accès.

Tu peux lancer la connexion manuellement en mode bavard pour voir ce qui se passe.

ifup -v wlo1

Ci-dessous les logs de la commande :

root@neptune:~# ifup -v wlo1

ifup: configuring interface wlo1=wlo1 (inet)
/bin/run-parts --exit-on-error --verbose /etc/network/if-pre-up.d
run-parts: executing /etc/network/if-pre-up.d/ethtool
run-parts: executing /etc/network/if-pre-up.d/wireless-tools
run-parts: executing /etc/network/if-pre-up.d/wpasupplicant
wpa_supplicant: wpa_action is managing ifup/ifdown state of wlo1
wpa_supplicant: execute `ifdown --force wlo1' to stop wpa_action
run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1
ifup: failed to bring up wlo1

Willy

Bonjour,

J’ai résolu mon problème, j’ai ajouté une ligne à la fin du fichier interface :

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback

auto wlo1
iface wlo1 inet manual

	wpa-driver nl80211
	wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf

iface default inet dhcp

L’ajout de cette ligne me permet d’obtenir automatiquement l’adresse IP.
Je persiste à dire qu’avec wpa_supplicant la directive inet ne peut être que manual.

Il y a une autre solution si vous voulez utiliser la directive static ou dhcp après la directive inet, dans ce cas il faut remplacer l’option wpa-roam par la directive wpa-conf.
Merci Pascal pour ton aide.

Willy