[XFree] Souris à molette (résolu)


#1

Bonsoir,

Je viens d’acheter une nouvelle souris (Logitech) mais la molette ne semble pas fonctionner. Je l’ai pourtant bien activée lors de la configuration de X. Voici ce que contient le fichier /etc/X11/XF86config-4 :

[code]
Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option “Device” "/dev/psaux"
Option “Protocol” "PS/2"
Option “Emulate3Buttons” "true"
Option “ZAxisMapping” "4 5"
EndSection

Section "InputDevice"
Identifier "Generic Mouse"
Driver "mouse"
Option “SendCoreEvents” "true"
Option “Device” "/dev/input/mice"
Option “Protocol” "ImPS/2"
Option “Emulate3Buttons” "true"
Option “ZAxisMapping” "4 5"
EndSection[/code]

Je suis sous Sarge.


#2

dpkg-reconfigure xserver-xfree86
pour la souris : /dev/psaux…protocol IMPS2…emulate 3 buttons…activer scroll…
c’est ce que j’ai fait chez moi (testing) et ca marche avec une logitec aussi
par contre mon xf86config-4 contient:
ection "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option “Device” "/dev/psaux"
Option “Protocol” "ImPS/2"
Option “Emulate3Buttons” "true"
Option “ZAxisMapping” "4 5"
EndSection

Section "InputDevice"
Identifier "Generic Mouse"
Driver "mouse"
Option “SendCoreEvents” "true"
Option “Device” "/dev/input/mice"
Option “Protocol” "ImPS/2"
Option “Emulate3Buttons” "true"
Option “ZAxisMapping” "4 5"
EndSection

et tout a la fin :

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "Generic Mouse"
EndSection

voila voila
j’espere avoir pu t’aider
philippe


#3

Pas moyen de prendre en compte le choix ImPS/2 avec dpkg-reconfigure xserver-xfree86, j’ai modifié le fichier de config à la main.