Xlib: connection to ":0.0" refused by server ?


#1

Bonsoir (2 !)

Voilà j’avais jamais eu ce message :
Xlib: connection to “:0.0” refused by server
Xlib: No protocol specified

Maintenant, je l’ai tout le temps… ô c’est pas bien grave mais toujours stressant de voir apparaître des lignes que l’on attend pas !
J’ai vu pour l’éviter ponctuellement mais … j’aimerais que cela soit pour toujours !
export DISPLAY=nom_de_la_machine:0.0 : fonctionne pas ; doit me manquer des étapes :wink:

Merci :smiley:


#2

il y a plusieurs raison pour laquelle ca peut arriver, dont la principale: tu as ouvert ta session en utilisateur standard, et tu essayes de lancer une apppli X en tant que root.
si ton user standard est d’accord pour ouvrir son DISPLAY au tout venant, il faut qu’il le dise avec 'xhost +'
Aprés, tu pourra lancer tout ce que tu veux en local avec n(importe quelle identité.

sinon, pas trop d’inquietude pour la sécurité quand on ouvrele serveur X aux autres: par defaut, sous debian, X n’ecoute que le localhost. Ce qui veut dire que si c’est pour de l’affichage distant, il faut modifier les préfèrences du login manager.


#3

Bonjour et merci !

Dès que j’ajoute à “xhost +” un nom utilistateur, cela me renvoie bad hostname, donc si je met mon hostname , ok mais cela ne change rien,
toujours :
Xlib: connection to “:0.0” refused by server
Xlib: No protocol specified

Quelle est la commande pour accéder à mon login manager et donc le modifier :laughing:

Merci et bonne journée,
xtofe.


#4

bonjour

[quote=“xtofe”]Dès que j’ajoute à “xhost +” un nom utilistateur, cela me renvoie bad hostname, donc si je met mon hostname , ok mais cela ne change rien,
toujours :
Xlib: connection to “:0.0” refused by server
Xlib: No protocol specified [/quote]
si l’ ‘xhost +’ tout court (sans argument) ne fonctionne pas, as tu essayé aussi un export DISPLAY=<adresse_de_la_machine>:0.0, au lieu d’utiliser le nom ?
ton ‘hostname’ est il bien fixé ?

[quote=“xtofe”]Quelle est la commande pour accéder à mon login manager et donc le modifier :laughing:
Merci et bonne journée,
xtofe.[/quote]
que veux tu modifier dans le login manager ?
le Login Manager n’est qu’une application utilisatrice de ton serveur X, c’est la manière don se lance ton serveur X qu’il faut (éventuellement) configurer.
Les fichiers de config sont dans /etc/X11.
Sinon, peux tu rerésumer un peu ce qui t’arrive, et ce que tu veux, STP, parceque je ne comprends pas bien.


#5

Bonjour !

DISPLAY=192.168.0.1:0.0 … si j’ai bien compris mette juste l’adresse ?
Si c’est ça ne change rien.

Ce que j’aimerais c’est ne plus avoir :
Xlib: connection to “:0.0” refused by server
Xlib: No protocol specified

Lorsque je modifie dans le shell, un fichier…

Un grand merci et bonne soirée,
xtofe. :smiley:


#6

que donne hostname ?


#7

:smiley: :smiley:
Oh ! Oh !

Display c’est ok avec un temps d’attente (léger)
Mais existe-t-il un moyen d’appliquer cette option pour tout nouvelle session et donc s’éviter de noter à chaque fois Display

Et … encore merci !
Bonne semaine,
xtofe.

P.S. : Avec vous : Linux, j’adore :wink: