Xorg et Radeon X300 PCIE


#1

J’ouvre un nouveau topic pour mon histoire de carte graphique, maintenant que j’ai résolu mon problème de décalage horaire. :smiley:

Donc j’ai une Debien SID avec un noyau 2.6.15, xorg 6.9 et ma carte ATI X300 PCIE.

Mon problème c’est que je ne suis pas sur de profiter pleinement des “maigres” performances de la carte graphique, bien que je ne connaisse pas un moyen de vraiment le vérifier via un outil, si quelqu’un a une idée je suis preneur :smiley:

Du coup j’ai fait des recherches via google et je suis complètement largué sur le driver à utiliser.

soit c’est le driver propriétaire ATI, et dans ce cas il faut modifier la config de la machine en intégrant le module fglrx et là je ne suis pas intéressé, je préfère utiliser le driver libre.

Soit c’est un module dri et là, je suis encore plus perdu sur la marche à suivre :cry: .

Voic la copie de mon xorg.conf

Section "Files"
	FontPath	"unix/:7100"			# local font server
	# if the local font server has problems, we can fall back on these
	FontPath	"/usr/lib/X11/fonts/misc"
	FontPath	"/usr/lib/X11/fonts/cyrillic"
	FontPath	"/usr/lib/X11/fonts/100dpi/:unscaled"
	FontPath	"/usr/lib/X11/fonts/75dpi/:unscaled"
	FontPath	"/usr/lib/X11/fonts/Type1"
	FontPath	"/usr/lib/X11/fonts/CID"
	FontPath	"/usr/lib/X11/fonts/100dpi"
	FontPath	"/usr/lib/X11/fonts/75dpi"
EndSection

Section "Module"
	Load	"bitmap"
	Load	"dbe"
	Load	"ddc"
	Load	"dri"
	Load	"extmod"
	Load	"freetype"
	Load	"glx"
	Load	"int10"
	Load	"record"
	Load	"type1"
	Load	"v4l"
	Load	"vbe"
EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"keyboard"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"fr"
	Option		"XkbVariant"	"nodeadkeys"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"		"/dev/input/mice"
	Option		"Protocol"		"ImPS/2"
	Option		"Emulate3Buttons"	"true"
	Option		"ZAxisMapping"		"4 5"
EndSection

Section "Device"
	Identifier	"ATI Technologies, Inc. RV370 5B60 [Radeon X300 (PCIE)]"
	Driver		"ati"
	BusID		"PCI:1:0:0"
EndSection

Section "Monitor"
	Identifier	"Dell 2001FP"
	Option		"DPMS"
	HorizSync	30-81
	VertRefresh	56-76
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"ATI Technologies, Inc. RV370 5B60 [Radeon X300 (PCIE)]"
	Monitor		"Dell 2001FP"
	DefaultDepth	16
	SubSection "Display"
		Depth		1
		Modes		"1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		4
		Modes		"1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		8
		Modes		"1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		15
		Modes		"1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		16
		Modes		"1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		24
		Modes		"1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
	EndSubSection
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	InputDevice	"Generic Keyboard"
	InputDevice	"Configured Mouse"
EndSection

Section "DRI"
	Mode	0666
EndSection

Par défaut j’utilise le driver ati de xorg, mais si je fait un lsmod, j’ai un module radeon qui est actif :open_mouth:

Si quelqu’un pouvait m’aider à éclaircir tout ça parce que là je mélange tout, ce serait vraiment sympa, ou bien un lien vers un tutorial clair pour optimiser ma config :smiley:

Merci d’avance et bonne journée


#2

le module radeon est peut être un problême, et tu devra peut être faire un ‘rmmod radeon’ si les pistes que je te donne ne fonctionnent pas.

en attendant, comme il est dit ici:
xoomer.virgilio.it/flavio.stanch … #configure
si tout est pret et compilé et installé là ou il faut, il faut surtout:

  • charger le module noyau fglrx:
    modprobe -v fglrx
  • modifier ta config X en utilisant le driver “fglrx” en remplacement de “ati”.

et si tu as déja compilé et installé les paquets fglrx, ca devrait marcher.
En attendant, il y a plein de “trucs & astuces” sur la mise en oeuvre du pilote ATI, dans le lien que je donne.


#3

Merci Matt :smiley:

entre temps j’ai essayé en modifiant “ati” par “radeon” dans mon xorg.conf mais je n’ai rien constaté de nouveau.

Lorsque je lance la commande glxinfo, je constate que le direct rendering n’est pas activé et j’atteind le score de 650 fps à glxgears .

Du coup je me suis inspiré de ton lien ainsi que d’autres pour passer en fglrx, et là prmeier souci lorsque je veux installer le paquet fglrx-driver par apt; j’obtiens l’erreur suivante:

sudo apt-get install fglrx-driver -s
Les paquets suivants contiennent des dépendances non satisfaites :
  fglrx-driver: Dépend: xserver-xorg (< 6.8.99)
E: Paquets défectueux