Arrêter le bip de la carte mère

Re salut :slightly_smiling:

Une autre astuce super je trouve, pour stopper définitivement le bip de la carte mère quand on fait retour arrière ou suppr et qu’il n’y a rien.

Dans un shell,

grep -1 bell .bashrc xset b 0

Voilà voilà :slightly_smiling:

Ou bien dans /etc/modprobe.d/blacklist, blacklister le module PC-Speaker en rajoutant “blacklist pcspkr”, c’est plus radical.

Perso, j’ai préféré utiliser une méthode encore plus radicale…
Le seul problème est que je ne sais plus ce que j’ai fait de ce foutu buzzer après l’avoir arraché !

De façon logicielle, alsamixer (du paquet alsa-utils) permet aussi de muter le bip système.

[quote=“vv222”]Perso, j’ai préféré utiliser une méthode encore plus radicale…
Le seul problème est que je ne sais plus ce que j’ai fait de ce foutu buzzer après l’avoir arraché !

De façon logicielle, alsamixer (du paquet alsa-utils) permet aussi de muter le bip système.[/quote]
Un peu hard comme solution… Un tour dans le BIOS pour désactiver le haut-parleur interne aurait largement suffit ^^

moi le bip de carte mère passe par les hauts parleurs, il n’y a pas de speaker intégré sur mon pc portable.
donc quand je ne veux pas de bip je coupe le son.

Pour enlever le bip de la carte mère :

[quote=“BbT0n”]Pour enlever le bip de la carte mère :

Nan sa fait toujour beep aux demarrage :laughing:

perso ce truc me ser a rien je l’ai débrancher si le pc plante et démarre plus je le remet en fait ce truc a un interet mineur si dans le bios on met allorror stop. sa va pas plus loin. après sa peux aider aux dignostic :slightly_smiling: donc chez moi y a pas de son du tout sauf si j’allume l’ampli :stuck_out_tongue:

J’aimerais pouvoir enlever le miens mais il est inclus dans la carte mère et il n’y a aucune option du bios pour ne pas faire de bruit au démarrage. Pire il va jusqu’à envoyer le son sur les enceintes si elles sont branchée.

effectivement la je voit pas, y a pas deux soudure près de l’aimant ? si oui tu desoudes :slightly_smiling: fait gaff aux vernis qui isole la cm :slightly_smiling:
nan je dé :smt005 conne

C’est des soudures à l’or bien trop précis pour mon fer à souder… :wink:

J’utilisais ces commandes avant quelque mois, mais lors de mon dernier installation lenny 5.0.3, ces 2 commandes marchent que pour la session courrante:

grep -1 bell .bashrc xset b 0

A chaque re-démarrage, le beeeeep re-fonctionne, ainsi ma nervosité pour ce bruit la nuit.

Est-ce normal ? les commande je les ais faite sous root et utilisateur, mais au redémarrage, on repart à zéro.
En parlant, quel fichier dois-je édité pour ajouter ces commandes, pour qu’ils prennent effet à chaque démarrage ?

Dans /etc/init.d tu peux placer ton script ensuite man update-rc.d
vala :slightly_smiling:

Merci, j’éssayerais.

Pour xset -b off, pas besoin de créer un service pour ça, tu peux lancer la commande en user. De plus, je pense que ça ne fonctionnera pas si tu lances la commande avant que X ait démarré.
Selon ton environnement de bureau/gestionnaire de fenêtres, tu devrais trouver facilement un moyen de lancer la commande après la connexion.
Tu peux aussi utiliser ~/.xinitrc ou ~/.Xsession (ou autre, selon ton gestionnaire de login).

Pour modprobe -r pcskrc, il faudrait confirmer, mais il me semble que l’astuce est obsolète (le beep n’est plus géré par le module pcskrc, il me semble).

J’ai ajouté sur xinitrc du x11 et du home mais alors c’est au niveau de gdm que sa bip encore.

J’ai aussi essayer ci dessous, mais rien qui change:
/etc/gdm/Xsession
/etc/X11/Xsession.options
/home/.xsession

Je continuerais demain mes tortues dorment, j’ai pas envie de les énervé :smiley:

Merci

Bigre ! Ça nous fait une belle jambe !

Oooh c’est trou mignon :smiley:

Bonjour

Pour enlever les beep il faut et il suffit d’ajouter à la fin du fichier /etc/modprobe.d/blacklist.conf

blacklist pcspkr

edit: sur un noyau 2.6.31

Sous gnome j’ai fait:
Système > Préférences > Son > Bip Système > Décocher

Mais dans ttx, sa beeepais toujours, alors j’ai enlevé le cable sur la carte mère, je suis tranquille…

[quote=“limax”]Bonjour

Pour enlever les beep il faut et il suffit d’ajouter à la fin du fichier /etc/modprobe.d/blacklist.conf

blacklist pcspkr

edit: sur un noyau 2.6.31[/quote]
Ah ? Cette manip’ fonctionne très bien sur Lenny, mais sur Sid (avec 2.6.31) au boot j’ai le droit à un “module pcspkr inexistant” et les BIP se font entendre.

[quote=“Keldath”][quote=“limax”]Bonjour

Pour enlever les beep il faut et il suffit d’ajouter à la fin du fichier /etc/modprobe.d/blacklist.conf

blacklist pcspkr

edit: sur un noyau 2.6.31[/quote]
Ah ? Cette manip’ fonctionne très bien sur Lenny, mais sur Sid (avec 2.6.31) au boot j’ai le droit à un “module pcspkr inexistant” et les BIP se font entendre.[/quote]

Il est ici
/lib/modules/2.6.31-1-686/kernel/drivers/input/misc/pcspkr.ko

Tu as peut être un autre module qui s’occupe du beep.
Il y avais un autre module avec le noyau 2.6.24 (ou proche de ce numero) qui devait s’appeler snd_???

Si tu mets le résultat de lsmod il sera facile de l’identifier. (enfin j’espère)