[ATI Radeon] FATAL: Error inserting fglrx


#1

Bonsoir,

Je préviens je débute sous linux, mais j’ai de la volonté. Oui je suis au courant que Debian c’est un truc de barbus mais autant prendre les bonnes habitudes tout de suite. J’ai lu une térachiée de tutos et FAQs pour mon problème, mais toujours pas de solution potable et/ou claire.

J’ai l’IMMENSE bonheur d’installer les drivers ATI de ma Radeon 9800Pro sous Debian. J’ai du apprendre a recompiler mon kernel (en passant du 2.4.27 au 2.6.8), j’arrive à booter dessus, je vérifie en faisant uname -r tout se passe bien.

Je DL les pilotes pour xfree4.3.0.
Je convertis ensuite le .rpm en .deb grâce à alien, et j’installe le paquet. J’arrive à compiler avec make.sh dans /lib/modules/fglrx/build_mod mais par contre je n’arrive pas à compiler avec make_install.sh dans /lib/modules/fglrx. En fait il finit par la ligne :

FATAL: Error inserting fglrx (/lib/modules/2.6.8/kernel/drivers/char/drm/fglrx.ko) : Invalid module format
failed.

Je fais ctrl + alt + F1, je relance la commande et là j’ai toujours la même erreur mais précédée de :

fglrx: version magic ‘2.6.8 preempt 386 gcc-3.3’ should be '2.6.8 386 gcc-3.3’
FATAL: blablabla…

J’ai fait un gcc --version sur les deux kernel, c’est les même.

Ca fait 2 journées de suite que je suis sur ce problème, j’ai fait le tour de google et j’ai pas trouvé de réponse satisfaisante. J’ai recompilé mon kernel plusieurs fois et toujours pareil. Je compte énormement sur vos réponses pour passer à linux une fois pour toutes :slightly_smiling:


#2

as tu fait un depmod -a ?
as tu compilé et tenté d’insèrer le module dans la foulée, ou as tu changé de noyau entre les deux ?
Et surtout, comment as tu compilé ton noyau ?
Je penses que tu as remarqué: ton module est compilé pour un ‘2.6.8 preempt 386 gcc-3.3’ alors que ton noyau est un ‘2.6.8 386 gcc-3.3’ (ou l’inverse).
Je me dis que tu as dû mettre un nom de sous version, ou patcher ton noyau avec un patch preempt, et que ca gène (mais comment corriger ?)…
essayes d’inserer avec un ‘modprobe -f’. Ca ne resoudra pas le problême, car il faudrait le refaire à chaque démarrage, mais si ca te permet un peu d’avancer.


#3

Tout d’abord merci de m’aider, j’apprécie beaucoup :wink:

J’avais pas fait de depmod -a , je viens de le faire mais toujours pareil.

J’ai changé de noyau entre les deux. Pour être clair j’ai compilé le kernel 2.6.8 depuis mon kernel 2.4.27 (mon kernel de base lors de l’install de ma debian). Ensuite j’ai compilé le module, puis j’ai rebooté sur le kernel 2.6.8 et tenté l’install. Ca a pas marché, alors j’ai recompilé le module depuis le kernel 2.6.8 mais toujours pareil.

[quote]
Et surtout, comment as tu compilé ton noyau ?
Je penses que tu as remarqué: ton module est compilé pour un ‘2.6.8 preempt 386 gcc-3.3’ alors que ton noyau est un ‘2.6.8 386 gcc-3.3’ (ou l’inverse).
Je me dis que tu as dû mettre un nom de sous version, ou patcher ton noyau avec un patch preempt, et que ca gène (mais comment corriger ?)…[/quote]

Alors pour l’install du kernel j’ai fait (je détaille) :
apt-get install kernel-source-2.6.8
make menuconfig histoire de créer le fichier de conf, j’ai rien modifié
make-kpkg --initrd --revision=custom.1.0 kernel_image je sais pas si c’est vraiment bon :confused:

Après je reboot, le kernel apparait bien sur GRUB, je boot dessus et ça roule. Je l’ai pas patché. Voici le uname :

Bazi:~# uname -a
Linux Bazi 2.6.8 #1 Sun Nov 27 17:36:34 CET 2005 i686 GNU/Linux

[quote]
essayes d’inserer avec un ‘modprobe -f’. Ca ne resoudra pas le problême, car il faudrait le refaire à chaque démarrage, mais si ca te permet un peu d’avancer.[/quote]
Bazi:~# modprobe -f fglrx
FATAL: Error inserting fglrx (/lib/modules/2.6.8/misc/fglrx.2.6.8.ko): Unknown symbol in module, or unknown parameter (see dmesg)

Il veut toujours pas :slightly_smiling:
En tout cas tu me réconforte dans l’idée que y’a un soucis de compilation ou du kernel ou du module, mais je sais toujours pas quoi faire :’(


#4

Bon, ben désolé, je pense qu’un utilisateur d’ATI pourra t’aider en reprenant à la base, mais en ce qui me concerne, j’ai évité la fréquentation des ATI depuis l’epidémie de rage des années 2000, donc je ne vois pas quoi te conseiller… :slightly_smiling:

sinon, à priori, de ce que tu me dis de ta manière de compiler le noyau me parait normal…


#5

As-tu déjà consulté ce lien ?
http://xoomer.virgilio.it/flavio.stanchina/debian/fglrx-installer.html


#6

Oui je suis tombé dessus, mais je me suis plus basé sur pcinpact.com/forum/index.php?showtopic=20622

En fait tout fonctionne, je parle dans l’ordre des commandes et ainsi de suite. La seule chose qui foire c’est apparement le fait que j’utilise 2 compilateurs différents, un pour compiler le kernel, et un pour compiler le module.

fglrx: version magic ‘2.6.8 preempt 386 gcc-3.3’ should be ‘2.6.8 386 gcc-3.3’

Concretement, où je peux voir apparaitre ces numéros de version ailleurs que dans ce message d’erreur ? Et il veut dire quoi ce “preempt” ? Ca peut me faire avancer.

J’ai encore passé une soirée dans le vent ;o( Je vous remercie d’avance, j’ai VRAIMENT envie de passer définitivemet à linux.


#7

C’est pas 2 versions différentes de compilateur que tu utilises semble-il mais j’ai l’impression que tu as un sacré mélange au niveau de tes sources de kernels.
Recommences en installant une image de kernel standard + les sources + les headers --> Et tous de la même version …

  1. sauvegarde ton config-xxx-kernel actuel qui est dans /boot.
  2. Installes un linux-image de ton choix (comme ça tu auras toujours une base stable sur laquelle redémarrer.
  3. installes un linux-source de même version que le linux-image
  4. Prends encore les headers exactement de la même version
  5. Et, bon dieu ! quand tu auras un kernel de base, PURGE tout le merdier qui te provoquait ces erreurs.

Ensuite on pourra peut-être dépanner le reste …


#8

+1, sauf pour les headers qui sont AMHA inutiles à installer (mais utiles à garder aprés le make-kpkg buildpackage)


#9

Ok merci Jabba, je fais tout ça ce soir je te dirais si ça foire (ou marche)

Installer une image de kernel ? C’est à dire ? Moi la dernière fois j’ai DL les sources, puis compilé le kernel à partir de ces sources, c’est pareil ou pas ? (je me renseigne là dessus)

héhé, dans le doute j’installe quand même on sait jamais :slightly_smiling:


#10

Pour la compilation des sources non ce n’est pas pareil il vaut mieux compiler a la sauce debian voir mon post forum.debian-fr.org/viewtopic.php?t=1806

Sinon pour les images, Jabba te demande d’installer les images déjà faites donc

apt-get install linux-image-2.6.14 si tu veux la version 2.6.14 et voila
ensuite les sources

apt-get install linux-source-2.6.14 il faut prendre la meme version :slightly_smiling:


#11

Ok je vais installer une image précompilée alors :slightly_smiling:
nuxo.net/tutorial-19.html

Sachant que j’ai une Sarge, donc stable, vous me conseillez un noyau en particulier ou n’importe ? C’est pas limité à la 2.6.8 ?


#12

pour sarge si c’est limité a la 2.6.8 mais tu peux prendre n’importe lequel pour installer le dernier noyau tout en restant stable voir forum.debian-fr.org/viewtopic.php?t=1728

le dernier noyau reconnu stable est le 2.6.14 (meme si il n’est pas dispo en stable :slightly_smiling:)


#13

Je trouve que tu te compliques la vie. Il existe des packages ATI pour linux, préts pour l’emploi, tu n’as qu’à simplement faire un sh sur le package pour lancer le setup d’installation, sans avoir à tout compiler.
forum.debian-fr.org/viewtopic.php?t=1761


#14

Bon j’ai (je pense) installé un kernel tout propre, le 2.6.8 K7. Reboot impec. J’ai alors installé le package que Damsss à montré, puis fais sa config en tappant fglrxconfig. Et ben non, ça marche pas ;o(

Voici le log de Xfree :
http://tehtwig.free.fr/log.txt
Apparement il trouve pas fglrx comme module, j’ai effectivement fait un modprobe dessus et il le trouve pas. Startx ne marche plus non plus, ça doit etre lié.

Ceci dis, on avance on avance … :slightly_smiling:


#15

D’après ton log,

ça inque que ton module fglrx est activé, et que l’accéleration 3D fonctionne,

en revanche :

quote Option “Device” “/dev/mouse”
(EE) xf86OpenSerial: Cannot open device /dev/mouse
No such file or directory.
(EE) Mouse1: cannot open input device
(EE) PreInit failed for input device “Mouse1”[/quote]
indique que ta souris n’est pas bien configurée et qu’il n’arrive pas à la trouver.
Tant que tu n’auras pas résolus ce problème, tu ne pourras pas lancer de séssion graphique (c’est suscéptible XFree86).

Essaye d’éditer le fichier /etc/X11/XF86Config-4 et de remplacer /dev/mouse par /dev/psaux si tu as une souris ps, ou /dev/input/mice si c’est une souris usb.

Oui, il y a aussi une erreur de chargement du module fglrx. Vérifie si tu as bien installé la source de ton kernel, que tu as dans synaptic, afin que le module fglrx puisse se compiler d’après ton kernel.


#16

ON Y EST LES ENFANTS ! \o/////////////
Merci Darnss, en fait le link de mon dossier linux était foireux, je l’ai refais ponté vers les sources et j’ai relancé glrxconfig, un petit ctrl+alt+back et paf ! Finis le 800x600 et bonjour le 1024 !

C’est presque finis mais il reste un petit truc, sinon ça serait pas drole :smiley:
Là je me flingue les yeux, je suis aller sous gnome dans les parametres de l’écran, et il veux pas aller au dessus de 1024 (remarque je m’en fous c’est ma résolution courante, mais j’aime pas trop si il me propose pas au-dessus), mais surtout il me propose que 43Hz ou 60Hz. Ca fait les yeux rouges ;o(

Il me semble que ça se change dans un fichier, je verrai ça demain !

Edit :
glxinfo | grep "direct rendering"
direct rendering: No
Je suis déçu. Dodo. :frowning:


#17

Pour le “direct rendering”, tu as bien activé le module DRI dans ton xorg.conf, au moins ?
Par ailleurs, pour le reglage des frequences, j’ai profité de ta question pour faire un “trucs et astuces”:
forum.debian-fr.org/viewtopic.php?p=11511#11511


#18

Dans le log d’installation des pilotes, il ne trouvait pas version.h, j’ai donc réinstaller les headers, et réinstallé les pilotes.

Bazi:~# glxgears
19537 frames in 5.0 seconds = 3907.400 FPS
22609 frames in 5.0 seconds = 4521.800 FPS
22605 frames in 5.0 seconds = 4521.000 FPS
22609 frames in 5.0 seconds = 4521.800 FPS

SAI GAGNAI ! Il ne reste plus qu’a changer cette fréquence affreuse, mais ça, c’est une autre histoire :slightly_smiling:
Merci à tous, ma grande aventure linux va pouvoir commencer :smiley:


#19

Chtite question tu as quoi comme ATI pour avoir des score glx pareil???

Moi je ne dépassais jamais les 500 Frames??? :confused: :confused: :imp:


#20

Pour la fréquence de balayage, si tu connais le mode supporté par ton écran, tu peux suivre l’astuce de Matt’, qui marche aussi avec le fichier /etc/X11/XF86Config-4.
En fait, les résolutions supérieurs n’apparaissent pas sous Gnome parcequ’elles ne sont pas supportés par ton écran tel quelles sont définis dans le fichier XF86Config-4. Si tu tentes un “ctrl alt +” sous X, tu devrais voir l’affichage basculer vers un mode supérieur, mais impossible pour l’écran.

Vérifie que tu as bien les lignes du genre :

[code]Section "Screen"
Identifier "Screen0"
Device "ATI Graphics Adapter"
Monitor "Monitor0"
DefaultDepth 24
#Option “backingstore”

Subsection "Display"
    Depth       24
    Modes       "1280x1024" "1024x768" "800x600" "640x480"
    ViewPort    0 0  # initial origin if mode is smaller than desktop

Virtual 1280 1024

EndSubsection

EndSection
[/code]
dans ton fichier XF86Config-4. Où la ligne Modes indique tout les modes que tu souhaites pour ton affichage., et Depth le nombre de bits de couleurs. Modifier cette ligne devrait suffire sans avoir à passer par des “Mode lignes”. (Il faut redémarrer la session graphique ctrl alt backspace à chaque modif du fichier)