Commande adduser sur Debian Buster ne fonctionne pas ? [Résolu]


#1

bonjour,

adduser installé je ne comprend pas pourquoi les commandes ne fonctionnent pas?!

En effet j’ai lancé la commande en root et en non root de adduser duchmol et l’utilisateur duchmol ne se créé pas.

Y à t’il une nouvelle subtilité sur Debian Buster pour créer des utilisateur et des groupes d’utilisateurs?

bien à vous…


#2

Bonjour,
Je dirais que c’est une histoire de PATH.
Le adduser ne doit pas être accessible à un utilisateur lambda et la commande ne doit pas être dans le PATH de root.
Voir les subtilités des connexions su, su -, sudo, etc. dans Buster…


#3

Salut Albert

Ok, ok ,

Je vais aller voir ça après mangé

Je viens de découvrir que l’utilisateur principal n’est pas présent dans le fichier
sudoers


#4

Bonjour tout le monde,

Concernant le fonctionnement de su et des PATH associés, voir notamment :
https://wiki.debian.org/NewInBuster
(paragraphes changes)
J’y ai découvert plein de choses utiles sur les différences Stretch vs Buster :slight_smile:


#5

Ce souci est bien expliqué sur Debian Facile :
Les enquêtes Debian-Facile : on a volé mes commandes root sous Buster


#6

Salut

Je viens de découvrir que l’utilisateur principal n’est pas présent dans le fichier sudoers

C’est pas plus mal…
Plutôt que d’éditer ce fichier pour rajouter des utilisateurs et risquer de péter la configuration de ‘sudo’, il est plus propre d’ajouter les utilisateurs au groupe ‘sudo’. Ce groupe est déjà traité dans ‘/etc/sudoers’ par défaut comme groupe d’utilisateurs de ‘sudo’ avec demande de mot de passe.

Pour le reste, c’est un souci d’utilisation de la commande ‘su’ qui ne doit plus être utilisée ‘à cru’, mais avec l’argument ‘-’ ou ‘-l’ qui lie l’entrée en shell en tant que root à l’appel de son environnement (notamment la variable PATH).
En fait, c’était déjà le cas avant, sauf que la commande ‘su’ seule se comportait comme ‘su -’. Du coup, beaucoup de monde utilisait ‘su’ au lieu de ‘su -’ simplement parce que c’était possible et surtout sans se poser la question de comment lier un environnement d’utilisateur (y compris root) à un shell.
En gros, ça a été corrigé et c’est ce qui perturbe les “mauvaises” habitudes (la fréquence des “faux problèmes” de ce genre depuis la sortie de buster en témoigne, mais ça va se tasser avec le temps).


Synaptic n'installe aucun fichier
Problème avec sudoer
#7

Salut et merci à tous pour vos réponses

En effet les mauvaises habitudes c’était pour ma part bien installées.

Je ne connaissais pas la commande su - ou su -l maintenant les choses sont plus clair
pour moi.

[/quote]


#8

En fait, la première fois qu’on m’a dit “ah mais non, pour te loguer proprement en root, c’est su -”, ça devait être dans le début des années 90 du dernier siècle, et c’était déjà une habitude à prendre pour les sysadmin.
C’était pas sous linux, mais c’était une généralité unix.

Peut on parler de nouveauté ?


#9

@mattotop
Comme toujours, il y a un XKCD adapté à la situation présente :wink: