Configuration langue locale debian Buster XFCE


#1

Bonjour à tous.
Le sujet peut paraître “éculé” tant on trouve d’informations sur la re-configuration locale parfois nécessaire. Cependant, voici le problème rencontré et j’aimerais des éclaircissements.
Installation de Debian Buster XFCE à partir d’une image Iso DVD: debian-live-10.0.0-amd64-xfce+nonfree.iso
Résultat: par défaut, le clavier est en anglais QWERTY. J’édite LOCALE et tout est paramétré fr_FR.UTF-8. De fait mes applications sont bien en français. Je peux changer le clavier mais l’icône en haut à droite du bureau reste EN pour indiquer l’anglais.
La commande en mode root de “DPKG-reconfigure locales” me répond “commande DPKG-reconfigure introuvable”.
J’ai fait cet exercice sur 3 machines physiques différentes et une machine virtuelle pour l’exact même résultat.
Anecdotiquement, en live, j’ai observé la même chose.
En dehors d’une explication sur le pourquoi du comment, quelle est la procédure pour reconfigurer par défaut en français de France métropolitaine?
Version Buster XFCE; je suis relativement néophyte lorsqu’il faut mettre les mains dans le cambouis.


#2

salut

https://www.debian.org/doc/manuals/debian-handbook/basic-configuration.fr.html#sect.default-language

Avec Buster pour avoir toutes les permissions il faut utiliser

su -

en français su suivi d’un tiret
et pas de majuscule dans le nom de la commande

 su -
Mot de passe : 
root@debian:~# dpkg-reconfigure locales

Capture%20d%E2%80%99%C3%A9cran%20du%202019-08-08%2014-55-06


#3

Et pour le clavier, c’est keyboard-configuration. Tu peux partir sur l’exécution de

dpkg-reconfigure locales keyboard-configuration tzdata

pour tout remettre en place (oui, tzdata pour le fuseau horaire, car je pense qu’il ne doit pas être bon non plus).
Et pense à redémarrer pour mettre tout en place.


#4

Merci pour ces 2 réponses.
Pour la commande “su -”, c’est parfait. Si on commence à faire des distinctions dans les droits Root, ou trouve-t-on l’inventaire de ces subtilités?
De fait, la commande dpkg-reconfigure fonctionne, mais rien ne change.
Après redémarrage, j’ai toujours mon icône “EN”. J’ai le clavier en français pour l’avoir modifié manuellement en mode graphique et en décochant donc le “mode par défaut”. Si je recoche le mode par défaut après avoir ajouter le clavier français et supprimé le clavier anglais, il redémarre en clavier anglais Qwerty. Je décoche paramètres par défaut et je redémarre avec un clavier français azerty mais toujours avec l’icône “EN”
L’heure est bonne.
La commande incluant le clavier et le fuseau n’a rien changé.
Par quelle donnée enregistrée est pilotée cette icône “EN” (anglais - English(US))?


#5

Bonjour,

Avec Xfce, j’ai réglé cette histoire avec Paramètres / Clavier / Disposition.

La langue du système et la disposition du clavier sont deux choses différentes.
La disposition du clavier ne change pas la langue du système.

L’onglet Comportement comporte une Zone de test.


#6

On est bien d’accord.
Mais ça ne règle pas le problème sur le fond, puisque l’icône reste calée sur “EN” et tôt ou tard, il y aura un souci, ne serait-ce que les paquets de langage. Dans les mises à jour, il me propose d’ores et déjà tous les paquets de langage et d’aide pour Firefox et Libreoffice qui sont sans intérêt si Buster a bien intégré qu’on travaillait exclusivement en français.


#7

Pour ton installation,
tu as utilisé un fichier image ISO d’une version Live de debian.

Dans Applications -> Paramètres -> Clavier -> Onglet Disposition
il te faudrait décocher la case associée au label : Utiliser les paramètres par défaut


#8

Ça, c’est fait. C’est ce que j’explique plus haut. Mais l’icône reste calée sur Anglais. Il y a donc autre chose à changer dans un quelconque fichier de configuration. D’où ma question. Qu’est-ce-qui conditionne cette icône.
Lorsque j’interroge avec “locale” tout est bien en français UTF-8, or par défaut le clavier est en anglais.
Comment avoir le clavier français par défaut, ou encore pourquoi le clavier par défaut est actuellement anglais alors que les locales sont bien en français???


#9

D’ici, je ne peux pas voir quelles sont les dispositions clavier qui sont dans la liste des
Disposition du clavier => (voir la liste au bas de la capture d’écran de mon message précédent)

Supprime de cette liste toutes les dispositions claviers
afin de n’en laisser qu’une : celle correspondant à ton clavier Français.


#10

C’est ce que j’ai fait. Je n’ai que le clavier français après avoir décoché les paramètres par défaut.
Si donc je décoche les paramètres par défaut, j’ai mon clavier français. Si je recoche les paramètres par défaut, j’ai mon clavier en anglais.
Et encore une fois, quel que soit le clavier, mon icone indique l’anglais par défaut alors que toutes mes locales sont en français.
Ça reste un grand mystère que j’aimerais éclaircir.


#11

Tu peux essayer :

setxkbmap fr

Pour voir si l’icone change.

et aussi

setxkbmap -print

J’ai vérifié avec deux claviers en disposition ;
et les arguments fr et us font changer l’icone du plugin xfce4-xkb-plugin

Capture%20d%E2%80%99%C3%A9cran_2019-08-08_17-50-29


#12

J’ai saisi la commande en mode utilisateur et en mode root sans changement


#13

Tu peux purger xfce4-xkb-plugin, fermer la session et le réinstaller ?


#14

Pour la commande Print, voilà le résultat:
xkb_keycodes { include “evdev+aliases(azerty)” };
xkb_types { include “complete” };
xkb_compat { include “complete” };
xkb_symbols { include “pc+fr+inet(evdev)” };
xkb_geometry { include “pc(pc105)” };


#15

purger puis ré-installer… en mode console root, je suppose. Ça signifie quelles commandes???


#16

Déjà, supprime le plugin de ton tableau de bord.
Tu dis n’utiliser qu’un agencement de clavier Français, alors ce plugin ne te sert à rien.

Non, de préférence avec sudo et dans un terminal.

sudo apt -s remove --purge xfce4-xkb-plugin

Le -s provoque une simulation.

https://packages.debian.org/buster/xfce4-xkb-plugin


#17

Réponse: Impossible de trouver le paquet xfce4-xkb-plugin


#18

Alors ce n’est pas celui-ci dont tu disposes.
Supprime donc de ton tableau de bord cet affichage de disposition de clavier inutile…

Aurais-tu utilisé la même image d’installation pour ces tests ?

Il y a manifestement un bug.
Inutile d’insister tout de suite.


#19

Via synaptic, en mode graphique donc, le paquet xfce4-xkb-plugin est installé. Je l’ai donc supprimé et incidemment le paquet des goodies associé. J’ai redémarré et j’ai toujours mon icône en anglais ainsi que paramètres/claviers/disposition.
Le mystère s’épaissit.
En cherchant parallèlement, quelqu’un qui cherchait à mettre en place un 2ème utilisateur dans une autre langue fait référence à un fichier .xsessionrc.
J’ai cherché dans mon répertoire Home pour y trouver 2 fichiers .xsession: l’un version -errors, l’autre version -errors.old. On y trouve bien le français paramétré mais cependant une alerte

xfce4-session-Message: 18:25:52.548: SSH authentication agent is already running
gpg-agent[949]: Attention : « --write-env-file » est une option obsolète — non prise en compte
gpg-agent: une instance de gpg-agent fonctionne déjà —
pas de démarrage d'une nouvelle instance

(xfce4-session:903): xfce4-session-WARNING **: 18:25:52.574: gpg-agent returned no PID in the variables

#20

J’expliquais ça aussi dans ce message

mais il n’y a aucun lien entre
les variables des paramètres régionaux (retournés par la commande locale)
et la disposition du clavier