Debian 9 (Stretch) Net Install avec Chipset Intel Z390

stretch
installation
Tags: #<Tag:0x00007fa94b5a00e0> #<Tag:0x00007fa94b5a7bb0>

#1

Bonjour,

A l’installation de Debian 9 via la version “Net Install”, le setup recherche le chipset LAN présent, puis qu’ici, il s’agit d’une instalation en réseau. Or, je dispose d’une carte mère récente dont le chipset LAN est un Intel Z390. Malheureusement, il n’est ni détecter par le setup de Stretch, ni proposé dans la liste des chipset LAN. Quelqu’un aurait-il une solution de contournement ?

Bonne Journée

Tux38


Debian 9 impossible à installer sur LDLC Aurore, bug d'affichage de l'installateur
#2

As tu un livecd qui reconnaisse ton chipset ?
N’importe quelle distrib, pas forcément debian.
Tu peux faire une install en chroot+debootstrap:
https://debian-facile.org/doc:install:debootstrap-chroot
Ca se fait.


Debian 9 impossible à installer sur LDLC Aurore, bug d'affichage de l'installateur
#3

Salut :wink:
Quel est le modèle de ta carte mère ?


#4

Hello Mattotop,

Bonne idée de passer par un CD-Live. J’en ai testé 3 distribs :

  • Debian 9.8.0 - amd64 => couche réseau non fonctionnelle, si je ping ma passerelle, je n’ai pas de réponse ainsi que sur un broadcast. La seule réponse se fait sur le localhost (127.0.0.1).
  • Ubuntu 18.10 Fr => C’est encore pire, je n’ai aucun affichage, visiblement la nouvelle gamme des chipsets RTX de chez Nvidia n’est pas gérée !!!???
  • KNOPPIX 8.2 En => Parfait ! la disrib KNOPPIX a toujours était reconnu pour la richesse de ses pilotes. Réputation mérité ici, car tout est reconnu et parfaitement opérationnel. Aussi, je vais partir sur cette distrib qui est basée sur le système de paquets de Debian ;o)

Merci pour ton aide, dans l’espoir quelle a été utile à d’autres.

Cordialement


Debian 9 impossible à installer sur LDLC Aurore, bug d'affichage de l'installateur
#5

Hello gadolb,

Ma carte mère est précisément une MSI MPG Z390 GAMING EDGE AC.
C’est pas mal, mais le chipset de chez Intel (Z390), gère tous les IO du sol au plafond, dont le LAN. Et ça c’est moins bien ;o(

Cordialement


#6

A première vue, la partie réseau est gérée par un Intel i219-v et ce n’est pas pris en charge par debian stretch.

Donc soit tu installes Buster et la ça passe.

Soit tu fais une installation avec l’ISO normal de Stretch et à la fin de celle-ci, tu compiles les pilotes Intel

Plus d’infos ici :

:wink:


#7

Hello Gadolb,

J’ai testé une Buster RC1 (Net Install), ça a été comme sur du velours.
Aucun problème d’installation :o)
Dans l’espoir que cela sera utile à d’autres.
Merci encore pour tes suggestions pertinentes.

Tux38


#8

Hello Tux38

Tu voudrais bien donner l’adresse de l’iso CD ?
C’est bien https://cdimage.debian.org/cdimage/unofficial/non-free/cd-including-firmware/buster_di_rc1+nonfree/amd64/iso-cd/ ?
Merci


#9

Je t’en prie Tux38.
Ca m’a fait plaisir d’aider :wink:

Bonne continuation sous Debian :wink:


#10

Hello r2mi,
Selon la page suivante :
https://wiki.debian.org/fr/DebianTesting
La Buster correspond à la version testing (future stable).
Aussi, je l’ai trouvée à la page suivante :
https://cdimage.debian.org/cdimage/weekly-builds/amd64/iso-cd/
sous le nom de :
debian-testing-amd64-netinst.iso
Dans l’espoir que cela puisse aider ;o)

Tux38


#11

Hello gadolb,

Pour info et pour être complet, j’ajoute une précision :
En réalité la Buster ne fournit pas le pilote du NIC Intel i219v. Et pourtant, j’ai bien du réseau !
Après investigations, il se trouve que le chipset Z390 d’intel, intègre un chipset NIC, mais aussi un chipset wifi AC, il s’agit d’un intel AC9462, et c’est ce dernier que Buster reconnait. Résultat, j’ai une unique interface de reconnue dans ma Debian (eno2), inversement la classique eth0 des NIC est absente ;o(
Voila, je crois ne rien avoir oublié.

Tux 38


#12

Merci Tux38 :slight_smile:

Je comprends mieux la question que je me posais en lisant sur : https://cdimage.debian.org/cdimage/weekly-builds/amd64/iso-cd/

This is an official Debian image build and so only includes Free Software.

For convenience for some users, there is an alternative unofficial netinst CD build which includes non-free firmware for extra support for some awkward hardware. Look under /cdimage/unofficial/non-free/cd-including-firmware/ if you need that CD image instead.

@jpages ayant résolu un problème d’installation d’un portable récent avec l’iso DVD de :

https://cdimage.debian.org/cdimage/unofficial/non-free/cd-including-firmware/buster_di_rc1+nonfree/amd64/iso-dvd/

Je voulais me tenir mieux au courant à propos des différentes images.

Merci encore,
C’est plus clair :slight_smile:

Tu l’aurais peut-être eu avec une iso Buster en version unofficial/non-free/cd-including-firmware


#13

C’est une excellente question !
Je suis déjà en train de charger la version unofficial/non-free, histoire de faire le test, et d’être enfin fixé sur la réponse à apporter. Je ne pourrai pas faire la manip avant fin de semaine (cause boulot). Mais je ne manquerai pas d’apporter la réponse sur le forum ;o)

Tux 38


#14

Salut Tux38,
Désolé pour la reponse tardive, beaucoup de boulot depuis quelques semaines.
Qu’est ce qu’ont donné tes tests avec la version non-free ?

Pour revenir sur ce que tu me disait dans le post 10, je pense (et j’espère ne pas dire de bétises) que les drivers pour le NIC Intel i219v sont intégrés au noyau.

Ta carte mère a bien 2 interfaces réseau (RJ45 et Wifi) donc en installant le firmware iwlwifi, tu aurais du avoir les 2.

Concernant le nom eth0, sur mes dernières install de debian, je n’ai jamais eu ca. Les cartes réseau ont souvent pour nom du genre “enp1s0”


#15

Hello gadolb,

Pas de souci pour le délai de ta réponse. A vrai dire, j’ai moi même été débordé par mon boulot. J’ai donc pu faire des tests de Debian sur mon nouveau matériel que très récemment ;o(
En fait, pour résumer . J’ai réalisé 4 tests d’installation avec une carte mère équipée du dernier chipset intel (Z390) :

  • Installation en net install de Stretch dans une V.M, sur un host Windaube 10.
  • Installation en net install de Stretch sur le poste physique.
    -Installation en net install de Buster dans une V.M , sur un host Windaube 10.
  • Installation en net install de Buster sur le poste physique.
    Dans les 2 cas d’installation via une V.M les connexions réseau ( filaire et wifi), sont parfaitement fonctionnelles. Ce qui est normale, car en réalité la configuration réseau des V.M étaient en mode pont. Ainsi, la couche réseau est totalement gérée par le pilote Windaube, qui je dois reconnaitre est tout à fait opérationnel.
    En revanche, pour l’installation de Stretch sur le poste physique. La net install s’arrête lors de la recherche d’une carte réseau, ce qui est logique, et ne permet donc pas d’installer Stretch. Concernant l’installation de Buster sur poste physique, la net install arrive à son terme. Néanmoins, seul la partie wifi est fonctionnel et pas la connexion filaire ;o(
    Après recherches, il s’avère que le chipset Z390 d’intel intègre 2 circuit réseau :
  • Un NIC I219-V, qui est un circuit LAN filaire.
  • Un AC 9462, qui est un circuit wifi AC.
    Buster intègre donc le pilote de l’AC 9462, mais pas du NIC I219-V. Toutes mes connexion réseau sous Buster se font donc exclusivement en wifi ;o(
    Pour le nom eth0, de mémoire, je l’ai connu depuis Woody (Debian 3), et jusqu’à Jessie (Debian 8). Depuis Stretch (Debian 9), j’ai pu noté des modifications importantes, la modification du nom par défaut de la NIC en est une.

Cordialement

Tux38


#16

Hello gadolb,

Ouuuups ! J’oubliais le retour des tests de la version non free :
En net install dans une V.M , avec un host en Windaube 10, cela fonctionne très bien. En revanche, en net install sur un poste physique j’ai un bel écran tout noir dès le début de l’installation. Aussi, comme j’ai pu m’en sortir avec la version officiel de Buster, je n’ai pas poussé plus loin les investigations.

Cordialement

Tux38