En français, il y a une espace entre le dernier mot et l'interrogation (?) ou l'exclamation (!)

Tags: #<Tag:0x00007ff8b85d5d50> #<Tag:0x00007ff8b85d5be8> #<Tag:0x00007ff8b85d59b8> #<Tag:0x00007ff8b85d5800>

Bonjour,

J’ai eu beau essayer de mettre une espace ; même une espace insécable,
à la fin du titre du sujet posté, et ce avant le point d’interrogation final :

Le signe ? colle “à l’anglaise ou à l’américaine ?” au dernier mot du sujet.

Pour mon exemple, je cherche à obtenir : « Guix : un outil pour les remplacer tous ? »

Et non : « Guix : un outil pour les remplacer tous? »

Je ne revendique pas un “droit” pour “mon” sujet mais simplement un respect de l’écriture de notre langue.

Je ne voudrais pas te déranger @ed, mais vraiment ça pique les yeux…

Salut,

Pareil pour “un espace” dans ton titre, d’autant plus qu’apparemment, d’après ton texte, tu fais partie des rares personnes qui savent qu’en typographie “espace” est féminin :wink:

2 J'aimes

Bonjour

Je viens d’ajouter un caractère espace insécable dans le titre du fil
Guix : un outil pour les remplacer tous ?
juste avant le point d’interrogation.

Sur mon système, pour entrer un caractère espace insécable (NO-BREAK SPACE)

j’utilise le raccourci AltGr+maj+espace

ou alors, Ctrl+maj+u puis j’entre le point de code unicode a0

2 J'aimes

Salut Arnaud et MicP

L’appartenance à cette minorité fait qu’il m’est encore difficile d’employer le genre “savant”
Je suis surpris souvent encore par mon incertitude et mon doute aussi.
Genre pour éviter de se faire remarquer peut-être…

J’avais essayé un copier coller d’une sélection d’une espace insécable depuis Wikipédia…
Ça n’a pas marché.

Merci MicP pour la correction et l’enseignement des méthodes.

édition :
J’ai trouvé la composition de l’espace insécable pour la configuration de mon clavier Mac M7803.

Une autre manière de gérer les caractères unicodes est de se tourner vers XCompose ou l’équivalent ; càd les fameuses touches de composition. :wink:

Bonjour,
Espace devant un ? ou un !
Libre Office WRITER le fait par défaut. C’est expliqué quelque part dans son Aide.
Voir Outils/Auto correction/Options d’autocorrection/Onglet Options linguistiques.
C’est à la première ligne, coché par défaut.
Bien à vous.

1 J'aime

C’est discouse qui fait le trim automatiquement, je ne peux pas y faire grand chose.

2 J'aimes

D’accord ed :slight_smile:

Merci de t’être penché sur la question et pour ta réponse.

On va faire avec donc !

2 J'aimes

Salut,

Je viens d’essayer (pour mettre une espace insécable avant un : ). Ça fonctionne bien dans la fenêtre d’édition, mais quand je valide le post, une espace normale revient, et le : se retrouve à la ligne suivante…

Bon, c’est peut-être lié à ce problème que je n’ai jamais pris le temps d’étudier. Mais j’aurais aimé savoir si quelqu’un d’autre que @MicP a tenté de mettre des espaces insécables avec ce raccourci clavier ?

Peut-être que le choix de la configuration de l’agencement du clavier du clavier
ne permet pas d’entrer un caractère espace insécable.

On peut vérifier quel est le caractère effectivement entré en visualisant la valeur hexadécimale du caractère entré :

michel@debg53sw:~$ echo -n " " | hd   # Là, j'ai entré un simple caractère espace entre les guillemets
00000000  20                                                | |
00000001
michel@debg53sw:~$ echo -n " " | hd   # Là, j'ai entré un caractère espace insécable entre les guillemets
00000000  c2 a0                                             |..|
00000002
michel@debg53sw:~$ 

Mais quoi qu’il en soit, c’est vrai qu’un caractère espace insécable entré dans la fenêtre d’édition est automatiquement transformé en caractère espace normal.

2 J'aimes

Ok, donc pas la peine de chercher plus loin ! Mais du coup, on a une solution pour que les : ! ? ne soient pas tout seuls sur une ligne dans les posts ?

J’essaie de passer à la ligne élégamment avant la marge droite…

C’est une solution effectivement. Mais si tu fais “entrée”, ça casse la justification automatique, et si tu refais une modif plus haut, il faut penser à enlever ton passage à la ligne…

Quelqu’un a mieux ?

Bonjour,

Ça n’a pas tenu la nuit. Dommage.
Pour ma part, je laisse tomber maintenant ces questions typographiques.

Discourse est mal régionalisé et puis c’est tout.

Merci encore

Salut,

:laughing:
C’est vrai que Discourse a de bons côtés, mais aussi de gros défauts pénibles !

Mais bon, c’est du LL : soit on participe et on améliore, soit on accepte de faire avec. Malheureusement, on n’a pas toujours le temps, l’envie ou les moyens de participer à l’amélioration de tous les LL qui le mériteraient…

Effectivement …Désolé.
Je viens de tenter une “bidouille”,
on verra combien de temps ça va tenir…