Gnome 3.20 / changement pilote périphériques d'entrée


#1

Bonsoir à tous,

Bon ce sujet n’est pas une question mais plutôt un avertissement pour celles et ceux qui sont passés sous Gnome 3.20 ou qui vont y passer (notamment ceux qui sont sous Unstable).

Depuis une mise à jour récemment j’avais perdu la fonctionnalité de mon touchpad sur laptop, mais bon étant donné que je ne m’en sers pas je ne m’en suis pas préoccupé non plus jusqu’à maintenant (j’ai une souris sans fil). Mais bon comme j’aime pas laisser traîner quelque chose qui marchait bien et qui ne marche plus tout à coup, je me suis finalement penché sur le problème.
Et bien sûr j’ai trouvé la solution… :smiley:, que je viens partager avec vous, ça fera gagner du temps à d’autres :wink:

Alors il se trouve que Gnome 3.20 a abandonné le pilote xserver-xorg-input-synaptics, celui-ci n’étant plus maintenu d’après ce que j’ai pu comprendre… Il est remplacé par xserver-xorg-input-libinput.
Néanmoins on peut faire fonctionner encore le pilote synaptics par la méthode classique en copiant le fichier /usr/share/X11/xorg.conf.d/XX-synaptics.conf vers /etc/X11/xorg.conf.d/ et en adaptant les options dont on a besoin.

Mais bon, autant passer à celui qui sera maintenu par la suite et s’adapter le plus tôt possible. Ils peuvent parfois cohabiter, mais si comme moi vous avez un souci désinstallez le pilote synaptics et ne gardez que le pilote libinput. Petite précision chez moi libinput n’était pas installé automatiquement lors de la mise à jour en question et synaptics ne marchait plus, si c’est le cas chez vous vérifiez s’il est installé et le cas écheant installez le manuellement :

apt-get install (ou aptitude) xserver-xorg-input-libinput

Et là, miracle, les options pour le touchpad réapparaissent dans le menu de configuration Préférences de Gnome (il va peut-être vous falloir redémarrer ou simplement réouvrir votre session).
Mais il n’y pas encore toutes les options affichées : réglages multitouch, edge scrolling, …

Alors pour gérer celà, il vous faudra installer encore un paquet :

apt-get (ou aptitude) install xinput

Ce paquet vous permet de gérer en ligne de commande les différentes options à passer à libinput pour prendre en charge les réglages cités ci-dessus.
Je n’ai pas exploré le manuel entier mais je retiens les deux commandes suivantes comme fondamentales :

xinput list
vous permet de lister les périphériques et leur ID

xinput list-props XX
vous permet de lister les options disponibles et/ou actives pour le périphérique dont l’ID est XX

xinput set-prop
[i]vous permet de modifier les valeurs de ces options conformément au manuel de libinput (pour voir les options consulter “man libinput”)
device-id correspond à l’ID du périphérique
prop-id correspond à l’ID de l’option entre parenthèses
prop-values correspond aux valeurs que peut prendre l’option (au format “x, y” ou “x, y, z”, attention à l’espace après la virgule).

Voilà, pour les détails je vous invite à consulter les man.


Pas de rubrique pavé tactile dans Gnome-control-center [Résolu]
#2

Bonsoir,

xserver-xorg-input-libinput semble avoir disparu de la circulation mais merci pour Xinput…que je vais solliciter illico.


#3

Bonjour plutôt :stuck_out_tongue:
À moins qu’on soit en décalage horaire… :smiley:

xserver-xorg-input-libinput n’est présent que dans les dépôts testing et unstable (sid), si tu es en stable, vois s’il est éventuellement dans les backports de Jessie…

xinput est juste un outil de configuration, ce n’est pas un driver.

EDIT : je viens de vérifier, il n’est pas présent dans les backports.