Impossible de se connecter sur internet


#1

Bonjour,
Je debute avec debian et je rencontre un probleme de connexion avec internet; en fait je n’arrive pas à me connecter. Je ne sais pas si je suis bien configuré où si mon probleme se situe ailleurs.
Mon portable est un Asus A6000.
Pour me connecter j’ai recensé les cartes suivantes:
Cartes reseaux

  • Realtek RTL 8139/810x Family Fast Ethernet NIC
  • Intel ® Pro/Wireless 2200BG Network connection
  • Intel ® Pro/Wireless 2200BG Network Connection- Intel Wireless connection agent miniport
  • Carte reseau fast ethernet PCI Realtek RTL 8139 family-miniport d’ordonnacement de paquets
  • carte reseau 1394

Cartes PCMCIA :

  • Controleur cardbus R/RL/SC476 (II) ou compatible

J’ai lu que pour relier une machine à un reseau, la 1er chose à faire est de charger le driwer permettant le dialogue avec la carte, puis ensuite configurer l’interface.

Si quelqu’un peut m’aider pour que je puisse acceder à internet avec debian ce serait très sympa car depuis 1 mois je patauge la-dedans
La version de debian installé est la V3.1 ROa i386. J’ai acheté les 14 CD debut août
Merci d’avance



#2

Salut,
Comment veux tu te connecter à internet, tu veux te brancher sur un reseaux local qui dispose déja d’internet ? tu veux brancher ton modem usb direct à ta debian ? … Si c’est un reseau local, quels en sont les caractéristiques (DHCP, IP FIXE, DNS ?)

More precision …


#3

Essayes déjà lspci pour détecter ton matos.
Ensuite lsmod pour voir les modules qui sont chargés et envoyes-nous le résultat des commandes


#4

[quote=“jabba”]Essayes déjà lspci pour détecter ton matos.
Ensuite lsmod pour voir les modules qui sont chargés et envoyes-nous le résultat des commandes[/quote]

Bonsoir Jabba,
J’ai lancé lspci et voici le resultat :
B UHCI Controller # (rev 03)
0000:00: 1d. USB Controller : Intel Corp. 82801DB/DB2/DBM (ICH4/ICH4-L/ICH4-M)
USB UHCI Controller #2 (rev 03)
0000:00: 1d.2 USB Controller : Intel Corp.82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 (rev 03)
0000:00: 1d.7 USB Controller : Intel Corp. 82801DB/DBM (ICH4/ICH4-M) USB 2.0 ECHI Controller (rev 03)
0000:00: 1e.0 PCI bridge : iNTEL cORP. 82801 PCI Bridge (rev 03)
0000:00: 1f.0 ISA Bridge : Intel Corp. 82801 DBM LPC Interface Controller (rev 03)
0000:00:1f.1 IDE interface: Intel Corp.82801 DBM(ICH4) Ultra ATA Storage Controller (rev 03)
0000:00:1f.5 Multimedia audio controller: Intel Corp. 82801 DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC’97 Audio Controller (rev 03)
0000:00: 1f.6 Modem : Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC’97 Modem Controller (rev 03)
0000:01:00.0 VGA compatible controller : ATI Technologies INC RV 350 [Mobility RADEON 9600 M10]
0000:02:00.0 Ethernet Controller : Realtek Semiconductor Co., Ltd. RTL_8139/8139C/8139+ (rev 10)
0000:02: 04.0 Network Controller : Intel Corp. Pro/Wireless 2200 BG (rev 05)
0000:02 : 05.0 Cardbus Bridge : Ricoh Co Ltd RL5C476 II (rev ac)
0000:02: 05.1 Cardbus Bridge : Ricoh Co Ltd RL5C476 II (rev ac)
0000:02:05.2 Firewire (IEEE 1394): Ricoh Co Ltd R5C552 IEEE 1394 Controller (rev 04).

Voici pour la commande lsmod :
commoncap 7168 1 capability
s2_mod 15780 0
tsdev 7168 0
monsedev 9996 0
joydev 9536 0
sbp2 22408 0
evdev 9088 0
scsi_mod 115148 2 sr_mod, sbp2
ieee 1394 100408 3 eth1394, ohci 1394, sbp2
psmouse 17800 0
ide_cd 38176 0
cdrom 35740 2 sr_mod, ide_cd
ext3 109672 1
jbd 54552 1 ext3
ide_generic 1664 0
piix 12448 1
ide_disk 16768 3
ide_core 125028 4 ide_cd, ide_generic, piix,ide_disk
unix 26036 370
font 8576 0
vesaf b 6688 0
cfbcopyarea 3840 1 vesaf b
cfbimgblt 3200 1 vesaf b
cfbfillrect 3712 1 vesaf b

Voilà le resultat des 2 commandes.
Si tu peux m’aider ce serait magnifique
Merci d’avance


#5

slt,

tu “modprobe” le module ou ta carte est branché, ensuite si tu utilise dhcp tu lançe “dhclient”…sinon si tu es en statique tu edite ton fichier /etc/network/interfaces pour plus d’info “man interfaces” puis pour finir le fichier /etc/resolv.conf et tu y met tes servers dns…“man resolv.conf”…


#6

[quote=“stonfi”]slt,

tu “modprobe” le module ou ta carte est branché, ensuite si tu utilise dhcp tu lançe “dhclient”…sinon si tu es en statique tu edite ton fichier /etc/network/interfaces pour plus d’info “man interfaces” puis pour finir le fichier /etc/resolv.conf et tu y met tes servers dns…“man resolv.conf”…[/quote]

Bonsoir stonfi,
Si tu peux m’expliquer plus clairement ce que je dois faire car je débute et je suis vraiment novice.
Merci pour ton aide


#7

slt,

ta conf,

  • Realtek RTL 8139/810x Family Fast Ethernet NIC
  • Intel ® Pro/Wireless 2200BG Network connection
  • Intel ® Pro/Wireless 2200BG Network Connection- Intel Wireless connection >agent miniport
  • Carte reseau fast ethernet PCI Realtek RTL 8139 family-miniport >d’ordonnacement de paquets
  • carte reseau 1394

la carte avec laquel tu es relié a ton lan…si c’est la Realtek :

modprobe 8139cp

si tu n’aie pas sur :
#cd /lib/modules/kernel/drivers/net

modinfo 8139cp.o

a condition de l’avoir, en general une installation generique autrement dit de base tu l’as…

si ce n’est pas la realtek mais une autre tu suis la meme procédure…

apres cela ton module est chargé autrement dit ta carte est reconnue par ton kernel un coup d’ifconfig -a te le confirme…

#ifconfig -a

cela devrait t’afficher eth0 et lo… sans ip
apres si tu utilise un adressage dynamique (dhcp) tu lançe la commande dhclient…

#dhclient

a ce moment si dans ton lan tu as un serveur dhcp il te file une conf reseaux a savoir ip/passerelle/dns

sinon si tu utilise un adresse statique, tu doit donc connaitre la classe reseaux utiliser dans ton lan soit A, B, ou C tu edite le fichier /etc/network/interface et renseigne les champs suivant…

#vi /etc/network/interfaces

[code]

The loopback network interface

auto lo
iface lo inet loopback

The primary network interface

auto eth0
iface eth0 inet static
address 192.168.1.41
netmask 255.255.255.0
gateway 192.168.1.1
network 192.168.1.0
up route add -net 172.17.0.0 netmask 255.255.0.0 gw 192.168.1.2 dev eth0
down route del -net 172.17.0.0 netmask 255.255.0.0 gw 192.168.1.2 dev eth0[/code]

bien-sur en ajustant selon ta config autrement la classe d’adresse…ensuite tu restart le network…

#/etc/init.d/networking restart

et pour finir tu peut mettre les ip des dns pour accélerer tes requete , tu peut mettre ceux de ton provider ou ce de ton serveur dns si tu en as un dans ton lan…

nameserver 194.2.0.66
nameserver 194.2.0.67

et voila roule et jeunesse…


#8

Bravo, il ne vous a pas dit par quoi il veut se connecter (RTC, ADSL, Réseau) et vous arrivez à lui dire que faire :laughing:


#9

Bonjour,
Effectivement je veux me connecter en ADSL wifi sans fil. Aidé moi pour que je puisse me connecter sur internet avec debian. J’ajoute que cje suis sur un portable avec technologie centrino et qu’à coté de debian est installé windows dont la connexion internet fonctionne tres bien; d’ailleurs c’est avec xp que je vous poste ces messages.
J’ai une grande envie d’utiliser debian mais sans acces internet je me vois privé d’un moyen de progresser.
Aidez moi s’il vous plait.
Merci d’avance


#10

Pour la connection wifi, il te faut soit les drivers prism soit ndiswrapper tout dépend de ton matériel.

Il faut d’abord que tu regarde avec quel driver ton matériel est compatible. Pour ndiswrapper tu peux regarder la ndiswrapper.sourceforge.net/medi … x.php/List

Pour prism je ne me souviens plus. Une fois que tu sais quel drivers est utilisé pour ta carte tu l’install.

Pour ndiswrapper tu utilise les drivers windows


#11

Les drivers centrino éxistent pour linux, par contre j’ai peur que ça ne soit pas super facile à faire marcher pour un noob.
En fait, il va falloir compiler le driver toi-même; Le premier bon point, c’est que les sources du driver éxistent dans l’arbre Debian.
Donc, pour commencer, il va falloir installer les headers de ton kernel. Pour savoir quelle est la version de ton kernel, fait un

Puis, pour installer les headers :

Ensuite, pour me faciliter la vie lorsque je dois compiler un driver se trouvant dans l’arbre Debian, j’utilise généralement module-assistant. Donc je te conseille fortement de l’installer :

Ensuite, lance module-assistant, fait un UPDATE, puis PREPARE et va ensuite dans le menu SELECT. Là, choisit le module ipw2200 (c’est le driver qui correspond à ta carte, fait OK, puis GET, BUILD et INSTALL.
Tu peux ensuite quitter module-assistant, et faire un modprobe ipw2200 pour charger le module fraîchement installé.
si tout s’est bien passé, Normalement tu devrais avoir une interface wlan0 quand tu fais un

Essaye déjà ça, on verra ensuite pour la conf de l’interface, c’est pas bien dur.


#12

pour trouver les paquets deb des sources d’ipw :
ftp.de.debian.org/debian/pool/contrib/i/ipw2200/

ensuite il faut faire comme BobX a dit, sauf qu’il faut appliquer un patch. je ne peux que te conseiller d’aller sur :
ipw2200.sourceforge.net


#13

Pas besoin d’appliquer un quelconque patch, ni de télécharger des quelconques sources par ses propres moyens, module-assistant s’occupe de tout :wink:


#14

Re,
Je veux bien telecharger quelconque paquet mais si je n’ai pas accés à internet avec debian comment je fais ? Puis je telecharger sur windows ?
Si l’on peut m’expliquer car je suis perdu.
Merci


#15

T’inquiétes, les sources dont tu as besoin doivent être sur les cd d’install normalement.
Fait un apt-get install ipw2200-source et voit ce qui se passe


#16

Re salut bobx,
J’ai fait les manips que tu m’as dit. Mon noyau est 2.6.8-2-386. Tout s’est bien déroulé sauf qu’à un moment quand j’ai fait install ou build avec le module assistant il m’est apparu un message comme quoi il manque un micro code.
J’ai fait un modprobe ipw 2200 et je te soumets le resultat :

ipw 2200 : Intel ® PRO/Wireless 2200/2915 network driver, 1.0.3
ipw 2200 : Copyright © 2003-2004
ACPI : PCI interrupt 0000:02:04 [A] GSI18 (level,low) IRQ185
ipw 2200 : detected intel PRO/Wireless 2200 BG Network connection
ipw 2200 : ipw-2.2-boot. fw load failed : reason -2
ipw 2200 : unable to load firmware : 0xFFFFFFFE
ipw 2200 : failed to register network device
ipw 2200 : probe of 0000:04.0 failed with error -5

Par aiileurs qd je lance ipconfig -a , cette commande ne fonctionne pas. J’ai le message " coomand not found"
Merci de m’aider car je voudrai tant y arriver


#17

[quote]Par aiileurs qd je lance ipconfig -a , cette commande ne fonctionne pas. J’ai le message " coomand not found"
Merci de m’aider car je voudrai tant y arriver[/quote]

Normal, la commande c’est ifconfig :wink:
Pour l’erreur au chargement du module, ça me semble bizarre. Il détecte bien la carte, mais il n’arrive pas à charger le firmware, je vais voir ce que je peux trouver là-dessus de mon côté


#18

personnellement, j’ai trouvé[quote=“http://ipw2200.sourceforge.net/”]Issues
Firmware files fail to load even if installed
In some kernel configurations (users have most frequently reported the problem only with 2.6.9), the default timeout value for the hotplug subsystem is too low. You may have this problem if you see the following in your kernel log (via dmesg or /var/log/messages):

ipw2200: Intel® PRO/Wireless 2200/2915 Network Driver, 1.0.1
ipw2200: Copyright© 2003-2004 Intel Corporation
ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
ipw2200: ipw-2.2-boot.fw load failed: Reason -2
ipw2200: Unable to load firmware: 0xFFFFFFFE
ipw2200: failed to register network device
ipw2200: probe of 0000:00:0b.0 failed with error -5

To work around this, you can increase the default timeout value:

echo 100 > /sys/class/firmware/timeout

and then reload the ipw2200 module. If this corrects your problem, you may wish to add the above line to your system startup scripts prior to the point at which the driver module would be loaded.

The other most common reason for getting the above error is that the firmware files are not installed in the correct location. Please see the INSTALL document for information on installing the firmware files. [/quote]
autrement dit, tu essayes le tweak du timeout qu’ils indiquent, si ca marche, tu le configures dans /etc/sysctl.conf (avec un peu de chance).
Sinon, il faut trouver un firmware à charger avec le module. Il est souvent dans les pilotes windows.
Comment on fait dans ce dernier cas, je ne sais pas.


#19

[quote=“MattOTop”]
Sinon, il faut trouver un firmware à charger avec le module. Il est souvent dans les pilotes windows.
Comment on fait dans ce dernier cas, je ne sais pas.[/quote]

A ce que j’ai trouvé, dans le dernier cas, on télécharge le firmware ici : ipw2200.sourceforge.net/firmware.php
Puis on le dépose dans /usr/lib/hotplug/firmware/


#20

est ce que je telecharge firmware à partir de windows et je l’installe à partir de windows; dans le cas contraire comment puis je faire pour telecharger ce firmware?