Impossible d'installer le module nvidia


#1

Sur les bons conseils d’Ashgenesis, je clos ce topic mal dénomé: forum.debian-fr.org/viewtopic.php?t=2226, pour insister un peu sur celui-ci, car j’ai une piste.
Hier j’ai compilé un noyau 2.6.12, ensuite j’ai fais:
m-a auto-install nvidia-kernel-source
j’ai enfin obtenu un paquet nvidia-kernel que j’ai installé.
J’ai mis nvidia dans mon xorg; nvidia present aussi dans /etc/modules
Reboot, et echec mais avec ce message:
the NVIDIA kernel module is version 1.0.8718, but the X module is version 1.0.7174. Please be sure that you kernel module and all NVIDIA driver files have the same driver version.[/url]


#2

on est passé en ce jour au kernel 2.6.15 en debian testing/etch.

comme d’hab, au changement de kernel mes drivers nvidia n’allaient plus.

j’ai donc suivi les instructions habituelles

mais (lol) j’ai eu un message “bad luck … machin brole” (dans le meme genre que toi).

j’ai du faire un module-assistant prepare qui m’a téléchargé nvidia-kernel-2.6.15-1-686 en version 1.0.8178-1+2.6.15-4 depuis le depot unstable/sid de debian.

et après cela, le traditionnel

m-a a-i -i -t -f nvidia-kernel depmod -a
a bien fonctionné!

me v’là donc sous linux 2.6.15 avec les drivers nvidia 1.0.8178 …

en esperant que cela puisse t’aider??


#3

harf mon appart est construit sur un cimetière indien c’est sur, :laughing: .
J’ai fait la même chose que toi, obtenu un paquet nvidia-kernel 2.6.15. Reconfiguré xorg en mettant nvidia, modprobe nvidia, puis lsmod qui me dit qu’il est bien chargé.
Je reboot et pan pas de demarrage graphique. J’insiste avec de nouveau modprobe, mais rien à faire toujours ce message me signalant: the NVIDIA kernel module is version 1.0.8718, but the X module is version 1.0.7174. Please be sure that you kernel module and all NVIDIA driver files have the same driver version.
Retour avec nv, et me vlà, :laughing: .


#4

une idée comme ça:
apt-get install xserver-xorg --reinstall


#5

non Mat, malheureusement c’est idem. Mais à mon avis c’est bien du coté de xorg que ça coince. Il n’a pas moyen de remettre xfree86?


#6

un peu radicale, non? …

certain que tu n’as pas le bon nvidia-kernel, c’est tout.

essaie de choper celui qui est en unstable.

et puis recommence :smiley:

@+


#7

mais c’est dejà ce que j’ai fais, et toi aussi je crois?


#8

au fait, ta version nvidia-glx correspond bien aussi??


#9

[quote=“yo4”][quote=“ghostintheshell”]
certain que tu n’as pas le bon nvidia-kernel, c’est tout.
essaie de choper celui qui est en unstable.
[/quote]

mais c’est dejà ce que j’ai fais, et toi aussi je crois?[/quote]

vi tout a fait.

enfin, bon, ça c’est fait automatiquement avec module-assistant prepare


#10

nvidia-glx 1.07174-4, version installée. Les depots sid propose une 1.0.8178-1. Hum ça sent bon ça, non?


#11

plutot oui :wink:

[EDIT] je confirme, c’est bien cette version :wink: apres l’installation, tu refais ton brole et ca devrait rouler :smiley:


#12

ho putàç"èy$ dediou, j’ai ecran noir de chez noir, rien, nada, même pas une tite ligne de commande, :laughing: :laughing: :laughing: !

C’est bon mon 2.6.12 a bien voulu m’offrir une tite ligne de commande, et donc retour en nv, :laughing: .


#13

:smiley:


#14

Tu comprends ma radicalité now, :wink: ?


#15

ah les joies de la compilation manuelle de son noyau …

apt-get install linux-image-2.6-686 + forum.debian-fr.org/viewtopic.php?t=1682 et yop la boom 8)


#16

ça roule je test ça bientot, juste pour voir, :laughing: , et puis voir le logo propriétaire sur cet ordi est devenu une affaire des plus personnelles, :stuck_out_tongue: .


#17

Rien à faire, je prend rencart avec un marabout!


#18

Bon on va terminer cette histoire. Je viens d’installer une sarge, avec xfree86 donc, et le resultat c’est ecran noir. Je penche pour un souci avec ma carte vidéo, genre incompatibillité, malediction, etc…,car sur mon autre pc en sarge, le driver nvidia s’installe les doigts dans le pif.
Quelqu’un penche-t-il dans le même sens que moi?


#19

cf explication dans ce fil: forum.debian-fr.org/viewtopic.php?p=16630#16630


#20

Merci Mat. Je retenterai en sid, bien que j’ai un peu tout tenté, :laughing: . Install d’une sarge, puis dist-upgrade en testing, puis en unstable, :laughing: .

ps: dans mon cas sur ce pc, ça ne fonctionne même pas en sarge, donc je seche beaucoup.