Install noyau 2.6.9 de kernel.org: pas simple


#1

Bonjour,
je suis parti à essayer d’installer un 2.6.9 pèché sur kernel.org, en attendant des sources officielles debian.
Ben c’est pas gagné :cry: :
le ‘make-kpkg debian’ se passe normalement, un commentaire affiché précise même qu’il corrige “des idioties ajoutées dans les versions précèdentes des sources debian” :laughing: .
Ensuite, aprés importation du .config de ma 2.6.8, le ‘make oldconfig’ me permet d’activer qques nouveaux modules, et surtout, demande un ‘nom de release’ qui soit disant doit être concatènée quelque part (effectivement, ca apparait dans le nom du répertoire des modules, mais on verra plus tard): tjs pas de pb.
et c’est la que ca commence à se compliquer: à la fin de la compil ‘make-kpkg --added-patches=mppe buildpackage module’, avant de créer les .deb, il plante sur un clean qu’il n’arrive pas à faire sous pretexte qu’il ne trouve pas le fichier scripts/package/Makefile.
(une bonne nouvelle tt de même, le patch mppe s’applique tjs aussi bien)
je regarde un peu tout ca, et aprés tatonnement, je m’apercois que ce fichier (qui n’est pas réellement utilisé par la compil en mode debian), est détruit une première fois juste aprés la phase d’application des patchs (qu’il y en ai ou non).
Donc, quand il en arrive à compiler les modules secondaires, je suspend la compil, je touch le dit fichier, je relance la suite de la compil et … ca passe (ouf): j’obtiens mes .deb.
Je les installe, je reboote et la, pas de chance: partition root inaccessible->j’ai oublié mon initrd :blush:
Je reboote en 2.6.8, je recommence ‘make-kpkg --added-patches=mppe --initrd buildpackage module’, zappage en cours, re touch refg.
je lance l’install des .deb, et patatra: alors que j’ai précisé que mon noyau avait comme suffixe ‘-p4-mppe’ au moment de la config (cf +haut) et que l’install précèdente m’a bien installé les modules dans /lib/modules/2.6.9-p4-mppe, il plante lors de l’install du kernel-image, au moment ou celui ci fait un mkinitrd: ‘/lib/modules/2.6.9 not found’ !
un petit lien symbolique de 2.6.9->2.6.9-p4-mppe dans /lib/modules, je relance l’install des .deb, ca passe.
Je reboote, et la, nom de nom, ca ne passe encore pas (pas eu le tps de voir pourquoi).
Bon, comme ma moitié veut regarder la TV et que c’est ma bttv qui fait tuner, je dois rester en 2.6.8, et attendre demain matin pour continuer à avancer.
En attendant, j’ai connu des noyaux officiels nettement plus debianisable :frowning: Ou sont les bonnes vieilles sources officielles 2.4 qu’on pouvait utiliser immédiatement sans attendre le boulot des gars de l’équipe debian…
Ah mon bon monsieur, ils nous detraquent le temps avec leurs bombes…


#2

aujourd’hui, recompil avec le max de choses en noyau… toujours rien…


#3

Tu as essayé en suivant le tuto suivant et la complation à la sauce debian (ce que j’ai fait avec succès)?
people.via.ecp.fr/~alexis/format … linux.html


#4

[quote=“ralou”]Tu as essayé en suivant le tuto suivant et la complation à la sauce debian (ce que j’ai fait avec succès)?
people.via.ecp.fr/~alexis/format … linux.html[/quote]
tu l’as fait avec succés sur le 2.6.9 ?
Parceque, même si je ne connaissais pas ce tutorial (plutot laconique en ce qui concerne la compil noyau), c’est bien à la sauce debian que je compile déja mon noyau, et avec succés pour par exemple le 2.6.8.
Simplement, le source patché debian du 2.6.9 n’existant pas dans les paquetages (tout du moins en testing), je travaille avec un source kernel patché debian avec ‘make-kpkg debian’ => d’ou les inconsistances…
Mais je penses que mon probléme actuel vient d’un cafouillage entre udev, devfs, et le /dev traditionnel (ca plante juste aprés init-tools).
Le problème, c’est que ca génère plein d’erreur, et que les séquences d’arret défilement ne fonctionnent pas à ce moment là.
Mais je tatonne mes options, je vais bien trouver…


#5

Ben oui, avec succès, mais je suis parti avec les sources du 2.6.9, pas un noyau patché.


#6

bon, j’ai réussi, il boote, mais il est super lent, et j’ai encore trop de problème de trucs qui plante pour le mettre en prod.
Non, simplement, je voulais, par pur esprit d’orthodoxie :slightly_smiling: , compiler mon noyau sauce debian.
Je n’ai pas essayé la methode non debian, mais je vais peut etre le faire, histoire de voir si j’obtiens un noyau moins “râlant” que celui que j’ai…
++


#7

J’ai lu cet article : debianaddict.org/article39.html
et ca m’a l’air d’etre une autre méthode pour changer de noyau

Qu’est ce que tu penses de cette méthode si c’est bien ca ?


#8

ca c’est pour installer une IMAGE de noyau :laughing: et ca concerne un 2.4 sur une woody, mais moi, j’ai besoin d’installer le patch mppe, dc je dois travailler avec les sources (et de ttes les manieres par principe je compile tjs mon noyau, c’est pas pour le tps que ca prend).
comment on fait me dira tu ?
desktop-linux.net/debkernel.htm
merci tout de meme.


#9

je suis “heureux” de savoir que je ne suis pas le seul à avoir des pbs avec la 2.6.9 :laughing:


#10

j’ai réussi a le conpiler avec les sources “pristine”, mais avec des pb, puis j’ai chargé les paquets debian sid du source patché (merci boomslang machin pour son tuyau), mais j’ai le meme probleme: en cours de route, il me supprime un Makefile dont il a besoin aprés…
la solution du ctrl+Z et touch gnin gnin/Makefile permet de passer outre, mais j’ai trop de pb aprés reboot pour pouvoir passer en prod. et pour l’instant trop de chose a faire dans un environnement qui marche pour me prendre la tete avec du deboggage de changment de noyau…


#11

elle fait quoi cette commande ?? … je suis en train de regarder le manuel mais je pige pas trop :question: :question: … ça c avant de faire ‘kernel_image’ ? :blush:


#12

j’ai oublié le ‘s’ à module dans la commande, et en plus, ca ne marchera pas parceque j’ai oublié l’initrd… je rajoute d’ailleurs dans mes compils une “special flavour” une version, pour ne pas me perdre entre mes noyaux.
la “bonne” commande complète que j’utilise, c’est
make-kpkg buildpackage modules --initrd --added-patches=mppe --append-to-version=-p4-mppe
buildpackage et modules sont des cibles de make-kpkg (make-kpkg --targets te les donne toutes)
buildpackage fait trois paquetages kernel (image, source (patchées et configurées) et headers ) et on peut le remplacer par kernel-image tout court pour ne faire que ce paquetage la.
modules, c’est pour compiler les paquetages installés dans /usr/src/modules (pour moi, le nvidia)
–initrd, bon, c’est pour l’initrd
–added-patches=patcha,patchb,patchc,patchd , pour sélectionner les patchs que je veux appliquer lors de ma compil (il faut avoir une variable PATCH_THE_KERNEL=auto, en export ou définie dans le .profile)
–append-to-version=, c pour préciser un suffixe pour ton noyau, mais il semblerait que ca soit devenu un “feature” du 2.6.9 intègré au .config)
vala :slightly_smiling:


#13

oki merci pour l’explication :wink:


#14

je vais bien voir ce que ça me donne … j’ai remplacé ‘buildpackage’ par ‘kernel_image’ … comme ça je n’ai qu’un seul .deb …
mais quelle est l’utilité de séparer les packages en images, sources et headers ? :stuck_out_tongue:


#15

ayé je viens de faire l’install du kernel.deb :slightly_smiling:
il m’a créé nickel mon .img et placé dans ‘menu.lst’ avec ‘update-grub’ … j’ai modifié les partoches en ext3 juste avant … je vais redémarrer la bécane … je croise les doigts :blush:

EDIT >>>> bon ça ne démarre pas en 2.6.9 … peut etre passke j’ai activé ‘cramfs’ dans mon noyau ??? … l’ecran défile tellement vite en boucle que je n’ai pas le temps de lire ce qu’il affiche … juste un pb avec le répertoire /SBIN …
enfin je suis content passke ça démarre sans pb sur mon ancien noyau 2.2.20 … ce que je n’arrivais pas a faire avant 8) … ça avance ça avance :stuck_out_tongue:

EDIT >>>> oui c bien ça il fallait que je mette mes partoches en Ext3 pour pouvoir démarrer en 2.2.20 sous grub … c strange


#16

[quote=“bilbo”]ayé je viens de faire l’install du kernel.deb :slightly_smiling:
il m’a créé nickel mon .img et placé dans ‘menu.lst’ avec ‘update-grub’ … j’ai modifié les partoches en ext3 juste avant … je vais redémarrer la bécane … je croise les doigts :blush:

EDIT >>>> bon ça ne démarre pas en 2.6.9 … peut etre passke j’ai activé ‘cramfs’ dans mon noyau ??? … [/quote]
non, ca c’est obligatoire pour un noyau debian, c’est le mode de compression de l’initrd debian

[quote=“bilbo”]l’ecran défile tellement vite en boucle que je n’ai pas le temps de lire ce qu’il affiche … juste un pb avec le répertoire /SBIN …
enfin je suis content passke ça démarre sans pb sur mon ancien noyau 2.2.20 … ce que je n’arrivais pas a faire avant 8) … ça avance ça avance :stuck_out_tongue:
EDIT >>>> oui c bien ça il fallait que je mette mes partoches en Ext3 pour pouvoir démarrer en 2.2.20 sous grub … c strange[/quote]
mmmh c’est sans doutes plus lié à un probleme de boot sector je pense, et un lilo mieux configuré aurait peuteetre suffit.
Mais baste, grub, c’est tres bien, tu va le découvrir souvent.
Sinon, avant d’essayer le 2.6.9 (qui est une version impaire, dc une version de transition) installes déjà un 2.6.8. autant j’ai eu des pb avec le 2.6.9, autant le 2.6.8 s’installe comme une fleur. tu peux garder les sources des deux en parrallele ds /usr/src … tout ce qu’il faut, c’est faire pointer /usr/src/linux vers la racine des sources de ton noyau actif, pour bien compiler les pgm qui font appel à des includes noyau. Je te conseille d’abandonner pour l’instant le 2.6.9, sauf aprés avoir fait un noyau 2.6.8 propre, et a mon avis, sans espoir de pouvoir en faire grand chose, juste pour se préparer aux futures options du 2.6.10 .


#17

ah d’accord je croyais que le n° impair à prendre en compte était sur le 2eme chiffre … en 2.6.9 je pensais que ct une bonne …
bon alors je vais me rabattre sur une 2.6.8 comme tu dis :wink: .

je vais me coucher mais demain je fonce dans le tas.

merci encore pour tes précieux conseils … je vais me faire un copier/coller de ce topic en local lol :smiley:

bonne soirée :wink:


#18

tu as peut etre raison sur le numero de série (le 2.4.27 n’est il pas le 2.4 standard ? ) .
Mais en tout cas, le 2.6.9, il est trop hard pour l’instant…


#19

salut

alors voila je viens de mettre la 2.6.8 mais au boot j’ai l’erreur :

bon c pas si simple que ça finalement la 2.6.8 aussi :smiley:


#20

c’est un pb avec devfs installé ou non. Est ce que c’est un noyau de distrib ?
si oui, est ce que tu utilises devfs sur ta 2.4 ?
sinon, as tu activé le devfs, dans la section “File Systems/Pseudo filesystems” ?
sinon, je suis en train de compiler mon 2.6.9, en utilisant une logique à laquelle je n’avais pas pensé. J’ai commencé par installer une image piquée sur la sid, ensuite, j’ai installé le /boot/config correspondant, et je recompile aprés l’avoir ajusté, sans patcher…
ca a l’air de fonctionner pour l’instant…
j’ajusterais aprés pour voir si le patch marche, mais par contre il me semble déja que les sources debian nvidia ne fonctionnent pas en 2.6.9: j’ai compilé mon module nvidia pour le noyau de distrib, et il ne veut pas s’inserer. on va voir…