Installation debian 10 et hibernation intempestive

Tags: #<Tag:0x00007f3b793b1b98> #<Tag:0x00007f3b793b1aa8> #<Tag:0x00007f3b793b19b8> #<Tag:0x00007f3b793b18f0>

Bonjour,

J’ai installer une version netinstall de debian 10 afin de me créer un serveur complet de développement.

J’ai un soucis avec et je ne sais pas comment le résoudre:
L’ordinateur se met en veille toutes les 20 minutes sans que je fasse quoi que ce soit.
Exemple: alors que j’ai un service web docker accessible par http et un terminal connecté par ssh, ma machine se met en veille quand même alors que je suis en train de taper des commandes depuis le terminal distant.

(je ne connait que très très peu systemd.)

La seule chose que j’ai fait qui me semble pas extraordinaire c’est qu’a l’install j’ai activer l’installation de l’environnement graphique de base debian (pas de gnome ou autre)… et même en ayant changer les paramètres dans cet environnement (Energie > Bouton de mise en veille et extinction > Mise en veille automatique > Désactivé) la mise en veille se fait automatiquement.

Par défaut l’environnement graphique de base de debian, c’est gnome. Tu utilises gnome.

Tu as aussi Paramètres -> Énergie -> Économie d’énergie -> Écran noir que tu peux mettre à Jamais

ainsi que :
Paramètres -> Confidentialité -> Verrouillage de l’écran à Désactivé

merci @gilles2 mais ce n’est pas un problème d’écran, c’est l’ordi qui se met en hibernation automatiquement.

En attendant de trouver comment on fait ça proprement, ce petit hack mérite un test:

Et dans les commentaires, il y a aussi:
sudo systemctl mask hibernate.target hybrid-sleep.target

Merci pour le lien @mattotop,
J’ai regarder attentivement la documentation debian8 qui se trouve dans un des commentaires.

For systems which should never attempt any type of suspension

Le problème est que je ne désire pas éliminer l’hibernation de ce pc, en effet je l’utilise quand même pour éteindre le serveur quand j’ai fini de travailler dessus. Ce n’est pas un serveur de production.

Mon problème est de comprendre pourquoi le serveur s’hiberne automatiquement alors que je bosse dessus en ssh.

OK.
Effectivement, les hacks que j’ai trouvés sont pour un serveur en prod qui n’a pas besoin de veille.
Alors ton pb est un peu trop pointu pour moi, mais par contre, le tuto parle des répertoires de scripts de pm-utils, ça vaudrait p.ê le coup de regarder ce qu’il y a comme docs dans le paquet (dpkg -L pm-utils) pour réflechir.

Bonsoir,

c’est un paramètre de gdm3 que tu dois changer, ici:

/etc/gdm3/greeter.dconf-defaults

[org/gnome/settings-daemon/plugins/power]
sleep-inactive-ac-timeout=0
sleep-inactive-battery-timeout=0

Avec 0, l’hibernation est enfin inactive!

Francesco

1 J'aime

Bonjour,

Je mets en relation avec :

Merci pour cette réponse et le lien associé qui explique le fond du problème.

Effectivement c’était bien ces paramètres qui posait problème. Sur ma version de debian ceux-ci étaient commentés et mis a 1200 secondes soit 20 minutes ce qui doit être la valeur de base. en les décommentant et en ajoutant le 0 aux deux valeurs plus de problèmes !

Impeccable!