Installation Debian-9.6.0-Lxde proprement

Tags: #<Tag:0x00007feddb7ca210> #<Tag:0x00007feddb7c9fb8> #<Tag:0x00007feddb7c9e00> #<Tag:0x00007feddb7c9ce8>

Bonjour a tous,
je n’ai que très peu expérience sur linux et
suite a de grosses galères a essayer d’installer steam, en Vain :Voir mon sujet initial
J’envisage une nouvelle installation a partir du :Debian-Live-9.6.0-amd64-Lxde.iso
que mon “petit” portable semble très bien supporté !

Seulement j’ai quelques exigences et j’aimerai gardé une OS la plus stable possible :
-Remplacer le firefoxESR d’origine par la version standard
-Récupérer les outils de gestion d’alimentation du Debian-Xde
-Installer steam (j’envisage de jouer a darkest dungeon)
-Donc je suppose : Installer les drivers graphique et quelque chose dans le genre Vulkan qui remplacerai directX si j’ai bien compris

je n’ai également pas bien compris l’intérêt de choisir un nom de domaine local au moment de l’installation, il était dit de choisir ce que bon nous semble j’ai mis un .com dans le doute mais peu être ai-je fait une bourde a ce niveau la aussi …

J’ai également installer directement depuis les dépôts via la 4G mais ne serait t’il pas préférable de faire cette première installation hors ligne ?!?

Bonne Fête a tous ;
Cordialement, Adiz

Salut
Pour ce qui concerne Firefox, la version standard est fournie dans sid, ce qui oblige à ajouter le dépôt sid dans le fichier sources.list
Mais ça demande de gérer les preférences sinon à la mise à jour les logiciels vont passer en version sid

cf
https://www.debian.org/doc/manuals/debian-handbook/sect.apt-get.fr.html#sect.apt.priorities

https://www.debian.org/doc/manuals/debian-handbook/sect.apt-get.fr.html#sect.apt-mix-distros

c’est pourquoi je préfère installer localement la version officielle de Mozilla, ce qui fonctionne tout aussi bien ( y compris la mise à jour automatique)

Bonjour,
il existe un post où il en est question, regarde:
https://www.debian-fr.org/t/installer-la-derniere-version-de-firefox-sur-stretch/74694/3
Si tu as un souci, on peut t’aider.

Salut,
merci de votre aide mais j’ai hélas l’impression de m’y perdre de plus en plus, je m’explique :
Je suis hospitalisé depuis un certains temps maintenant avec pour seul occupation ce vieux packard bell récupéré pour une bouché de pain sur le bon coin;
je suis parti a la base avec un Ubuntu xde sur lequel j’arrivais a faire tourné steam sans problème, pour le jeux en question (darkest dungeon et d’aprés la configu minimum annoncé sur le site cela devrait fonctionné) se lancé malgrés l’absence de driver graphique mais avec des lag trop fort pour permettre une expérience de jeu correct
je me suis donc tourné vers ce qui ma semblé d’après mes recherche l’OS le plus léger et le plus stable possible …
Le problème : je passe par un wifi public sur lequel la plateforme steam est visiblement bloqué, donc vpn obligatoire et a priori firefoxESR ne supporte pas ca, j’ai tout de même réussi cette étape une fois sans trop me souvenir comment
Maintenant pour ce qui est de lancé steam … j’ai vraisemblablement reussi a mettre une sacrée pagaille dans le pc (de plus en plus de bug en tout genre nécessitant parfois même un reboot) a force de suivre toute sorte de tuto plus inutile les uns que les autres …
bref je sent la réinstallation venir mais y a t’il un moyen de faire ca sans avoir 10 ans d’études en informatique dans les bottes ?

Quoi qu’il en soit merci pour votre participation je me pencherai demain plus en détail sur vos lien car j’arrive a saturation ce soir !

Cordialement, Adiz

Donc si je comprend bien ces paquet qui refuse de s’installer en permanence et qui me bloque toutes mes installations drivers viennent d’un problème de priorité ?!

Les paquets suivants contiennent des dépendances non satisfaites :
 steam:i386 : Dépend: libc6:i386 (>= 2.15) mais ne sera pas installé
              Dépend: libstdc++6:i386 (>= 4.3) mais ne sera pas installé
              Dépend: libx11-6:i386 mais ne sera pas installé
              Dépend: libudev1:i386 mais ne sera pas installé
              Dépend: libxinerama1:i386 mais ne sera pas installé
              Dépend: libtxc-dxtn0:i386
              Dépend: libgl1-mesa-dri:i386 mais ne sera pas installé
              Dépend: libgl1-mesa-glx:i386 mais ne sera pas installé
              Dépend: libgpg-error0:i386 mais ne sera pas installé
              Recommande: libxss1:i386 mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

pour ce qui est de la carte graphique

[GeForce 7000M / nForce 610M] [10de:0533] (rev a2) (prog-if 00 [VGA controller])
    	Kernel driver in use: nouveau
    	Kernel modules: nouveau

une idée pour l’installation du driver graphique ?

je m’y remet plustard, merci !

Salut
“nouveau” est le pilote libre pour les cartes Nvidia
si ça ne te convient pas tu peux essayer d’installer un pilote nvidia
https://wiki.debian.org/fr/NvidiaGraphicsDrivers

pour steam si tu es en 64 bits, il est possible que ce soit un pb de multi-arch pour avoir i386 https://wiki.debian.org/fr/Multiarch/HOWTO

Ceci dit je n’ai pas de carte nvidia et je ne joue pas aux jeux vidéos
https://wiki.debian.org/fr/Steam

Je ne me vois pas répéter tout ce qui est fort bien expliqué dans les liens du wiki Debian, que je t’indique, mais bien évidemment tu es tout a fait libre de ne pas les lire. :grinning:

bon courage, d’autres t’en diront surement plus

Salut,
J’ai finalement réinstaller mon affaire bière soir (EDIT : les lapsus a l’écrit ca compte ? hahaha) avant le dodo et je reprend tout a zéro ce matin !
Non toutes ces infos me seront sûrement bien utiles merci bien en tout cas je vais essayer d’y allé doucement pour pas faire de connerie !

Joyeuses fête a vous je vous tiens au courant en cas de pépin

cordialement, Adiz

je me tourne vers la méthode D’éditer /etc/apt/sources.list qui me semble la plus simple sauf que 2 petites choses me taraude l’esprit :
1-comment supprimer firefox esr proprement ? apt-get purge firefoxesr suffira t’il ?
2-quel est ce base.list dans /etc/apt/sources.list.d/ je n’y touche pas ou je supprime ?

Je me retrouve de nouveau confronté au même soucis avec steam et pourtant j’ai bouquiné les wiki ce coup ci, ce qui m’interpelle le plus c’est de voir que steamOS est basé sur debian et non ubuntu (oui sur ubuntu ca pase tout seul)…

Allé un petit dernier pour la route,

L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 steam:i386 : Dépend: libc6:i386 (>= 2.15) mais ne sera pas installé
              Dépend: libstdc++6:i386 (>= 4.3) mais ne sera pas installé
              Dépend: libx11-6:i386 mais ne sera pas installé
              Dépend: libudev1:i386 mais ne sera pas installé
              Dépend: libxinerama1:i386 mais ne sera pas installé
              Dépend: libtxc-dxtn0:i386
              Dépend: libgl1-mesa-dri:i386 mais ne sera pas installé
              Dépend: libgl1-mesa-glx:i386 mais ne sera pas installé
              Dépend: libgpg-error0:i386 mais ne sera pas installé
              Recommande: libxss1:i386 mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

j’abandonne si quelqu’un arrive a comprendre quelque chose a ce merdier …

j’éspère juste que cela n’aura aucune répercution sur la stabilité de l’os bien que je soit plus a un formatage prés