Lire son logiciel


#1

je ne sais comment lire mon dvd debian sarge .j’ai essayé avec les divers lecteur multimedia (kaffeine,…)
je voudrais lire le 3 dvd (nombreux logiciel,etc a l’interieur )
faut’il un lecteur special ? ou un décompresseur ?


#2

non, il ne faut rien: un dvd de données est un filesystem comme un autre, et ne nécessite pas plus d’outils qu’un disque dur (si c’est pour regarder un film c’est un peu différent).
Tu sais quel mountpoint correspond à ton DVD ?
Est ce que cette dernière question te parle ?
Quelle est ton interface graphique (si tu en utilise une) ?
Quel est le contenu de ton fichier /etc/fstab ?


#3

je suis débutant je ne sais comment on fait /etc/fstab :cry:
sinon mon interface graphique est kde.

je me suis renseigné au net , il semblerait que je dois monter mon cdrom afin de pouvoir quand je met un cd ou dvd dans mon lecteur je puisse y acceder,l’utiliser ,etc


#4

bon, alors pour lire un fichier, par ex. /etc/fstab (qui est un fichier, pas une commande), tu tapes dans une konsole:
cat /etc/fstab
si le fichier est trop long pour que tu aies le temps de le lire, tu utilises less:
less /etc/fstab

Ensuite, dedans, tu va voir apparaitre une ligne du genre
/dev/hdc /mnt/cdrw iso9660 ro,user,noauto 0 0
ca veut dire que le “device” (=peripherique sur lequel est ton cd) est /dev/hdc (dans mon cas bien sur), et que son “mountpoint” (=point de montage, l’endroit ou tu va pouvoir acceder au contenu du cd) se trouve dans /mnt/cdrw (toujours dans mon cas)…
Il se peut (mais ca serait étonnant) que cela ne soit pas configuré. Dans ce cas, on verra.
Si c’est bien configuré, pour monter ton péripherique (ici, c’est le cdrom, mais ca pourrait etre un appareil photo), dans une konsole ADMINISTRATEUR, tu executes la commande:
mount /dev/hdc (ou /mnt/cdrw, ca marche aussi).
Aprés, en te promenant avec konqueror, tu peux aller regarder dans /mnt/cdrw (bien sur toujours dans mon exemple) et y chercher ce que tu veux.

Ah, aussi, petite remarque, tu ne pourra pas ejecter le cd, même en appuyant sur le bouton, tant que tu n’aura pas fait le umount du cdrom.
Attention, si tu a un explorateur (konqueror, pardon) qui est ouvert sur le cd, il refusera de l’umounter…
Vala.
J’ai été simple ?


#5

Le plus simple serait peut-être de le rajouter dans les sources apt via un apt-setup non?


#6

je n’avais pas vu que c’etait pour faire des installs :laughing:
ceci étant dit, c’est pas franchement inutile de savoir monter un CD…
Bon, la fourmi, si tu veux installer qqchose sous debian, il faut lire un peu:
lea-linux.org/software/soft_gere/apt_dpkg.html


#7

un gd merci MattOTop ca devient bcp plus clair .

voici ce que j’ai eue:


proc /proc proc defaults 0 0
/dev/hdb1 / ext3 defaults,errors=remount-ro 0 1
/dev/hdb5 none swap sw 0 0
/dev/hdc /media/cdrom0 iso9660 ro,user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0

pour moi il s’agit de /dev/hdc /media/cdrom0 iso9660 ro,user,noauto 0 0
donc je dois faire sur mon terminal :
/media/cdrom0
ou
mount/dev/hdc

ok pour cela,mais pour le umount ,je dois le taper en console aussi ?


#8

c’est mount <l’un ou l’autre>.
Le ‘umount /media/cdrom0’, c’est quand tu as fini de travailler sur le CD.
tu peux aussi faire ‘eject /media/cdrom0’


#9

j’ai eue se message :open_mouth:

mount /dev/hdc

mount: wrong fs type, bad option, bad superblock on /dev/hdc,
missing codepage or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

mount /media/cdrom0

idem !!!


#10

mais enfin, c’est quoi ce délire?

sous gnome, le montage (cd, app. photo, clée usb, …) est automatique!

et KDE se présente comme etant user-friendly? :confused:


#11

[quote=“la fourmi”]j’ai eue se message :open_mouth:

mount /dev/hdc

mount: wrong fs type, bad option, bad superblock on /dev/hdc,
missing codepage or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

mount /media/cdrom0

idem !!![/quote]

essaye en UDF

ça dit quoi?


#12

ghostintheshell :

:astonished: je débute et s’est la 1 fois que j’utilise linux.mon interface péferé est kde.
apres on peut me critiquer , mais c’est trop facile.

ton code n’a pas fonctionné ghostintheshell . :astonished:
x-torww5:/home/fourmi# mount -t udf /dev/hdc /media/cdrom0
mount: Aucun medium trouvé


#13

déjà, quand tu fais ‘eject /dev/hdc’ est ce que ca t’ouvre le lecteur ?
Tu n’as pas déplacé ton cdrom depuis l’installation, sinon ?


#14

oui MattOTop :wink: ca marche ,ca fait bien ejecter le cdrom.

heu ! deplacé le cdrom,non je ne pense pas.
sinon il est bien en ide 2 et en master .


#15

Bon, ben je suis un peu sec: /dev/hdc est donc bien ton lecteur, et tout ce que je t’ai dit devrait marcher.
Tu as essayé de monter un CD au lieu d’un DVD ?


#16

mount /dev/hdc

mount: Aucun medium trouvé

mount /media/cdrom0

mount: Aucun medium trouvé

non c’est quoi la procedure ?


#17

pas de différence entre un cd de données et un dvd de données, juste la taille des données contenues.
Mais tu es bien sûr que tu mets ta galette en polymère (CD ou DVD) DANS le lecteur (tu sais le truc qui sort quand tu fais un eject), et ceci AVANT de lancer la commande mount ? :laughing:


#18

[quote=“MattOTop”]pas de différence entre un cd de données et un dvd de données, juste la taille des données contenues.
Mais tu es bien sûr que tu mets ta galette en polymère (CD ou DVD) DANS le lecteur (tu sais le truc qui sort quand tu fais un eject), et ceci AVANT de lancer la commande mount ? :laughing:[/quote]

à l’endroit? :laughing:


#19

bon bon bon…
Et le point de montage (=le répertoire /mnt/crdom0) existe bel et bien ?


#20

bien entendu la galette est bien mise.:angry:

c’est bon je chercherai seul .