Pb compilation kernel 2.6.9


#1

bonjour

comme indiqué dans le titre j’ai un pb de compil …

actuellement je suis sous sid avec kernel 2.2.20 (celui de base).
je souhaite passer en 2.6.9 et j’ai vu qu’il fallait compiler le support pour Ext3 et en plus convertir les partitions existantes en Ext3 pour que ça fonctionne.

donc pour la conversion j’ai fait :
tune2fs -j /dev/hda2
tune2fs -j /dev/hda5

puis j’ai modifié dans /etc/fstab les “Ext2” en “Ext3” pour qu’il les monte en Ext3 au prochain redémarrage.

ensuite j’ai fait un “make menuconfig” en prenant bien soin de mettre en dur le support Ext3 (plus les autres options).

j’ai créé mon fichier .deb puis je l’ai installé.
il m’a bien créé le fichier vmlinuz sous /boot et créé le lien symbolique dans /
j’exécute “lilo” pour quil prenne bien en compte les modifs.

==> le pb : qd je redémarre le systeme il me met : Kernel panic : VFS: Unable to mount root fs on unknown block(3,2)

j’ai raté qq chose mais je ne sais pas quoi :question:
si vous avez une soluce je suis preneur merki :slightly_smiling:


#2

j’ai eu ca aussi, la seule solution que j’ai trouvée c’est d’installer le package kernel-image-2.6.9-1-[ton architecteure] disponible sur les ftp debian, mais avant de faire ca as tu bien fait ton mkinitrd et lavoir specifié dans grub ou lilo ?

et ca fonctionne.

++
:wink:


#3

pour le paquet je vais tester merci :wink: … mais au juste que fait il ? c une maj ?
sinon je ne sais pas ce qu’est mkinitrd ??? ça sert à quoi ? je pense n’avoir jamais eu à l’utiliser avec lilo :question:


#4

ah ok je vien de voir …
mais pour installer le patch 2.6.9.1 il faut que mon lilo soit configuré pour initrd
pour configurer initrd il faut que j’arrive à omprendre comment il fonctionne :s … il me faut une image .img mais avec la commande make-kpkg je n’ai qu’un .deb ???

peut etre en lancant un make bzImage ?


#5

pour construire un noyau avec l’initrd, c’est 'make-kpkg buildpackage --initrd’
aprés, il faut effectivement l’indiquer dans l’entrée correspondante de lilo.
Mais avec grub, rien d’autre à faire que d’installer le paquet kernel-image :smiley: … vive grub !


#6

arghh j’arrive un peu trop tard pour le tuyau :smiley:

je viens juste de lancer la commande :
make-kpkg --initrd --revision kernel_image
en ayant mis à jour préalablement les packages cramfs.

bon spa grave si ça ne marche pas je prend ta technique :wink:
pour grub tu m’intéresse … je débute sous linux et je me rend compte que bcp de personnes préfèrent grub à lilo … le temps d’installer correctement mon nouveau noyau et je regarde ça de plus près :smiley: (j’ai faux ou alors on ne peut pas installer grub par défaut ??)

merci pour ton aide :slightly_smiling:


#7

je ne me souviens plus à quel moment j’ai installé grub, si c’est a l’install ou aprés, mais si tu as besoin que je t’aide, fais une disquette lilo pour booter à coup sur, regardes s’il ne suffit pas d’installer le paquetage grub, et si ca ne marche pas, reboote avec ta disquette, je t’expliquerais comment l’installer et l’utiliser (mais a mon avis, il suffit d’installer le paquetage)


#8

oui je crois qu’installer le package suffira :stuck_out_tongue: faut desinstaller lilo avec la commande
lilo -U
(si mes souvenirs sont bon lol) pi installer grub : apt-get blabla …
pi quand il est installé verifie le fichier : /boot/grub/menu.lst pour voir si il a les lignes qui permettront de demmarer ton noyau, si pas, il y a une commande je crois mais je ne sais plus laquelle :stuck_out_tongue:


#9

ok merci pour ces infos :slightly_smiling:
par contre la commande ‘make-kpkg buildpackage --initrd’ m’a construit d’autres fichiers .deb et toujours pas de .img … j’ai meme un fichier .change

bon je me suis arrêté là hier passke j’étais crevé mais je reprend ça ce soir :smiley:


#10

l’initrd est DANS le paquetage kernel-image*.deb… l’install du .deb depaquete ET le noyau ET son initrd, les deux etant indissociables…
sinon, tu as raison, moi je fais tjs le buildpackage par habitude, mais le make-kpkg kernel-image est suffisant pour produire juste le paquetage noyau (kernel-image*.deb)…
pour info, ca fait quelques temps que je ne sais plus quoi integrer au noyau pour eviter l’initrd, meme l’ext3 en noyau n’est pas uffisant pour booter sans initrd… si quelqu’un arrive a booter sans, ca m’interresse


#11

donc cela veut dire que lorsque je fais :
‘dpkg -i kernel-image*.deb’ il est censé me placer le fichier initrd dans le bon répertoire et aussi dans lilo ?

sinon peut on extraire manuellement le fichier .img du fichier .deb ?

c des questions qui peuvent paraitre idiotes mais j’ai toujours l’habitude de poser bcp de questions lol :smiley:

merci :slightly_smiling:


#12

[quote=“bilbo”]donc cela veut dire que lorsque je fais :
‘dpkg -i kernel-image*.deb’ il est censé me placer le fichier initrd dans le bon répertoire et aussi dans lilo ?
merci :slightly_smiling:[/quote]
dans grub oui, dans lilo je ne sais pas…

quel interet , alors autant soit le creer avec mkinitrd soit le dl sur les ftp debian :wink:


#13

ok ok je passe à grub :smiley:

merci pour tout je vous tiendrait au courant :wink:


#14

huhu … c encore moi :smiley:

vala j’ai installé grub, créé le fichier ‘menu.lst’ mais je me suis trompé dans le nom de ma partition :frowning: … à un endroit j’ai mis hda0 au lieu de hda1 …

ma question est comment remodifier mon fichier menu.lst maintenant ?
qd je boot sur le cd1 et que je vais dans la 2eme console je n’ai pas le droit à vi … juste ‘nano-tiny’ qui est bien pourri …

:question: :question: :question: :question: :question: :question:


#15

edit >> c bon j’ai réussi à le modifier :smiley: mais j’ai l’erreur 17 : Cannot mount selected partition
je suis en Ext2 … comment cela se fait-il ?

il y a une commande en plus ?


#16

je t’avais dit, avant toute manip de te faire une disquette de boot :wink:
bon, si tu as tout de même un boot grub, tu peux éditer les options car grub est INTERPRETE, et tu peux modifier ton boot (et faire plein d’autres choses d’ailleurs, comme activer des partoches, etc) avant de booter (lis la doc, c’est passionnant).
bon, avec ‘e’ sur le boot que tu veux ajuster, tu rentre dans l’editeur , tu refais ‘e’ sur la ligne que tu veux modifier, tu modifies comme tu veux, et aprés, je crois que c’est entrée pour valider ta modif, puis ‘b’ pour lancer ton boot avec les caracs modifiées…
tout n’est point perdu.
attention, la modif n’est pas enregistrée, mais une fois sous X, il faudra juste penser à lancer un ‘update-grub’ qui génerera AUTOMATIQUEMENT un manu.lst avec tous les noyaux qu’il aura détecté (c’est plus simple que de modifier à la main, non ?)


#17

oui je m’en fais une dès que j’arrive à redémarrer correctement :smiley:

en fait j’ai réussi a trouver comment modifier le fichier mais une fois l’erreur corrigée il me met l’erreur …

pourtant :
kernel (hd0,0)/vmlinuz-2.2.20-idepci root=/dev/hda1 resume=/dev/hda1 noresume splash=silent vga=791

avec le fichier ‘vmlinuz-2.2.20-idepci’ dans ‘/boot’ et mon ‘/’ dans ‘hda1’ je ne vois pas ce qui cloche … le fait que je soit en ‘Ext2’ ??? dans ce cas je suis bloqué et dois recommencer mon install :blush:

EDIT >> le forum a une heure de retard lol


#18

voilà une de mes entrées: title Debian GNU/Linux, kernel 2.4.27-1-686-smp root (hd0,1) kernel /boot/vmlinuz-2.4.27-1-686-smp root=/dev/hda2 ro initrd /boot/initrd.img-2.4.27-1-686-smp savedefault boot
ca n’a pas l’air de correspondre DU TOUT avec la syntaxe dont tu me parles dans ton post précèdent… meme en ajoutant des retours à la ligne. et malgré la souplesse de grub qui accepte peut etre les ‘=’.
alors pour toi, ca devrait etre, en supposant que /boot n’est pas sur une partoche à part: title Debian GNU/Linux, kernel 2.2.20-idepci root (hd0,0) kernel /boot/vmlinuz-2.2.20-idepci initrd /boot/initrd.img-2.2.20-idepci savedefault boot
(j’ai ajouté une réfèrence à un initrd, car ca m’étonne que tu n’en ai pas)


#19

ps: kan tu auras rebooté, fais un update-grub, tu ajouteras tes noyaux à toi aprés ceux détectés automatiquement
pps: l’ext2 ne change rien à mon avis :slightly_smiling:


#20

hola je m’étai encore trompé (je suis fatigué ce soir …), mon ‘/’ est sur ‘hda2’ donc je mettrais plutot ‘root (hd0,1)’

mais il ne trouve pas fichier initrd.img-2.2.20-idepci :blush: … j’en ai pas créé passke tu m’avais dit qu’avec grub ça servait à rien :blush:

merci pour la syntaxe :slightly_smiling: … j’avais trouvé la mienne sur un site et apparemment c plutot pas bon lol