PB Config Apache2


#1

bonjour tout le monde,
je tourne sous Debian Sarge kernel 2.4. j’ai installé apache2, depuis une machine connecté au reseau local je vois l’index de base de apache mais quand je reload apache2 “/etc/init.d/apache2 reload”. Il y a un message qui me pose un probleme.

“Reloading web server config…httpd not running, trying to start (98)Address already in use: make_sock: could not bind to address 10.0.0.2:80 no listening sockets available, shuting down
Unable to open logs”

Au niveau du fichier apache.conf, j’ai mis :

Listen 10.0.0.2:80


User admin
Group admin

D’ou le probleme peut il venir?
Merci des réponses


#2

as tu la possibilité de faire un restart plutot qu’un reload ?
Il faudrait regarder ce qui utilise ton port 80 (avec netstat peut être) ?


#3

:exclamation:
dis moi, tu as bien reloadé en root ?


#4

oui je suis en root et quand je fai un restart, j’ai un autre message :

forcing reload of web server : Apache2 … no pidfile found! not running?apache2: could not open document config file /etc/apache2/ssl.conf

Y a t il un pb avec ssl??? alors que je n’ai rien touché dedans?

quand je fais un netstat -anlp |grep ‘80’, j’obtiens :

tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN 4212/apache2

Les pb toujours les pb…


#5

tu dois avoir un apache zombie qqpart.
fais un stop, plusieurs fois,
ensuite, tu fais un killall apache2, un ps aux pour vérifier, un netstat pour être absolument sur qu’il n’y a plus rien, et ensuite start.
Ca implique un petit temps d’arret comparable à celui d’un redémarrage, ceci étant dit… :wink:


#6

j’ai testé ce que tu m’as dit mais quand je start, encor un message concernant ssl.conf

Starting web server: Apache2apache2;could no open document config file /etc/apache2/ssl.conf

voila j’espere que tu peut faire quelque chose car je n’y arrive pas


#7

Regarde dans /etc/apache2/mods-available et regarde si tu as un ssl.conf
Regarde aussi dans /etc/apache2/mods-enabled

François


#8

je l’ai dan mods-available mais pas das mods-enabled.
mais pk m’a tu demandé de regardé ça??


#9

tu as bien stoppé, tout vérifié (ps, netstat), avant de faire ‘start’ ?
Tu as regardé dans /var/log/apache2 ? rien de bizarre ?
last, qui te donne la liste de tes connections, te parait normale ?
tu as vérifié l’état des fichiers auquel il a dit ne plus pouvoir accèder (droits pour l’user dans lequel tourne ton apache2, par exemple, et que tu aurais par erreur mis en root.root).
Et sinon, je sais que ce n’est pas propre, mais que donne le reboot ?


#10

[quote=“kegro”]je l’ai dan mods-available mais pas das mods-enabled.
mais pk m’a tu demandé de regardé ça??[/quote]

Car ssl.conf est justement le fichier de configuration de ssl sous apache. Je me demandais donc si tu l’avais activé. Sous debian, l’activation d’un module pour apache se fait en créant un lien dans /etc/apache2/mods-enabled vers le fichier .conf (et .load) si existant dans /etc/apache2/mods-available.

Le truc bizarre c’est que le module ssl n’est pas activé dans ton install mais il te demande quand même le fichier de conf.

Sinon, en dernier recours, un dpkg-reconfigure apache2


#11

oui, j’ai bien stoppé et vérifié avant de starter. le reboot j’avais déja essayé mais quand meme refait. toujours pareil.
sinon le reste a l’air bien…


#12

justement concernant le module ssl, comme tu le précise je ne l’est pas install auparavant. l’install est toute fraiche. j’ai juste mis en place un dns (sans le ssl), rien de plus.
par contre, je ne vois pas ce que tu veux dire par le fichier .conf


#13

fsoumil a raison: essayes de relinker le module ssl.conf dans mods-enabled, pour voir.
Peux tu donner le résultat de 'aptitude search" apache2 ?
Quel age a la config ? Et la dernière mise à jour d’apache2 ?
Tout ça, quoi…


#14

J’ai fait une connerie, sans faire exprès j’ai effacé tout ce que contenait le fichier mods-enabled.
Comment fait on pour recharger des fichiers par défaut d’apache2?
Comme ça je pourrais essayer ce que vous m’avez dit…
merci :wink:


#15

Dans /etc/apache2/mods_available, tu trouveras une série de modules (fichier .conf et .load). Pour activer un modules, il suffit de créer un lien dans /etc/apache2/mods_enabled vers le fichier .conf et .load

PAr exemple, pour php4, tu dois faire
ln -sfn /etc/apache2/mods_available/php4.conf /etc/apache2/mods_enabled/php4.conf
ln -sfn /etc/apache2/mods_available/php4.load /etc/apache2/mods_enabled/php4.load

Je me demande s’il n’existe pas une commande debian pour le faire mais j’ai un petit trou de mémoire.

A+

François


#16

j’ai réussi a récupérer mes fichiers effacés… quand meme… mais quand je redémarre apache , il y a le message suivant :

Forcing reload of web server: Apache2 … no pidfile found! not runnig no listening sockets available, suhtting down
Unable to open logs

j’ai vérifié avec killall apache2 mais il ne tue rien docn rien n’est démarré…

quelqu’un auraitil une lampe pour que j’y vois plus claire??


#17

que renvoit la commande ps -ef | grep apache ?


#18

slt,

A mon avis tu doit avoir un fichier dans /var/pid ou /var/lock ou /var/run, a supprimer ensuite vérifie que les chemins des logs sont correct ainsi qu’avec les bon droits.


#19

Pour réactiver les modules:

[code]emeraude:~$ man -k apache
a2dismod (8) - disables an apache2 module
a2enmod (8) - enables an apache2 module
ab (8) - Apache HTTP server benchmarking tool
apache2 (8) - Apache hypertext transfer protocol server
apache2ctl (8) - Apache HTTP server control interface
CGI::Apache (3perl) - Backward compatibility module for CGI.pm
check_forensic (8) - tool to extract mod_log_forensic output from apache log files
DBI::ProfileDumper::Apache (3pm) - capture DBI profiling data from Apache/mod_perl
logresolve (8) - Resolve IP-addresses to hostnames in Apache log files
rotatelogs (8) - Piped logging program to rotate Apache logs
emeraude:~$ man a2enmod | head
Remise en forme de a2enmod(8), attendez SVP…
A2ENMOD(SECTION) A2ENMOD(SECTION)

NAME
a2enmod - enables an apache2 module

SYNOPSIS
a2enmod [module]

[/code]


#20

j’ai essayé cette commande mais elle ne renvoie rien.
j’ai créé le pid de apache : apache2.pid dans /var/run
et quand je stop apache2, le message est le suivant :

Stopping web server: Apache2 … no pidfile found! not runnig?.

Ce qui est bien c’est que le message diminue mais il y en a toujours un. On doit pas être loin…
Je cherche en attendant des réponses