Pb démarrage suite MAJ Wheezy>Jessie à cause réglages tmpfs


#1

Bonjour,

J’ai mis à jour Debian Wheezy vers Jessie sur le PC de mes parents qui ne démarre plus avec systemd

systemd failed to stop exec spawning /bin/plymouth no such file or directory

Le démarrage se fait bien en mode sysVinit en revanche

Voilà leur /etc/fstab :

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>

tmpfs	/tmp	tmpfs	defaults,noatime,mode=1777	0	0
tmpfs	/var/lock	tmpfs	defaults,noatime,mode=1777	0	0
tmpfs	/var/run	tmpfs	defaults,noatime,mode=1777	0	0
#Entry for /dev/sda7 :
/dev/sda7	/	ext4	noatime,errors=remount-ro	0	1
#Entry for /dev/sda6 :
/dev/sda6	/home	ext4	noatime	0	2
#Entry for /dev/sda1 :
/dev/sda1	/media/sda1	ntfs	defaults,nls=utf8,umask=0222	0	0
#Entry for /dev/sdb1 :
#UUID=112E95F97596BB40	/media/usb0	ntfs-3g	defaults,rw,user,noauto,locale=fr_FR.UTF-8	0	0
/dev/sr0	/media/cdrom0	udf,iso9660	user,noauto	0	0
/dev/sr1	/media/cdrom1	udf,iso9660	user,noauto	0	0

Si je commente les 3 premières lignes afférentes à tmpfs le système démarre normalement sous systemd.

J’ai lu que Debian mettait dorénavant (depuis Wheezy ?) /tmp, /var/lock et /var/run en tmpfs par défaut mais que systemd ne gérait pas tmpfs comme sysVinit du coup je me demande : par défaut avec Jessie et systemd, /tmp, /var/lock et /var/run sont ils montés en tmpfs ou faut-il toujours le configurer manuellement ? Auquel cas comment faire ?

Merci d’avance


#2

Salut,
apparemment c’est géré par systemd-tmpfiles http://www.freedesktop.org/software/systemd/man/systemd-tmpfiles.html et tmpfiles.d freedesktop.org/software/sys … les.d.html


#3

Merci
J’ai suivi les liens et fais quelques recherches, malheureusement je n’ai pas trouvé de tuto sur l’utilisation de systemd-tmpfiles pour /var/lock /var/run et /tmp :unamused:


#4

d’après ce que je comprends il faut creeér un fichier de conf tel que décrit dans dsm.fordham.edu/cgi-bin/man- … &ampsect=5

comme dans cet example:

   /etc/tmpfiles.d/screen.conf example

   screen needs two directories created at boot with specific modes and
   ownership.

       d /run/screens  1777 root root 10d
       d /run/uscreens 0755 root root 10d12h[/i]

puis l’activer tel que décrit dans dsm.fordham.edu/cgi-bin/man- … &ampsect=8

systemd-tmpfiles --create

Voici ce qu’il y a dans un système Xubuntu 15.04 “brut de fonderie” sans modifications sur le sujet ça se passe dans /usr/lib/tmpfiles.d

@desktop:/usr/lib/tmpfiles.d$ cat tmp.conf
#  This file is part of systemd.
#
#  systemd is free software; you can redistribute it and/or modify it
#  under the terms of the GNU Lesser General Public License as published by
#  the Free Software Foundation; either version 2.1 of the License, or
#  (at your option) any later version.

# See tmpfiles.d(5) for details

# Clear tmp directories separately, to make them easier to override
D /tmp 1777 root root -
#v /var/tmp 1777 root root 30d

# Exclude namespace mountpoints created with PrivateTmp=yes
x /tmp/systemd-private-%b-*
X /tmp/systemd-private-%b-*/tmp
x /var/tmp/systemd-private-%b-*
X /var/tmp/systemd-private-%b-*/tmp

#5

Le problème ne viendrait pas de Plymouth ?
Essaie en le supprimant.


#6

Désinstaller plymouth demanderait qu’il soit préalablement installé.
Or, il nous est arrivé de rencontrer ce message d’erreur bien que plymouth ne soit pas installé sur le système.
Pour faire disparaître le message d’erreur à propos de plymouth sur une installation elive (distribution de la famille debian) il m’a fallu supprimer l’option splash des arguments passés au démarrage par grub. L’option splash a pour effet d’afficher des images et des animations lors du démarrage au lieu de l’affichage sec de texte défilant.
Voir les options au démarrage à travers l’édition de /boot/grub/grub.cfg et

cat /proc/cmdline

#7

jul & etxeberrizahar : dans mon cas l’erreur ne se produit plus quand je commente les lignes liées à tmpfs dans le fstab

grandtoubab : merci je vais regarder ça
ça a l’air incroyablement plus compliqué qu’avant ou c’est moi ?
Par ailleurs certains dossiers devraient être en RAM par défaut depuis Wheezy (cf mon 1er post), ce n’est plus le cas au final depuis le passage à systemd ?


#8

Avec systemd, /tmp, /var/lock (lien vers /run/lock) et /var/run (lien vers /run) sont montés en tmpfs par défaut.
Pas besoin d’entrée dans fstab pour ça.


#9

Y a pas /tmp

@desktop:~$ sudo df -k | grep tmpfs
tmpfs                 180536     22164     158372  13% /run
tmpfs                 902668       108     902560   1% /dev/shm
tmpfs                   5120         4       5116   1% /run/lock
tmpfs                 902668         0     902668   0% /sys/fs/cgroup
tmpfs                 180536        36     180500   1% /run/user/1000

Ca ne nous dit pas comment mettre /tmp en tmpfs


#10

Essaye la commande suivante pour indiquer à systemd de monter /tmp en tmpfs :

Si elle est efficace, la commande suivante rendra ce montage persistant :


[résolu]Impossible de monter les periphériques
#11

Cool merci, je vais passer ce week end chez mes parents tester ça :slightly_smiling:


#12

ça passe

@desktop:~$ systemctl start tmp.mount
@desktop:~$ systemctl enable tmp.mount
Created symlink from /etc/systemd/system/local-fs.target.wants/tmp.mount to /lib/systemd/system/tmp.mount.
@desktop:~$ sudo df -k | grep tmpfs
tmpfs                 180096     22168     157928  13% /run
tmpfs                 900460        80     900380   1% /dev/shm
tmpfs                   5120         4       5116   1% /run/lock
tmpfs                 900460         0     900460   0% /sys/fs/cgroup
tmpfs                 180096        36     180060   1% /run/user/1000
tmpfs                 900460         0     900460   0% /tmp

Merci.


Optimiser son partitionnement avec un disque de petite taille
#13

Testé et approuvé, merci bien :slightly_smiling: