Pilotes Nouveau et ventilateur

pilote
nouveau
fan-management
Tags: #<Tag:0x00007fdf1d69afb0> #<Tag:0x00007fdf1d69adf8> #<Tag:0x00007fdf1d69ac90>

#1

Salut !
Je suis passé aux drivers Nouveau sur ma carte graphique Nvidia.
(non sans mal Problème affichage)
Petit problème le ventilo de la carte tourne à fond maintenant !
J’ai trouvé ça :
http://floppym.blogspot.com/2013/07/fan-control-with-nouveau.html
Mais ça ne fonctionne pas.
Je mets le résultat de dmesg | egrep -i “nouveau|drm|fb”

[ 0.000000] BIOS-e820: [mem 0x0000000000000000-0x000000000009fbff] usable
[ 0.374755] system 00:03: [mem 0xffb80000-0xffffffff] could not be reserved
[ 5.944590] nouveau 0000:02:00.0: NVIDIA GF108 (0c1000a1)
[ 6.082758] nouveau 0000:02:00.0: bios: version 70.08.ae.00.00
[ 6.083964] nouveau 0000:02:00.0: fb: 4096 MiB DDR3
[ 7.425802] nouveau 0000:02:00.0: DRM: VRAM: 4096 MiB
[ 7.425803] nouveau 0000:02:00.0: DRM: GART: 1048576 MiB
[ 7.425807] nouveau 0000:02:00.0: DRM: TMDS table version 2.0
[ 7.425809] nouveau 0000:02:00.0: DRM: DCB version 4.0
[ 7.425811] nouveau 0000:02:00.0: DRM: DCB outp 00: 01000302 00020030
[ 7.425813] nouveau 0000:02:00.0: DRM: DCB outp 01: 02000300 00000000
[ 7.425815] nouveau 0000:02:00.0: DRM: DCB outp 02: 08011392 00020020
[ 7.425816] nouveau 0000:02:00.0: DRM: DCB outp 03: 04022310 00000000
[ 7.425818] nouveau 0000:02:00.0: DRM: DCB conn 00: 00001030
[ 7.425819] nouveau 0000:02:00.0: DRM: DCB conn 01: 00002161
[ 7.425820] nouveau 0000:02:00.0: DRM: DCB conn 02: 00000200
[ 7.442506] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[ 7.442508] [drm] Driver supports precise vblank timestamp query.
[ 7.443537] nouveau 0000:02:00.0: DRM: MM: using COPY0 for buffer copies
[ 7.518350] nouveau 0000:02:00.0: DRM: allocated 1920x1200 fb: 0x60000, bo (ptrval)
[ 7.518557] fbcon: nouveaufb (fb0) is primary device
[ 7.577272] nouveau 0000:02:00.0: fb0: nouveaufb frame buffer device
[ 7.593247] [drm] Initialized nouveau 1.3.1 20120801 for 0000:02:00.0 on minor 0

C’est une debian buster/sid :
Noyau 4.19.0-1-686-pae

Et la carte :
02:00.0 VGA compatible controller: NVIDIA Corporation GF108 [GeForce GT 630] (rev a1)

Merci pour l’aide !


#2

salt
ta page est plein de google je ne suis pas allé voir :
Sur celle-ci tu as quelques conseils :
https://wiki.archlinux.org/index.php/Nouveau


#3

Hello,
ma page pleine de google raconte la même chose que ta page pleine d’archlinux.
Merci pour ta réponse mais ça ne fonctionne pas.


#4

Hello ponky,

https://wiki.archlinux.org/index.php/Nouveau#Fan_control

N’aide pas du tout ??


#5

Salut r2mi,
et bien j’ai fait ça :
echo 2 > /sys/devices/pci0000:00/0000:00:09.0/0000:02:00.0/hwmon/hwmon1/pwm1_enable

ce qui est sensé mettre sur AUTO. Et ça ne change rien.
Alors j’ai pas essayé de le couper j’ai un peu peur de cramer le tout…


#6

Bien en superuser ?

Tu as bien raison.

Pour voir si ces réglages ont un effet, tu peux essayer temporairement le mode MANUAL à 40%

Que donne :

# cat /sys/devices/pci0000:00/0000:00:09.0/0000:02:00.0/hwmon/hwmon1/pwm1_enable
# et
# cat /sys/devices/pci0000:00/0000:00:09.0/0000:02:00.0/hwmon/hwmon1/pwm1

Autrement, essaie avec la règle udev citée :

$ cat /etc/udev/rules.d/50-nouveau-hwmon.rules
ACTION=="add", SUBSYSTEM=="hwmon", DRIVERS=="nouveau", ATTR{pwm1_enable}="2"

Il faut regarder les températures avec sensors aussi ;
le refroidissement avec le ventilo à fond est peut-être justifié.

Le modinfo nouveau doit peut-être contenir des infos intéressantes.

https://www.kernel.org/doc/Documentation/thermal/nouveau_thermal

Fan management

Not all cards have a drivable fan. If you do, then the following HWMON
attributes should be available:

  • pwm1_enable: Current fan management mode (NONE, MANUAL or AUTO);
  • pwm1: Current PWM value (power percentage);
  • pwm1_min: The minimum PWM speed allowed;
  • pwm1_max: The maximum PWM speed allowed (bypassed when hitting Fan_boost);

You may also have the following attribute:

  • fan1_input: Speed in RPM of your fan.

Your fan can be driven in different modes:

  • 0: The fan is left untouched;
  • 1: The fan can be driven in manual (use pwm1 to change the speed);
  • 2; The fan is driven automatically depending on the temperature.

NOTE: Be sure to use the manual mode if you want to drive the fan speed manually

NOTE2: When operating in manual mode outside the vbios-defined
[PWM_min, PWM_max] range, the reported fan speed (RPM) may not be accurate
depending on your hardware.


#7

Oui en root.
Tes deux commandes me renvoient respectivement 2 et 40.


#8

Après je ne pense pas que la ventilation à fond se justifie d’une part parce que ça se met
en route 100 % du temps dès le démarrage et d’autre part ça n’arrivait jamais avec les
drivers proprios.


#9

Le réglage de la vitesse du ventilo de ta carte n’est peut-être pas pilotable avec nouveau :frowning:
Il faut essayer la règle udev.


#10

Je viens d’essayer. Même chose :confused:


#11

Que valent pwm1_min et pwm1_max ?

Est-ce qu’un passage de AUTO à MANUAL est bien pris en compte ?

Que donne la lecture de fan1_input en baissant pwm1 et pwm1_min en mode MANUAL ?

Je pense que le mode AUTO fonctionne mais d’après une valeur de capteur de température erronée.

Il faudrait installer ce que préconise mattotop ; cité plus haut.


#12

Hello.
Je dois avouer que ça me casse un peu les pieds de passer des heures sur ce truc
alors que les drivers proprios gèrent ça très bien.
Donc je suis repassé aux drivers propios.
Merci pour votre aide.
ponky