Plantage de xsane et simplescan Imprimante Samsung CLX-3175FN Debian 10

Tags: #<Tag:0x00007faa290a86a8> #<Tag:0x00007faa290a8540>

Merci beaucoup pour ces infos, notamment apt -s install…

J’ai téléchargé les 2 paquets mais la commande apt -s install me renvoie pas mal d’erreurs.

avec libsane 1

Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances
Lecture des informations d’état… Fait
Note : sélection de « libsane1 » au lieu de « ./libsane1_1.0.31-3_amd64.deb »
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l’impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n’ont pas encore
été créés ou ne sont pas sortis d’Incoming.
L’information suivante devrait vous aider à résoudre la situation :
Les paquets suivants contiennent des dépendances non satisfaites :
libsane1 : Dépend: libsane-common (= 1.0.31-3) mais 1.0.27-3.2 devra être installé
Dépend: libc6 (>= 2.29) mais 2.28-10 devra être installé
Dépend: libgcc-s1 (>= 3.0) mais il n’est pas installable
Dépend: libsnmp40 (>= 5.9+dfsg) mais il n’est pas installable
Recommande: sane-utils (>= 1.0.31-3) mais 1.0.27-3.2 devra être installé
Recommande: ipp-usb mais il n’est pas installable
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l’état ».`

**et avec sane-utils **

sudo apt -s install ./sane-utils_1.0.31-3_amd64.deb
Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances
Lecture des informations d’état… Fait
Note : sélection de « sane-utils » au lieu de « ./sane-utils_1.0.31-3_amd64.deb »
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l’impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n’ont pas encore
été créés ou ne sont pas sortis d’Incoming.
L’information suivante devrait vous aider à résoudre la situation :
Les paquets suivants contiennent des dépendances non satisfaites :
sane-utils : Dépend: libc6 (>= 2.29) mais 2.28-10 devra être installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l’état ».

Je crains de me retrouver au fur et à mesure avec des dépendances non résolues, d’autant plus que de nombreux paquets dépendent de libc6.

Je pense malheureusement devoir attendre la version 11 pour résoudre mon problème. En attendant, je peux toujours scanner directement à partir de l’imprimante en utilisant son port USB même si la définition est moindre et au pire utiliser une clé live.

Merci infiniment pour ton aide sans laquelle je n’aurais pas pu faire ces investigations

une autre grosse bidouille consisterai a décompresser localement les fichiers .deb, ce ne sont que des archives finalement

Nautilus -> extraire ici

decompresser ensuite data.tar.xz
Capture d’écran du 2020-11-21 12-59-22

et a subsistuer les ingredients nécessaires que tu juges meilleurs, dans ton installation

tu peux d’abord garder les anciens en les renommant en .bak

C’est une bonne idée !

Je vais regarder en faisant les modifs pas à pas. Je pourrai toujours revenir en arrière si ça ne marche pas.

Merci