Problème de résolution d'écran [résolu]


#1

Bonjour,
Je voudrais peaufiner ma taille d’écran qui est un 17" soit 12801024, or il ne me propose pas plus de 800600!
C’est un sony tritintron cathodique générique 60 Hz, que dois-je modifier dans base-config, étant donné que je laisse tout en générique et que je ne connait pas le modèle exacte?

merci :wink:


#2

salut,
deux solutions: dpkg-reconfigure xserver-xfre86 dans une console et aux choix de l’ecran tu choisi “advanced” mais il faut que tu connaisses le rafraichissement horizontal et vertical de ton ecran, alors avec un peu de recherches sur le net tu devrai trouver sinon tu edites le fichier: /etc/X11/XF86Config-4 (attention à la syntaxe) et tu modifie la section monitor et screen.


#3

http://forum.debian-fr.org/viewtopic.php?t=1629


#4

[quote=“reynald”]salut,
deux solutions: dpkg-reconfigure xserver-xfre86[/quote]
ou dpkg-reconfigure xserver-xorg si Testing [quote=“reynald”]dans une console et aux choix de l’ecran tu choisi “advanced” mais il faut que tu connaisses le rafraichissement horizontal et vertical de ton ecran, alors avec un peu de recherches sur le net tu devrai trouver sinon tu edites le fichier: /etc/X11/XF86Config-4 (attention à la syntaxe) et tu modifie la section monitor et screen.[/quote]
ou /etc/X11/xorg.confsi Testing


#5

En faite, il ne me propose pas de mettre une étoile ou une croix sur la résolution 1280*1024, il ne me laisse que les 2 premières résolutions de base, même après modif. :confused:


#6

essayes sudo dpkg-reconfigure -phigh xserver-xorg


#7

A cocher avec la barre d’espacement.
Ensuite, modifier la résolution ds KDE ou Gnome


#8

Après tt ça, un /etc/init.d/gdm (ou kdm) restart (ou reload) pour prendre en compte.


#9

ctrl+alt+backspace fonctionne aussi trés bien pour redémarrer le serveur X.


#10

Ah, oui, j’y pensais plus :wink:

Mais s’il est en console, il sort… (ça m’arrive tt le tps grrr :angry: )


#11

Est-ce que tu es sûr que ton moniteur supporte le 12801024? C’est une résolution plutôt utilisée par les 19". Mais en principe, les 17" supportent au moins le 1024768. Je pense que ça vient de la configuration de ton moniteur, dans la config d’XF86.
Si tu nous montrait ton fichier /etc/X11/XF86Config-4, on pourrait t’aider d’avantage.


#12

[quote]Si tu nous montrait ton fichier /etc/X11/XF86Config-4, on pourrait t’aider d’avantage.[/quote]+1


#13

Mon problème ne se résoud pas, puisque kde me propose toujours pas ma résolution après avoir coché la croix. Il met un 800*600 85 Hz par défault.
Je précise que je ne suis pas en testing.

merci

XF86Config-4 (XFree86 X Window System server configuration file)

This file was generated by dexconf, the Debian X Configuration tool, using

values from the debconf database.

Edit this file with caution, and see the XF86Config-4 manual page.

(Type “man XF86Config-4” at the shell prompt.)

This file is automatically updated on xserver-xfree86 package upgrades only

if it has not been modified since the last upgrade of the xserver-xfree86

package.

If you have edited this file but would like it to be automatically updated

again, run the following commands as root:

cp /etc/X11/XF86Config-4 /etc/X11/XF86Config-4.custom

md5sum /etc/X11/XF86Config-4 >/var/lib/xfree86/XF86Config-4.md5sum

dpkg-reconfigure xserver-xfree86

Section “Files"
FontPath “unix/:7100” # local font server
# if the local font server has problems, we can fall back on these
FontPath “/usr/lib/X11/fonts/misc”
”/etc/X11/XF86Config-4" 154L, 3695C 1,1 Haut


#14

On n’en voit qu’une partie… :laughing:
Ouvre le fichier, avec gedit par exemple, et fait un copié-collé du tout. (On va y arriver)


#15

Oups pardon! je l’ai ouvert avec vi, j’ai trop l’habitude de la roulette :laughing:
Sinon mon écran supporte bien cette résolution(Cf:windows, mandriva) :wink:

Section "Files"
FontPath “unix/:7100” # local font server
# if the local font server has problems, we can fall back on these
FontPath "/usr/lib/X11/fonts/misc"
FontPath "/usr/lib/X11/fonts/cyrillic"
FontPath "/usr/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/Type1"
FontPath "/usr/lib/X11/fonts/CID"
FontPath "/usr/lib/X11/fonts/Speedo"
FontPath "/usr/lib/X11/fonts/100dpi"
FontPath "/usr/lib/X11/fonts/75dpi"
EndSection

Section "Module"
Load "GLcore"
Load "bitmap"
Load "dbe"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "speedo"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option “XkbRules” "xfree86"
Option “XkbModel” "pc105"
Option “XkbLayout” "fr"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option “Device” "/dev/input/mice"
Option “Protocol” "ImPS/2"
Option “Emulate3Buttons” "true"
Option “ZAxisMapping” "4 5"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option “Device” "/dev/event0"
Option “Type” "cursor"
Option “Mode” "relative"
Option “Speed” "3.0"
Option “Threshold” "10"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option “Device” "/dev/event0"
Option “Type” "stylus"
Option “Mode” "absolute"
Option “Tilt” "on"
Option “Threshold” "10"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option “Device” "/dev/event0"
Option “Type” "eraser"
Option “mode” "absolute"
Option “TiltInvert” "on"
Option “Threshold” "10"
EndSection

Section "Device"
Identifier "NVIDIA Corporation NV11 [GeForce2 MX/MX 400]"
Driver "nv"
EndSection

Section "Monitor"
Identifier "Écran générique"
HorizSync 30-70
VertRefresh 50-160
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "NVIDIA Corporation NV11 [GeForce2 MX/MX 400]"
Monitor "Écran générique"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes “1280x1024” "640x480"
EndSubSection
SubSection "Display
Depth 4
Modes “800x600” "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes “800x600” "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes “800x600” "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes “800x600” "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes “800x600” "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice “cursor” "SendCoreEvents"
InputDevice “stylus” "SendCoreEvents"
InputDevice “eraser” "SendCoreEvents"
EndSection

Section "DRI"
Mode 0666
EndSection


#16

Dans ton fichier de config, pour tous les niveaux de couleur (1/4/8/16/24 bits), tu mets la même ligne avec toutes les définitions que tu veux, genre:
mode “1280x1024” “1024x768” “800x600” "640x480"
tu fais ça pour toutes les lignes “mode”, et ca devrait résoudre ton problême.


#17

Dans la section Screen, modifie les lignes de cette façon, en root :
DefaultDepth, c’est le nombre de couleurs par défaults, ici 24 bits, soit un million de couleurs (c’est good).
Ensuite, les SubSection Display correspondent à la configuration de chaque mode de couleurs. Comme par défaut ta config est en 24 bits, c’est surtout la subSection Display où le Depth est à 24 qui est importante. Là, tu dois lister toutes les résolutions que tu souhaites. Ajoute donc les résolutions 1280x1024 et 1024x768.

[quote]
Section "Screen"
Identifier "Default Screen"
Device "NVIDIA Corporation NV11 [GeForce2 MX/MX 400]"
Monitor "Écran générique"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes “1280x1024” "640x480"
EndSubSection
SubSection "Display
Depth 4
Modes “800x600” "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes “800x600” "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes “800x600” "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes “1280x1024” “1024x768” "800x600"
EndSubSection
SubSection "Display"
Depth 24
Modes “1280x1024” “1024x768” “800x600”
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice “cursor” "SendCoreEvents"
InputDevice “stylus” "SendCoreEvents"
InputDevice “eraser” "SendCoreEvents"
EndSection

Section "DRI"
Mode 0666
EndSection[/quote]

enregistre, puis relance gdm en appuyant sur ctrl+alt+backspace.
Si au relancement, l’écran ne s’affiche pas, essaye une résolution plus faible en faisant ctrl alt “-”, et modifie la syncronisation de ton écran dans ce fichier.


#18

essaye de remplacer ta section

Depth 24 Modes "800x600" "640x480"

par

Depth 24 Modes "1280x1024" "1024x768" "800x600" "640x480"


#19

les derniers ont raison comme condition suffisante, mais si tu souhaites les avoir (tes résolutions) dans tous les niveaux de couleur, remplaces bien TOUTES les lignes mode. :wink:


#20

lol. Ca c’est de l’aide multi-utilisateurs. :laughing: