Problème d'installation phpbb module apache2 manquant ?


#1

Bonjour à tous,

Je viens de me monter un serveur web apache2 sous Debian Sarge 3.1 avec PHP 4 et MySQL 4. J’ai également installé et configuré Phpmyadmin correctement.

La page d’installation se présente correctement mais l’installation n’aboutit pas : phpbb termine l’installation avec le message d’erreur suivant :
Citation:

[quote]La configuration de php sur votre serveur ne supporte pas le type de base de données que vous avez choisi
[/quote]

Aurais-je oublié d’installer un module ? J’ai installé libapache2-mod-auth-mysql en espérant que cela règlerait le problème mais il n’y fait rien. Si quelqu’un a la solution… merci d’avance


#2

c’est surement php4-mysql qui manque … mais c’est bizzare étant donné que phpmyadmin semble? fonctionner ?


#3

il y a peut être un module à activer dans /etc/apache2/mods-enabled ?
non ?


#4

non non je confirme php4-mysql est bien présent et phpmyadmin fonctionne normalement vu que j’ai créé un utilisateur et une base de donnée.

quand au module à activer dans /etc/apache2/mods-enabled , je ne vois effectivement pas de ligne en rapport avec mysql, voici le contenu de mon fichier :

[quote]actions.load
cgi.load
php4.conf
php4.load
userdir.conf
userdir.load[/quote]


#5

nan, normalement, tu pourrais éventuellement lier symboliquement un des modules de mods-available dans mods-enabled, pour l’activer, mais en regardant dans le mien, je n’ai aucune réference non plus à un module spécifique sql, alors que j’ai un phpmyadmin qui marche.
C’est donc que c’est plutot dans php qu’il manquerait une passerelle mysql, mais puisque tu dis que ca marche avec mysqladmin, je ne sais pas d’ou ca peut venir.
Tu n’as pas un “phpbb.conf”, ou un équivalent qqpart ?
Je n’sais pas… DSL


#6

je me posais une question, s’il ne fallait pas charger un module dans httpd.conf du style [quote]LoadModule php-mysql libexec/php-mysql.so[/quote] :question: (je précise que ce module est une invention, j’ignore s’il existe vraiment mais c’était pour l’exemple).


#7

Non. Le fonctionnement d’apache2, c’est de charger les modules qu’il trouve dans mods-enabled (modules activés), et qui sont des liens vers les modules dans mod-available (modules disponibles).
Si tu ne trouves pas déja ton boinheur dans available, c’est que le module n’est pas installé comme paquet debian.
Sinon:
emeraude:~$ apt-cache search php | grep mysql
<…>
php4-mysql - MySQL module for php4
php5-mysql - MySQL module for php5
phpbb2-conf-mysql - Automatic configurator for phpbb2 on MySQL database
as tu installé php4-mysql, tout de même (même si phpmyadmin marche, peut etre qu’il a ses propres bibliothèques) ?


#8

non il faut inclure php, apres c’est PHP qui inclue le module mysql, la configuration est stoquée dans le fichier /etc/php4/apache/php.ini

regarde la sortie de /var/log/apache/error.log voir si il ya des soucis lors du chargement d’apache, ou lorsque tu essaye de faire ton installation de phpbb2


#9

ps: pour enable / disable des modules, il faut utiliser la commande a2enmod ou a2dismod, pour les sites c’est a2ensite ou a2dissite

:slightly_smiling:


#10

thx. J’avais compris la logique, mais je faisait mes linkages à la main :laughing:


#11

la sortie de /var/log/apache/error.log est parlante : dans le log je vois une ligne qui parle de mysql.so[quote]PHP Warning : Unknown(): Unable to load dynamic library ‘/usr/lib/php4/20020429/msql.so’ - /usr/lib/php4/20020429/mysql.so: cannot open shared object file : No such file or directory in Unknown on line 0[/quote]

hum :confused: je me demande bien ce qu’il se passe


#12

je comprends d’autant moins qu’en allant vérifier dans le répertoire si le fichier demandé y est, il y est… c’est possible de le réinstaller ?


#13

apt-get install --reinstall


#14

j’ai réinstallé le package mysql-server sans vraiment beaucoup d’espoir et j’ai eu raison de ne pas trop y croire car cela ne marche toujours pas. Par contre j’ai essayé d’installer un autre script, GLPI où là aussi l’installation ne marche pas, par contre dans l’installation de GLPI il y a un test sur l’extension mysql et j’ai donc un message m’informant de ceci : Vous devez compiler votre php avec l’extension Mysql.

je pensais que c’était automatique :question:

merci pour vos réponses au fait


#15

dis ? tu as tout installé avec apt ?


#16

et bien oui j’ai tout installé avec apt-get install, ensuite j’ai modifié les fichiers de configuration httpd.conf pour mettre en route mon serveur web. c’est tout ce que j’ai fait


#17

copies ta config, purges tous les paquets ‘apt-get remove --purge’, et réinstalles pas à pas en verifiant à chaque fois s’il n’y a pas de regression…
Je ne vois que ça.


#18

ok merci du conseil, je le ferai demain


#19

j’ai donc désinstallé avec l’option --purge les packages nécessaires à un serveur web et j’ai eu une grosse surprise, même après désinstallation de apache2, le site s’affiche ! alors là je ne comprends plus rien… j’ai regardé s’il restait des résidus de apache et effectivement il restait des fichiers. j’ai essayé de les supprimer c’est trop bizarre, j’arrive à les lister avec ls -la mais lorsque je tente de les supprimer avec rm, il me dit qu’il ne les trouve pas… ce n’est à rien n’y comprendre, je sens que je vais réinstaller complètement le système :frowning:


#20

ps aux | grep apache, pour voir si tu n’as plus de serveur qui tourne.
Sinon, c’est quoi cette histoire de reinstall ? on est pas sous windows (signé le commissaire politique debian)…