Problème Français dans XFCE

français
xfce
Tags: #<Tag:0x00007f09327379f8> #<Tag:0x00007f09327378b8>

#1

Bonsoir,

Je cherche un peu d’aide pour comprendre pourquoi XFCE n’est qu’en partie en français.
Je ne pense pas avoir de problème de locales en tant que tel.
Par exemple sous gnome-shell tout est bien en français.

$ cat /etc/default/locale 
LANG=fr_FR.UTF-8
$ locale -a
C
C.UTF-8
en_US.utf8
french
fr_FR
fr_FR@euro
fr_FR.iso88591
fr_FR.iso885915@euro
fr_FR.utf8
POSIX
$ locale
LANG=fr_FR.UTF-8
LANGUAGE=fr,en
LC_CTYPE="fr_FR.UTF-8"
LC_NUMERIC="fr_FR.UTF-8"
LC_TIME="fr_FR.UTF-8"
LC_COLLATE=fr_FR.UTF-8
LC_MONETARY=fr_FR.UTF-8
LC_MESSAGES="fr_FR.UTF-8"
LC_PAPER=fr_FR.UTF-8
LC_NAME=fr_FR.UTF-8
LC_ADDRESS=fr_FR.UTF-8
LC_TELEPHONE=fr_FR.UTF-8
LC_MEASUREMENT=fr_FR.UTF-8
LC_IDENTIFICATION=fr_FR.UTF-8
LC_ALL=

Le clavier est bien en français (terminal et XFCE), pas de pb à ce niveau là.
Dans les terminaux je n’ai pas de problème, c’est bien en français (par ex dpkg-reconfigure me propose des menus en français) mais apt est en anglais

Par contre pour l’interface du bureau XFCE, j’ai bien une base en français. Le menu application est bien en français par ex, de même pour le panneau de configuration. Tout semble donc correct sauf que l’environnement XFCE (et peut-être le reste du système mais le 'locale -a' semble correct) considère toujours l’anglais par défaut, je m’explique :

  • Les applications (mousepad, synaptics…) se lancent en anglais et je dois modifier la langue “à la main” dans les préférences (quand cela est possible). Je ne parle pas des applis comme firefox, thunderbird ou libreoffice qui ont un paquet spécifique pour le français.
  • Les sous-menu du panneau de config, le menu du clic-droit, le menu user sont tous en anglais. Si j’ouvre le gestionnaire de paramètres il s’appelle “Settings - customize your desktop” mais tout les choix sont en français (Apparence, Application favorites, Bureau, Economiseur d’écran…) mais si rentre dans un de ces sous-menu on est à nouveau en anglais (dans Apparence, les onglets sont : Style, Icons, Fonts et Settings ; et les paramètres modifiables et affichés sont aussi en anglais)

Avez-vous une idée de ce qui pourrait être à l’origine du problème ?
Un grand merci pour votre aide.
Bonne soirée,
Benjam


#2

Bonjour,

Je n’ai pas l’environnement sous la main, mais la console de paramétrage des langues comporte un bouton “Appliquer à tous le système” ou un truc qui s’en rapproche. Est-ce que ça change quelque chose ?


#3

Bonjour,
comment l’as tu installé ? Avec un l’iso Net Install, j’ai tout en français pour ma part.
N’es-tu pas passé par une iso live usb ?


#4

Salut
Ton système mélange les deux langues française et anglaise

cf le retour des commandes sur un système en français seul, aucune mention de en

locale -a
C
C.UTF-8
fr_FR.utf8
POSIX
~$ locale
LANG=fr_FR.UTF-8
LANGUAGE=
LC_CTYPE="fr_FR.UTF-8"
LC_NUMERIC="fr_FR.UTF-8"
LC_TIME="fr_FR.UTF-8"
LC_COLLATE="fr_FR.UTF-8"
LC_MONETARY="fr_FR.UTF-8"
LC_MESSAGES="fr_FR.UTF-8"
LC_PAPER="fr_FR.UTF-8"
LC_NAME="fr_FR.UTF-8"
LC_ADDRESS="fr_FR.UTF-8"
LC_TELEPHONE="fr_FR.UTF-8"
LC_MEASUREMENT="fr_FR.UTF-8"
LC_IDENTIFICATION="fr_FR.UTF-8"
LC_ALL=
~$ env | grep -i lang
LANG=fr_FR.UTF-8

je reconfigurerai pour ne laisser que le français

sudo dpkg-reconfigure locales

Capture%20d%E2%80%99%C3%A9cran%20du%202018-12-04%2009-26-04


#5

Vérifiez que le paquet task-french-desktop est bien installé.
Sur une Debian xfce installée il y a 2 ans depuis une netinstall

fp2@debpacha:~$ aptitude  search desktop | grep '^i'
i  desktop-base - fichiers communs du Bureau Debian
i  desktop-file-utils - Utilitaires pour les fichiers .desktop
i  gir1.2-freedesktop - données d'introspection pour certains composants FreeDesktop
i  gnome-desktop3-data - Common files for GNOME desktop apps
i  gsettings-desktop-schemas - Schémas Gsettings destinés à l'ensemble de l'environnement de bureau
i  libfile-desktopentry-perl - Perl module to handle freedesktop .desktop files
i  libgnome-desktop-3-12 - bibliothèque de chargement de fichiers .desktop - fichiers d'exécution
i  task-desktop - environnement de bureau Debian
i  task-french-desktop - bureau français
i  task-xfce-desktop - Xfce
i  xfdesktop4 - arrière-plan, icônes et gestionnaire de menu pour le bureau XFCE
i  xfdesktop4-data - arrière-plan, icônes et menu principal pour le bureau Xfce – fichiers communs
fp2@debpacha:~$ 

Cordialement,
Regards,
Mit freundlichen Grüßen,
مع تحياتي الخالصة


F. Petitjean
Ingénieur civil du Génie Maritime.

Femme qui pète et poule qui pond ne font que bruit dans la maison.
Les proverbes philosophiques du Professeur Choron


#6

Depuis une console pour voir exactement ce qu’il y a de configuré :

localectl status

Après pour configurer le clavier et/ou les locales :

localectl set-locale XXXXXX
localectl set-keymap XXXXX

Pour lister les locales et les disposition clavier disponibles :

localectl list-locales
localectl list-keymap

Et si il y a une interface graphique ce sera avec un x11 en plus :

http://man7.org/linux/man-pages/man1/localectl.1.html


#7

c’est moins précis que

locale -a -v

locale: fr_FR.utf8      archive: /usr/lib/locale/locale-archive
-------------------------------------------------------------------------------
    title | French locale for France
   source | RAP
  contact | Traduc.org
    email | bug-glibc-locales@gnu.org
 language | French
territory | France
 revision | 1.0
     date | 2008-03-15
  codeset | UTF-8

locale: C.UTF-8         directory: /usr/lib/locale/C.UTF-8
-------------------------------------------------------------------------------
    title | C locale
    email | aurel32@debian.org
 language | C
 revision | 1.6
     date | 2016-08-08
  codeset | UTF-8

la je vois où c’est

 ls -alrt /usr/lib/locale/
total 1596
drwxr-xr-x   3 root root    4096 nov.   2 08:18 C.UTF-8
drwxr-xr-x   3 root root    4096 nov.   2 08:18 .
-rw-r--r--   1 root root 1683120 nov.   2 08:18 locale-archive
drwxr-xr-x 144 root root   20480 nov.  29 18:51 ..

#8

Bonsoir,

Je m’excuse vraiment pour mon temps de réponse.
Je n’ai à peine allumé mon ordi depuis des semaines.
Je vous remercie beaucoup pour toutes vos réponses.

J’ai testé vos manip mais sans succès, je ne comprend pas bien mais je n’arrive pas à avoir du français partout.
J’ai même testé de virer toute ma conf dans le home mais sans succès.
Et également de réinstaller tous les paquets de ma distrib en tenant compte du pining [ dpkg -l | grep ^ii | awk ‘{print $2"="$3}’ | xargs apt-get install --reinstall --yes ]
Et dans tous les cas j’ai ce même problème de “franglais” sur ma distrib.

@sk4hrr
Je connais cette option de paramétrage des langues sous Gnome-Shell ou Unity mais je n’ai pas trouvé sous XFCE.

@Herve33
Non ce n’est pas une netinstall ni une installation avec l’installeur classique.
L’installeur classique ne permet pas une installation “propre” sur du btrfs puisqu’il installe à la racine du système btrfs et non dans un snapshot. Moi j’installe dans une arborescence de sous-volumes btrfs imbriqués les uns dans les autres. C’est donc une installation en debootstrap comme je fais souvent.
Les seules choses qui changent par rapport à toutes mes autres installations debootstrap précédentes sont que j’ai mis XFCE au lieu de Gnome-Shell et l’option “minbase” de debootstrap.
Avec une install classique et XFCE pas de pb. Donc je vais refaire l’installation sans cette option “minbase”, peut-être que cela vient de là (et mon pb de grub aussi).

@grandtoubab
Effectivement, j’ai bien “fr” et “en” au niveau du système (dpkg-reconfigure locales) et dans mon bashrc.
Je fais ça sur toutes mes install depuis un moment car à l’époque (il y au moins 5 ou 10 ans) j’avais lu que c’était conseillé de toujours laisser “en” en utf8 sur les systèmes car tous les programmes sont conçus pour “en” et donc que c’était une sécurité. Sur tous mes autres systèmes je n’ai jamais eu de problème.
Mais j’ai tenté tout de même de reconfigurer et de changer les langues en “fr” seulement dans bashrc, puis reboot mais ça n’a rien changé.

@littlejohn75
J’ai ajouté ce paquet “task-french-desktop” (que je n’avais pas) et ses dépendances mais ça n’a ajouté que hunspell-fr quasiment et cela ne règle rien.
Merci de l’astuce car je liste ce paquet dans mes standards d’installation

@Clochette
Je ne connaissais pas “localectl” seulement “locale -a -v”.
Le “status” et le “list-locales” indique bien français ; par contre “list-keymap” n’est pas trouvé.

Je suis en train de tout sauvegarder et je vais refaire une installation deboostrap sans l’option “minbase” et si ça ne fonctionne pas je testerai d’installer par l’installeur Debian en faisant moi-même le montage des sous-volumes juste après le partitionnement.

Merci beaucoup et encore une fois désolé de ne répondre que maintenant.
Benjam