[Résolu]etch ? noyau 2.6.15.1 ? gnome ?


#1

Bonsoir,

voila mon sources.list

[code]# Stable
deb http://security.debian.org/ stable/updates main contrib non-free
deb-src http://security.debian.org/ stable/updates main contrib non-free
deb http://ftp.fr.debian.org/debian/ stable main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ stable main contrib non-free

Testing

deb http://security.debian.org/ etch/updates main contrib non-free
deb-src http://security.debian.org/ etch/updates main contrib non-free
deb http://ftp.fr.debian.org/debian/ etch main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ etch main contrib non-free

deb cdrom:[Debian GNU/Linux 3.1 r0a Sarge - Official i386 Binary-2 (20050607)]/ unstable contrib main
deb cdrom:[Debian GNU/Linux 3.1 r0a Sarge - Official i386 Binary-1 (20050607)]/ unstable contrib main
[/code]

seulement, lorsque j’ai fait la mise a jour pour avoir le noyau 2.6.15.1-686 (qui apparement est le seul qui veuille reconnaitre ma iwp2200)
gnome ne fonctionne plus car il a été desinstallé et devient totalement in-instalable

je recois des messages comme quoi X n’est pas configuré ou n’est pas executable dans l’écran bleu quand je démarre le pc

Pendant les tentatives d’installation des paquets je vois passer souvent cette erreur :

debconf: Impossible d'initialiser l'interface\uffff: Gnome
debconf: (Unable to load Gnome -- is libgnome2-perl installed?)
debconf: Utilisation de l'interface Dialog en.....

#2

pour gnome : Cela peut arriver lorsque les mises à jour ne sont pas toujours faites avec le même outil (il y a un post récent sur ce sujet)
-> remède : toujours utiliser le même outil, et dans ce cas réinstaller gnome avec aptitude ( # aptitude donc avec les droits root) ou apt-get. Si comme moi tu débutes, aptitude comnine les avantages de apt (console) et de synaptic (on a la jiste des paquets à l’écran, on peut faire des recherches, on a un menu pour choisir son action …)

pour le serveur X qui ne démarre pas : si la mise à joir est sarge -> etch, c’est normal car xfree86 a été remplacé par xorg. Il faut donc configurer ce dernier par (# et $ ne sont pas à taper)
$ su
$ mot_de_passe_root
$ dpkg-reconfigure xserver-xorg
si soucis, choisir vesa comme type de carte : c’est le dénomonateur commun
installer ensuite son pilote ou radeon pour un radeon ATI, nv si nvidia pas trop récent (fonctionne pas chez moi), … suivant le type de carte graphique

Bon courage :smt006


#3

Ce qui me surprend c’est que tu sois obligé à tout prix de changer de noyau pour supporter cette carte Wifi.

Tu ne nous dis pas quel noyau actuel tu avais (avant le 2.6.15) et ce que tu as tenté pour activer ta carte Wifi et quels résultats as-tu obtenu ?
Pour connaître ton noyau actuel (pas le 2.6.15), tape en console :


#4

ginkgo biloba > j’ai deja essayé tout ca, ca ne passe pas, j’ai toujours l’erreur avec debconf et gnome qui ne peut pas etre chargé

Korben Dallas> j’avais la version 2.6.8.2, puis je suis passé a la 2.6.8.3, en version 386 686, j’ai aussi essayé avec les 2 kernel AMD64
J’ai formaté le disque entre les version x86 et amd64 pour etre sur…


#5

[quote=“vohu”]Korben Dallas> j’avais la version 2.6.8.2, puis je suis passé a la 2.6.8.3, en version 386 686, j’ai aussi essayé avec les 2 kernel AMD64
J’ai formaté le disque entre les version x86 et amd64 pour etre sur…[/quote]
As-tu testé avec une Live Cd du genre Knoppix ?

J’ai lu un fil qui parle de l’installation de ce module http://forums.knoppix-fr.org/viewtopic.php?pid=68400


#6

Knoppix ne passe pas sur mon pc, amd64

Mias ma ubuntu fonctionne parfaitement avec un 2.6.12

Je viens de rechanger mon sources.list… en testing… je vais essayer de modifier les autres fichiers pour ne pas detruire mon gnome quand il fera la mise a jour… ca fait 9 fois que je recomence, ca commence a me ronger


#7

si ça te ronge, c’est parceque tu recommences. Resouds un à un tous les problêmes, et un jour, ta debian sera parfaite. Chaque fois que tu recommences, tu te prépares de nouveaux problêmes.
Une debian ne se reinstalle pas.

Par ailleurs, je ne suis pas en 64 donc je ne serais pas le meilleurs pour t’aider, mais de deux choses l’une: ou bien tu fais une machine 32 bits pure, et tu n’installes aucun soft en 64bitsz, ou bien tu installes en 64, avec un chroot en 32. Essayer un noyau 64bits alors que tes programmes sont des 32 bits est une erreur.


#8

J’ai l’impression que beaucoup ont des soucis avec les processeurs 64 bits :cry:

Je ne comprends pas tout : tu es en Ubuntu ou Debian ?

Irrémédiablement, la même manipulation te donnera le même résultat et c’est heureux.
Concernant tes problèmes de paquets, soit attentif à utiliser toujours le même applicatif de gestion des paquets, comme l’a dit ginkgo biloba. Nous avons été plusieurs ici, à constater des écarts entre apt, aptitude, synaptic, lors des upgrade ou dist-upgrade.
L’installation d’un noyau trop récent sous Sarge (Stable) oblige à supprimer hotplug et installer une certaine version de udev qui génère pas mal de dégâts dans les paquets Sarge. Peut-être est-ce l’origine de ton problème.

D’où le conseil de basculer complètement en Testing qui est un bon compromis sur une machine de bureau.


#9

MattOTop> je sais qu’il ne faut pas reinstaller, mais avant d’avoir penser a faire un bck du menu de grub, j’étais bien emmerdé quand il m’enlevait toutes mes entrées…

cela dit, ne t’inquiete pas, je ne mélange pas le amd64 avec les autres, c’est pour ca que je formate quand je passe de l’un a l’autre… mais la j’ai decidé de rester en 32, le temps de comprendre tout ca… meme si ma brouette avance encore moins vite qu’elle le devrait :smiley:

Korben Dallas > j’ai un multiboot windows ubuntu debian (heureusement dailleur, ma ubuntu me permet de venir faire un tour sur le forum quand plus rien ne fonctionne)

Je n’arrive toujours pas malgres la creation du fichier preference pour apt à passer sur etch, lorsque je fais apt-get dist-upgrade, udev est toujours dans la liste des programmes a desinstaller
Je peux faire quoi ?


#10

Euh, si tu viens de sarge, il y a quelquechose que je ne comprends pas, parcequ’il n’existe pas en sarge en ce moment:

meraude:~$ apt-cache policy udev udev: Installé : 0.089-1 Candidat : 0.089-1 Table de version : 0.090-4 0 987 http://ftp2.fr.debian.org sid/main Packages *** 0.089-1 0 997 http://ftp2.fr.debian.org etch/main Packages 100 /var/lib/dpkg/status
tu regardes quelle version de udev tu as en etch, et ensuite tu fais ton dist-upgrade, mais AVEC APTITUDE.
S’il te dit encore qu’il veut désinstaller udev, quand il te demande s’il peut continuer, tu tapes +udev= (tu peux aussi faire ? pour comprendre ce que tu fais).
Il devrait te proposer une autre combinaison de paquet qui accepte de garder udev.
sinon, quand tu réponds ‘n’ (pas ‘q’) il passe à une autre combinaison de paquet, jusqu’a ce que tu en acceptes une, ou que tu quittes aptitude.


#11

je l’ai dans stable : /

vohudebian:/home/vohu# apt-cache policy udev udev: Installé : 0.056-3 Candidat : 0.089-1 Table de version : 0.091-1 0 33 http://ftp.fr.debian.org unstable/main Packages 0.089-1 0 550 http://ftp.fr.debian.org etch/main Packages *** 0.056-3 0 550 http://ftp.fr.debian.org stable/main Packages 100 /var/lib/dpkg/status vohudebian:/home/vohu#

ca devient assez pesant j’avoue : /
Je me rends compte que j’ai une partie qui est passée en testing (gnome) et que le systeme de base lui, est toujours en stable… j’en suis arrivé la en faisant un


#12

Bizarre cette histoire d’udev !

Il existe pourtant bien des paquets dans toutes les versions :
http://packages.debian.org/cgi-bin/search_packages.pl?keywords=udev&searchon=names&subword=1&version=all&release=all


#13

[quote=“vohu”]je l’ai dans stable : /

vohudebian:/home/vohu# apt-cache policy udev udev: Installé : 0.056-3 Candidat : 0.089-1 Table de version : 0.091-1 0 33 http://ftp.fr.debian.org unstable/main Packages 0.089-1 0 550 http://ftp.fr.debian.org etch/main Packages *** 0.056-3 0 550 http://ftp.fr.debian.org stable/main Packages 100 /var/lib/dpkg/status vohudebian:/home/vohu# [/quote]
Tout à fait d’accord avec vohu.


#14

je tente la mise a jour avec apt-get upgrade ?
que devrais je faire si gnome ne démarre plus, pour annuler la dernière opération ?

j’attends la réponse cette fois :smiley: (parce que d’abitude, je fais ma connerie, et je demande apres >:]
(j’ai mis le code de sources.list et preferences plus bas)

et encore une petite chose avec synaptic (je sais, je fais tout en meme temps et c’est pas bien :$)
cette fois quand je veux installer le nouveau kernel, il me desinstalle hotplug, je suppose que c’est pas bon signe ?
par contre udev n’est que mis a jour, alors qu’avant il était supprimé

vohudebian:~# apt-get -t testing install linux-image-2.6.15-1-686 Lecture des listes de paquets... Fait Construction de l'arbre des dépendances... Fait Les paquets supplémentaires suivants seront installés : busybox gnome-applets-data initramfs-tools klibc-utils libklibc udev Paquets suggérés : linux-doc-2.6.15 linux-source-2.6.15 lilo Paquets recommandés : libc6-i686 Les paquets suivants seront ENLEVÉS : gnome-applets gnome-core gnome-desktop-environment gnome-office gnome-volume-manager hal hotplug Les NOUVEAUX paquets suivants seront installés : busybox initramfs-tools klibc-utils libklibc linux-image-2.6.15-1-686 Les paquets suivants seront mis à jour : gnome-applets-data udev 2 mis à jour, 5 nouvellement installés, 7 à enlever et 573 non mis à jour. Il est nécessaire de prendre 23,5Mo dans les archives. Après dépaquetage, 46,6Mo d'espace disque supplémentaires seront utilisés. Souhaitez-vous continuer ? [O/n]

[code]# Stable

deb http://security.debian.org stable/updates main contrib non-free

deb-src http://security.debian.org/ stable/updates main contrib non-free
deb http://ftp.fr.debian.org/debian stable main contrib non-free
deb-src http://ftp.fr.debian.org/debian stable main contrib non-free

Testing

deb http://security.debian.org etch/updates main contrib non-free
deb-src http://security.debian.org/ etch/updates main contrib non-free
deb http://ftp.fr.debian.org/debian etch main contrib non-free
deb-src http://ftp.fr.debian.org/debian etch main contrib non-free

Unstable

deb http://ftp.fr.debian.org/debian unstable main contrib non-free
deb-src http://ftp.fr.debian.org/debian unstable main contrib non-free

#mirroir video et autre http://debian.video.free.fr/
deb ftp://ftp.nerim.net/debian-marillat/ sarge main
deb ftp://ftp.nerim.net/debian-marillat/ etch main

Skype

deb http://download.skype.com/linux/repos/debian/ stable non-free

WINE

deb http://wine.sourceforge.net/apt/ binary/
deb-src http://wine.sourceforge.net/apt/ source/

Package non officiel

deb http://ftp.debian-unofficial.org/debian sarge main contrib non-free restricted
deb-src http://ftp.debian-unofficial.org/debian sarge main contrib non-free restricted

Videolan VLC

deb http://download.videolan.org/pub/videolan/debian sarge main
deb-src http://download.videolan.org/pub/videolan/debian sarge main
[/code]

[code]Package: *
Pin: release a=testing
Pin-Priority: 550

Package: *
Pin: release a=apt-build
Pin-Priority: 990

Package: *
Pin: release a=stable
Pin-Priority: 550

Package: *
Pin: release a=unstable
Pin-Priority: 33

Package: *
Pin: release a=experimental
Pin-Priority: 15

Package: linux-image-2.6.*
Pin: release a=unstable
Pin-Priority: 550

Package: linux-header-2.6.*
Pin: release a=unstable
Pin-Priority: 550

Package: linux-source-2.6.*
Pin: release a=unstable
Pin-Priority: 550
[/code][/quote]


#15

[quote=“vohu”]et encore une petite chose avec synaptic (je sais, je fais tout en meme temps et c’est pas bien :$)
cette fois quand je veux installer le nouveau kernel, il me desinstalle hotplug, je suppose que c’est pas bon signe ?
par contre udev n’est que mis a jour, alors qu’avant il était supprimé[/quote]
Ca c’est tout à fait normal, la nouvelle version d’udev est en conflit avec hotplug.

Mais si tu aimes synaptic, fais tout avec lui, ne teste pas aptitude, apt, ET synaptic, sinon tu auras de gros ennuis.


#16

bon, j’ai manifestement un problême de mon coté…
vohu, ce qu’il te propose me parait sain.
Si je peux me permettre, dans tes préfèrences, tu devrais distinguer stable de testing (600 pour testing, ça revient au même) et différencier toutes les sources en 500, pour pouvoir être sûr de l’ordre dans lequel tu les privilègies (et ne pas attendre qu’elles respectent des numéros de version toujours dans le même ordre).

mais surtout rajouter dans tes sources les # security deb http://security.debian.org/ sarge/updates main contrib non-free deb-src http://security.debian.org/ sarge/updates main contrib non-free deb http://security.debian.org/ etch/updates main contrib non-free deb-src http://security.debian.org/ etch/updates main contrib non-free et les prioriser

tu peux aussi si tu utilises un antivirus, ou un truc que tu dois mettre à jour régulièrement utiliser les sources # volatile deb ftp://ftp2.de.debian.org/debian-volatile stable/volatile main contrib non-free deb-src ftp://ftp2.de.debian.org/debian-volatile stable/volatile main contrib non-free
par ailleurs, tes pinning particulier pour les 2.6 font doublon avec les priorités que tu as données à l’etch et à la sarge toutes entières.

Enfin bon, ceci étant, ca c’est pour aprés, parcequ’en l’etat de tes préfèrences, tu n’as pas besoin de préciser -t testing, parceque de toutes les manières, tu es par défaut en etch (testing) :wink:

alors ça va bien t’installer le bon noyau, mais si tu veux rester en sarge, tu as intèret à corriger tes préfèrences, et mettre la testing en dessous de la stable dans tes priorités (et même en dessous de 100 d’aprés la doc).

Sinon, ca ne me parait pas anormal, pour le hotplug.
Au pire, tu perdra des automatismes à l’insertion d’un CD, ou d’un dispositif USB, mais si c’est le cas, rien ne t’empècheras de le reinstaller.

sinon, si tu veux des conseils sur tes préfèrences, penses à mettre le résultat d ‘apt-cache policy’


#17

[quote=“Korben Dallas”][quote=“vohu”]et encore une petite chose avec synaptic (je sais, je fais tout en meme temps et c’est pas bien :$)
cette fois quand je veux installer le nouveau kernel, il me desinstalle hotplug, je suppose que c’est pas bon signe ?
par contre udev n’est que mis a jour, alors qu’avant il était supprimé[/quote]
Ca c’est tout à fait normal, la nouvelle version d’udev est en conflit avec hotplug.

Mais si tu aimes synaptic, fais tout avec lui, ne teste pas aptitude, apt, ET synaptic, sinon tu auras de gros ennuis.[/quote]Korben, arrètes de dire ça ! c’est faux, il n’y a pas plus de problême à utiliser les trois que de n’en utiliser qu’un. Je ne vois pas ce qui te permets de dire ça.


#18

j’aime bien apt, mais quand gdm fonctionne, c’est vrai que j’ai tendance a utiliser synpatic… je vais m’y faire, synaptic ne focntionne pas quand tout est bousillé…

je ne sais toujours pas quoi faire : / avec ces 351 paquets qui attendent la mise a jour… j’en fait quoi ?


#19

En fait, ce qui te gène, c’est qu’il ne te propose pas les mêmes solutions d’installation d’un lot de paquet, mais c’est normal.
Comme je te l’ai, je crois, déjà dit, ils utilisent simplement des stratègies de sélection de paquet différentes. aptitude est même capable de te proposer toutes les solutions d’install cohérentes qu’il peut déterminer.
L’installation d’un lot de paquets est un choix qui se fait dans un ensemble de solutions possibles, et il y en a qui marchent, d’autres pas (et on le signale comme bug). La stratègie d’install des uns et des autres n’est pas nécessairement tout le temps meilleure si tu n’utilise qu’un des outils.
Sauf peut être l’usage d’aptitude qui est l’outil de réfèrence actuel de debian (donc testé en premier lors des préparation des mises à jour des dépots).
Tu vois mieux ? je t’ai convaincu ?


#20

Et pour en rajouter, j’utilise indifféremment tous les outils sur toutes mes machines, et sur celle ou je suis peureux (mes serveurs) je prends toujours la solution qui me fait le moins de modif d’un coup, et ce n’est pas toujours le même outil (mais souvent apt-get), et sur les machines ou je peux me permettre d’être casse cou, je fais allègrement des dist upgrade, avec pas plus d’une journée au total de fonctionnement dégradé par an.