[Résolu] Grub et sa config


#1

Bonsoir,

Je me suis amusé à transferer mes différentes parties de ma debian sur mon disque dur de 80 Go. Le problème ,c’est que je n’arrive pas à dire à Grub d’aller voir sur hdb1 au boot et non sur hda3.

Dans ma logique, je dirais que dans la config de grub je dois mettre le boot sur la partition hdb1 qui est ma partition racine et qui comprend le répertoire /boot

j’ai donc actuellement une erreur 15 au stage 1.5 du lancement de grub ce qui correspond au fait qu’il ne trouve pas la bonne partition. J’ai essayé différentes solutions trouvés sur google et j’ai aussi regardé la doc et testé d’autres solutions que je pensais etre juste mais je n’y arrive toujours pas.

J’ai la possibilité de modifer la config de grub par live-cd mais la je bloque complètement sur celle-ci

j’ai deux disques dur hda et hdb (logique me direz-vous )

sur hda3 (partition contenant anciennement debian) je n’ai plus rien et apparement c’est sur cette partition que grub cherche sa config.
sur hdb1 j’ai ma partition racine comprenant tout mis a part home usr tmp et var.

/boot se trouve sur hdb1

N’étant pas sur mon pc actuellement je ne peux pas vous en dire plus mais si vous avez besoin de plus d’info pour m’aider n’hésitez pas a me le dire je m’arrangerais pour vous transmettre ces infos quitte a les recopier a la main.

Serait-il donc possible que l’on me guide dans cette config car la j’avoue j’ai un peu de mal :blush:


#2

il faudrait ton menu.lst au cas où mais je pencherais plutôt pour le flag d’activation de la partition au boot qui ne doit pas être présent.

pour l’activer “fdisk /dev/hdb” (en su) ensuite “a” puis tu choisit la partition à activer pour vérifier tu fais juste “p” tu dois voir une * devans la partition que tu souhaites activée au boot , reste plus qu’a sauvegarder la table de partition “wq”.


#3

Si tu peux entrer ds le menu.lst du grub de ta dernière installation, tu places en tête celle que tu veux voir démarrer.
Si je comprends bien, tu devrais aller ds
hda3 /boot/grub/menu.lst
et palcer en tête les 4 ou 5 lignes qui concernent hdb1

Bien sûr, j’ai relu et tu dis que tu n’as plus rien sur hda3 :cry:
Vérifie quand m^ s’il n’y a pas un menu.lst qui traîne.


#4

D’abord merci pour vos réponses.

Maintenant, j’y réponds :slightly_smiling:

Le flag boot est bien activé sur hdb1 il l’est aussi sur hda1 est-ce que ca pourrait venir de la ???

voici la config actuelle de menu.lst se trouvant dans le rep /boot sur hdb1

[code]title Debian 2.6.11-seal
root (hd1,1)
kernel /boot/vmlinuz-2.6.11-seal root=/dev/hdb1 ro
initrd /boot/initrd.img-2.6.11-seal
savedefault
boot

title Debian 2.6.11-seal (recovery)
root (hd1,1)
kernel /boot/vmlinuz-2.6.11-seal root=/dev/hdb1 ro
initrd /boot/initrd.img-2.6.11-seal
savedefault
boot
[/code]

J’ai gardé mon menu.lst d’avant qui fonctionnais correctement lorsqu’il est sur hda3 le voici

[code]title Debian 2.6.11-seal
root (hd0,2)
kernel /boot/vmlinuz-2.6.11-seal root=/dev/hda3 ro single
initrd /boot/initrd.img-2.6.11-seal
savedefault
boot

title Debian 2.6.11-seal (recovery)
root (hd0,2)
kernel /boot/vmlinuz-2.6.11-seal root=/dev/hda3 ro single
initrd /boot/initrd.img-2.6.11-seal
savedefault
boot[/code]

L’objectif étant de laissé le boot sur hdb1 et de le faire fonctionner sans avoir besoin de mettre quoi que ce soit sur hda3.

Si je remet mon répertoire /boot sur hda3 alors j’arrive a voir grub se lancer et j’ai les differents choix mais si je lance le boot sur la 2.6.11-seal ben j’obtiens un beau kernel panic.

Voila pour les infos que je peux vous donner en plus.

ps: j’ai une partition windows que je dois garder sur hda


#5

Si je ne me trompe pas /boot et / sont sur la même partition ? Pourquoi mets-tu :

root (hd1,1) --> (/boot sur la partition 2 du disque b)
root=/dev/hdb1 --> (/ sur la partition 1 du disque b)

Pourquoi répète-tu 2 fois la même entrée dans menu.lst (tu charges le mode normal pour recovery au lieu de single) ?

Pas de pb pour les flag boot, j’ai moi-même un flag boot sur chaque disque.

Tu as bien fait grub-install pour installer ta config grub sur le disque que tu veux ? (peu importe lequel)


#6

C’est un peu coufus ton affaire :cry:
Reprenons :
A l’allumage, c’est bien le hda3 qui s’ouvre ?
Si oui, considère ce seul /boot/grub/menu.lst
ouvre le sous root et place en tête celui que tu veux avoir au démarrage càd hdb1, si j’ai bien suivi.
Si tt ça est bon, voilà comment je verrais ton menu.lst du hda3 :

[code]title Debian 2.6.11-seal
root (hd1,1)
kernel /boot/vmlinuz-2.6.11-seal root=/dev/hdb1 ro
initrd /boot/initrd.img-2.6.11-seal
savedefault
boot

title Debian 2.6.11-seal
root (hd0,2)
kernel /boot/vmlinuz-2.6.11-seal root=/dev/hda3 ro single
initrd /boot/initrd.img-2.6.11-seal
savedefault
boot [/code]


#7

[quote]ps: j’ai une partition windows que je dois garder sur hda
_________________[/quote]
Où elle est cette partoche car il n’en est pas question ds le menu.lst que tu ns montres ?
Fais-ns une copie totale du menu.lst de la partition qui s’ouvre.


#8

Bon apparement je m’explique très mal :slightly_smiling: je vais essayé d’éclairer tout ca

Au démarrage j’avais toute une partition de 10go (hda3) réservé a debian c’etait pour la testé. Lors de l’install je n’avais fait que deux partitions une pour l’install complete et la swap.

[quote=“Ricardo”]A l’allumage, c’est bien le hda3 qui s’ouvre ? [/quote]Oui c’est bien sur hda3 qu’il va voir la config mais je veux qu’il aille le voir sur hdb1 car j’ai transferé mes données la-bas. Ce que je pense faisable c’est de faire fonctionner grub en laissant le boot sur hda3 et de le déplacer une fois fonctionnel.

ce qui donnais donc pour le disque hda
partition windows partition debian et swap

J’ai fait l’acquisition d’un disque dur de 80go sur lequel j’ai transferé tout ce qu’il y avait sur la partition de 10go réservé a debian pour lui laisser un peu plus de place et ceci en partitionnant le disque hdb

ce qui me donne donc maintenant la meme chose pour le hda mais maintenant pour hdb j’ai
partition racine hdb1
partition home hdb5
partition var hdb6
partition usr hdb2
partition tmp hdb7

j’ai tout transferé sur hdb en respectant les partitions mais maintenant il reste a configurer grub pour qu’il prenne en compte tout ca. C’est a dire oublié completement hda3 et le remplacer par hdb1.

J’ai essayé un grub-install mais ou meme differents autres moyens et je doit me tromper au niveau des partitions car il me dit qu’il ne les reconnais pas :confused:

Voici le menu.lst initiale sur la partition hda3 que j’ai reussi a copier sur cle usb avec windows :slightly_smiling:

[code]# menu.lst - See: grub(8), info grub, update-grub(8)

grub-install(8), grub-floppy(8),

grub-md5-crypt, /usr/share/doc/grub

and /usr/share/doc/grub-doc/.

default num

Set the default entry to the entry number NUM. Numbering starts from 0, and

the entry number 0 is the default if the command is not used.

You can specify ‘saved’ instead of a number. In this case, the default entry

is the entry saved with the command ‘savedefault’.

default 0

timeout sec

Set a timeout, in SEC seconds, before automatically booting the default entry

(normally the first entry defined).

timeout 5

Pretty colours

color cyan/blue white/blue

password [’–md5’] passwd

If used in the first section of a menu file, disable all interactive editing

control (menu entry editor and command-line) and entries protected by the

command ‘lock’

e.g. password topsecret

password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/

password topsecret

examples

title Windows 95/98/NT/2000

root (hd0,0)

makeactive

chainloader +1

title Linux

root (hd0,1)

kernel /vmlinuz root=/dev/hda2 ro

Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

BEGIN AUTOMAGIC KERNELS LIST

lines between the AUTOMAGIC KERNELS LIST markers will be modified

by the debian update-grub script except for the default options below

DO NOT UNCOMMENT THEM, Just edit them to your needs

## Start Default Options

default kernel options

default kernel options for automagic boot options

If you want special options for specific kernels use kopt_x_y_z

where x.y.z is kernel version. Minor versions can be omitted.

e.g. kopt=root=/dev/hda1 ro

kopt_2_6_8=root=/dev/hdc1 ro

kopt_2_6_8_2_686=root=/dev/hdc2 ro

kopt=root=/dev/hda3 ro

default grub root device

e.g. groot=(hd0,0)

groot=(hd0,2)

should update-grub create alternative automagic boot options

e.g. alternative=true

alternative=false

alternative=true

should update-grub lock alternative automagic boot options

e.g. lockalternative=true

lockalternative=false

lockalternative=false

additional options to use with the default boot option, but not with the

alternatives

e.g. defoptions=vga=791 resume=/dev/hda5

defoptions=

altoption boot targets option

multiple altoptions lines are allowed

e.g. altoptions=(extra menu suffix) extra boot options

altoptions=(recovery mode) single

altoptions=(recovery mode) single

controls how many kernels should be put into the menu.lst

only counts the first occurence of a kernel, not the

alternative kernel options

e.g. howmany=all

howmany=7

howmany=all

should update-grub create memtest86 boot option

e.g. memtest86=true

memtest86=false

memtest86=true

## End Default Options

title Debian GNU/Linux, kernel 2.6.11-seal
root (hd0,2)
kernel /boot/vmlinuz-2.6.11-seal root=/dev/hda3 ro
initrd /boot/initrd.img-2.6.11-seal
savedefault
boot

title Debian GNU/Linux, kernel 2.6.11-seal (recovery mode)
root (hd0,2)
kernel /boot/vmlinuz-2.6.11-seal root=/dev/hda3 ro single
initrd /boot/initrd.img-2.6.11-seal
savedefault
boot

END DEBIAN AUTOMAGIC KERNELS LIST

This is a divider, added to separate the menu items below from the Debian

ones.

title Other operating systems:
root

This entry automatically added by the Debian installer for a non-linux OS

on /dev/hda1

title Windows NT/2000/XP
root (hd0,0)
savedefault
makeactive
chainloader +1

[/code]et maintenant le menu.lst se trouvant sur hdb1

[code]# menu.lst - See: grub(8), info grub, update-grub(8)

grub-install(8), grub-floppy(8),

grub-md5-crypt, /usr/share/doc/grub

and /usr/share/doc/grub-doc/.

default num

Set the default entry to the entry number NUM. Numbering starts from 0, and

the entry number 0 is the default if the command is not used.

You can specify ‘saved’ instead of a number. In this case, the default entry

is the entry saved with the command ‘savedefault’.

default 0

timeout sec

Set a timeout, in SEC seconds, before automatically booting the default entry

(normally the first entry defined).

timeout 5

Pretty colours

color cyan/blue white/blue

password [’–md5’] passwd

If used in the first section of a menu file, disable all interactive editing

control (menu entry editor and command-line) and entries protected by the

command ‘lock’

e.g. password topsecret

password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/

password topsecret

examples

title Windows 95/98/NT/2000

root (hd0,0)

makeactive

chainloader +1

title Linux

root (hd0,1)

kernel /vmlinuz root=/dev/hda2 ro

Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

BEGIN AUTOMAGIC KERNELS LIST

lines between the AUTOMAGIC KERNELS LIST markers will be modified

by the debian update-grub script except for the default options below

DO NOT UNCOMMENT THEM, Just edit them to your needs

## Start Default Options

default kernel options

default kernel options for automagic boot options

If you want special options for specific kernels use kopt_x_y_z

where x.y.z is kernel version. Minor versions can be omitted.

e.g. kopt=root=/dev/hda1 ro

kopt_2_6_8=root=/dev/hdc1 ro

kopt_2_6_8_2_686=root=/dev/hdc2 ro

kopt=root=/dev/hda3 ro

default grub root device

e.g. groot=(hd0,0)

groot=(hd0,2)

should update-grub create alternative automagic boot options

e.g. alternative=true

alternative=false

alternative=true

should update-grub lock alternative automagic boot options

e.g. lockalternative=true

lockalternative=false

lockalternative=false

additional options to use with the default boot option, but not with the

alternatives

e.g. defoptions=vga=791 resume=/dev/hda5

defoptions=

altoption boot targets option

multiple altoptions lines are allowed

e.g. altoptions=(extra menu suffix) extra boot options

altoptions=(recovery mode) single

altoptions=(recovery mode) single

controls how many kernels should be put into the menu.lst

only counts the first occurence of a kernel, not the

alternative kernel options

e.g. howmany=all

howmany=7

howmany=all

should update-grub create memtest86 boot option

e.g. memtest86=true

memtest86=false

memtest86=true

## End Default Options

title Debian GNU/Linux, kernel 2.6.11-seal
root (hd1,1)
kernel /boot/vmlinuz-2.6.11-seal root=/dev/hdb1 ro
initrd /boot/initrd.img-2.6.11-seal
savedefault
boot

title Debian GNU/Linux, kernel 2.6.11-seal (recovery mode)
root (hd1,1)
kernel /boot/vmlinuz-2.6.11-seal root=/dev/hdb1 ro single
initrd /boot/initrd.img-2.6.11-seal
savedefault
boot

END DEBIAN AUTOMAGIC KERNELS LIST

This is a divider, added to separate the menu items below from the Debian

ones.

title Other operating systems:
root

This entry automatically added by the Debian installer for a non-linux OS

on /dev/hda1

title Windows NT/2000/XP
root (hd0,0)
savedefault
makeactive
chainloader +1

[/code]lorsque je vire completment tout ce qu’il y a sur hda3 afin de ne laisser que ce que je veux avoir c’est a dire la config complete sur hdb il ne me trouve pas la partition de démarrage et ne lance pas grub.

Si je laisse le repertoire /boot sur hda3 et que je le configure je peux booter sous windows mais si j’essaye linux j’obtiens soit un kernel panic soit il ne reconnait pas la partition.

Pour plus d’info sur ce que j’ai fait et ce que je veux faire voir mon autre post forum.debian-fr.org/viewtopic.php?t=2465


#9

Vite fait car je n’ai pas encore bien compris et je vais relire :

tu as essayé en mettant 1 ?


#10

Bon, apparemment, tu n’as rien modifé de ce que je t’ai dit plus haut.
On reprend :
En admettant que tes DD soient branchés ts les deux.
Tu t’arranges pour aller sur ton hda3,
tu édites, sous root, ton /boot/grub/menu.lst
J’ai bien écrit : hda3
entre :

et

tu écris

title Debian GNU/Linux, kernel 2.6.11-seal root (hd1,0) kernel /boot/vmlinuz-2.6.11-seal root=/dev/hdb1 ro initrd /boot/initrd.img-2.6.11-seal savedefault boot
Je pense que ça devrait marcher

PS :
Si ça fonctionne, pour ta punition, tu devras trouver ce qui clochait et qui saute aux yeux :wink:


#11

Bon ben merci Ricardo problème en voie de résolution.

Je boot bien maintenant sur debian avec ce que tu propose comme config de grub (pour la solution ce ne serait pas par hasard un problème au niveau du début de nommage de partition 0 au lieu de 1)

Bon ben maintenant que c’est fait j’en ai 2 autres de problèmes.

1-> Je souhaite transférer mon répertoire /boot se trouvant sur hda3 dans ma partition racine se trouvant sur hdb1.

2-> Impossible de me logguer kdm se lance je tape le login et le mot de passe et je reviens a kdm pas d’interface graphique. J’y regarde et j’ouvre un post après exprès pour.

Comment dire à grub de regarder sa config maintenant sur hdb1 et non plus sur hda3.


#12

Ash, rassure-moi, tu avais lu mon post ? :mrgreen:


#13

Tu n’es pas loin :laughing:

[quote]title Debian GNU/Linux, kernel 2.6.11-seal
root (hd1,1)
kernel /boot/vmlinuz-2.6.11-seal root=/dev/hdb1 ro
initrd /boot/initrd.img-2.6.11-seal
savedefault
boot [/quote]
Ton / est en hdb1 et, ligne au dessus, tu avais écrit (hd1,1) or le ‘b’ équivaut à 1 et là tu as bon mais le ‘1’ équivaut à 0 donc en mettant (hd1,1), tu ouvrais le hdb2

Pour le reste, je crois qu’il faut que tu reconfigure grub mais je laisse le soin aux autres d’expliquer[/quote]


#14

Oui j’ai bien lu tout les posts mais le probleme c’est que j’avais essayé différentes solutions qui y ressemblait mais qui ne fonctionnait pas et j’ai très peu dormis ces derniers jours donc difficile d’analyser et de comprendre ce qui est proposé même si ca parait simple :slightly_smiling:

le probleme grub étant a moitié solutionné je peux maintenant booter je verrais pour améliorer tout ca apres la en ce moment le probleme c’est X qui ne se lance qu’en root et pas en user :confused: :question:

Je fait quelques recherches avant de venir poser mes questions :slightly_smiling:


#15

Crée-toi un nouvel ‘user’ .


#16

J’ai essayé avec un nouvel user j’ai aussi essayé en modifiant les droits sur un fichier qu’il n’arrivait pas a lire mais je retombe sur d’autres probleme de droits dans /tmp. J’ai l’impression qu’il y aurais quelque chose de plus simple à faire mais je ne vois pas quoi pour le moment.

Toujours est-il que je n’arrive toujours pas a lancé X en tant qu’user mais seulement en tant que root. Je continue mes recherches :slightly_smiling:


#17

[quote]2-> Impossible de me logguer kdm se lance je tape le login et le mot de passe et je reviens a kdm pas d’interface graphique. J’y regarde et j’ouvre un post après exprès pour. [/quote]As-tu essayé :
dpkg-reconfigure xserver-xorg
?


#18

essaie aussi :

chmod 1777 /tmp

sans oublier le ‘1 (un)’ devant 777


#19

Que ca fait plaisir de revenir sur sa session normale :slightly_smiling:

Merci Ricardo c’etait bien un chmod 1777 qui manquais :slightly_smiling: j’avais déjà essayé la reconfiguration sans succes :slightly_smiling:

Reste plus qu’a bouger mon /boot et c’est finis

Merci encore :slightly_smiling:


#20

Alors, passons à Grub maintenant :laughing: :
Je te recopie en vrac les notes que j’avais prises, je ne sais plus d’où :
En admettant que ta partoche où il y a /boot soit hdb1, si je ne me trompe pas donc ça équivaut à (hd1,0)
–lancer le shell de grub en console

grub

–indiquer où se trouve la partoche

grub> root (hd1,0)

–indiquer où il doit se placer

grub> setup (hd1)

là, en principe, grub se place sur le ‘mbr’

grub> quit

J’espère que ça marchera :question: