[RÉSOLU] k3b sous kde 3.4 : install impossible


#1

Quand j’essaie d’installer k3b sur ma Debian en kde 3.4, voilà ce que j’obtiens :

[code]ricardo:/home/ricardo# apt-get install k3b/stable
Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances… Fait
Version choisie 0.11.20-1 (Debian:3.1r0/stable) pour k3b
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l’impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n’ont pas encore
été créés ou ne sont pas sortis d’Incoming.

Puisque vous n’avez demandé qu’une seule opération, le paquet n’est
probablement pas installable et vous devriez envoyer un rapport de bogue.
L’information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
k3b: Dépend: k3blibs (>= 0.11.20) mais ne sera pas installé
Dépend: kdelibs4 (>= 4:3.3.2-1) mais ne sera pas installé
Dépend: libarts1 (>= 1.3.2) mais ne sera pas installé
Dépend: libqt3c102-mt (>= 3:3.3.3) mais ne sera pas installé
E: Paquets défectueux
ricardo:/home/ricardo#
[/code]
Comment faire sachant que les sources sont actuellement en stable et en testing ?
Même réponse en commentant les sources “testing”


#2

Décidemment … je vais finir par croire que tu le fais expres :open_mouth:

Relis bien mon post, dans son entiéreté, mot par mot, lentement, en respirant profondément:

forum.debian-fr.org/viewtopic.php?p=9735#9735


#3

Ben oui mais y trouve pas msieu :cry:

ricardo:/home/ricardo# apt-get install k3b/unstable Lecture des listes de paquets... Fait Construction de l'arbre des dépendances... Fait E: La version « unstable » de « k3b » est introuvable ricardo:/home/ricardo#
Bien sûr, j’ai décommenté mes sources unstable


#4

[quote=“ricardo”]Ben oui mais y trouve pas msieu :cry:

ricardo:/home/ricardo# apt-get install k3b/unstable Lecture des listes de paquets... Fait Construction de l'arbre des dépendances... Fait E: La version « unstable » de « k3b » est introuvable ricardo:/home/ricardo#
Bien sûr, j’ai décommenté mes sources unstable[/quote]

ah bon?

packages.debian.org/cgi-bin/sear … lla-search

[quote]Package k3b

* [b]stable[/b] (otherosfs): A sophisticated KDE cd burning application
  0.11.20-1: alpha amd64 arm hppa i386 ia64 m68k mips mipsel powerpc s390 sparc

* [b]unstable[/b] (otherosfs): A sophisticated KDE CD burning application
  0.12.7-1: alpha amd64 arm hppa i386 ia64 m68k powerpc s390 sparc
  0.12.5-1: mips mipsel[/quote]

#5

Ok merci, je tele tt ça demain et j’installe.
Bonne nuit.


#6

Allez, j’ai été courageux et j’ai installé tt ce qui manquait.
K3b tourne parfaitement maintenant.
Merci Docteur :wink:


#7

[quote=“ricardo”]Allez, j’ai été courageux et j’ai installé tt ce qui manquait.
K3b tourne parfaitement maintenant.
Merci Docteur :wink:[/quote]

De rien. Ca fera 20 EUR pour la consultation :laughing:


#8

Oui mais remboursé intégralement ou avec 1 € à ma charge :wink:


#9

cela n’est pas mon problème cela :wink:


#10

Moi aussi j’ai un problème avec k3b, mais apparemment pas tout à fait le même :

apt-get install k3b
[…]
Les paquets suivants contiennent des dépendances non satisfaites :
k3b: Dépend: k3blibs (>= 0.12.7) mais ne sera pas installé
Dépend: libstdc++6 (>= 4.0.2-3) mais 4.0.2-2 devra être installé
E: Paquets défectueux

Tout ça depuis un apt-get dist-upgrade :frowning:


#11

donne nous le resultat de:


#12

packages.debian.org/cgi-bin/sear … chon=names

et

packages.debian.org/cgi-bin/sear … lla-search

tu dois installer ces deux packages depuis la version unstable.

si tu as un amd64, tu dois installer libstdc++6 en i386 car pour amd64 la version est encore en 4.0.2-2 et non 4.0.2-3


#13

un petit conseil: fais ça depuis Synaptic, tout sera automatique et donc beaucoup plus facile :wink:


#14

+1
mais tu auras certainement aussi des dépendances de dépendances à installer.
Il te le dira


#15

Voilà mon sources.list


deb ftp://ftp.proxad.net/mirrors/ftp.debian.org/ testing main contrib non-free
deb ftp://ftp.proxad.net/mirrors/ftp.debian.org/ unstable main contrib non-free

deb-src ftp://ftp.proxad.net/mirrors/ftp.debian.org/ testing main

deb security.debian.org/ testing/updates main contrib non-free

#— Blackdown jre (Java) —
deb ftp://ftp.easynet.be/blackdown/debian unstable main non-free

Evidemment j’ai un fichier de préférence pour installer les packages testing par défaut.

Le problème tourne autours de libstdc++6.

Ca me renvoie la même erreur en voulant installer K3blibs, et si j’installe depuis synaptic.


#16

j’ai pas lu tout le fil, mais deux solutions pour pas mal de pb de dépendances avec une release mixte:
utiliser dselect ou faire des dselect-upgrade avec apt-get
faire une install d’un paquet AVEC TOUTES SES DEPENDANCES dans une release particulière:
apt-get install -t
(qui donne une priorité 900 - ou 990 je ne sais plus - au paquet et à ses dépendances pour l’install)
++


#17

C’est assez “amusant” car je vient d’installer une Debian testing+unstable sur une autre machine, et j’arrive exactement dans la meme situation.


#18

oui et c’est le même chez Ricardo, chez moi et tout poste que tu installeras TANT QUE K3b ne passera pas en testing (les raisons sont expliquées ici, cfr “The package has not yet entered testing even though the 10-day delay is over. Check why.”).

la solution a été fournie depuis le début et je suis étonné que tu n’aies pas encore réussi à y remédier.

toutes les dépendances de K3b (celles pour lesquelles tu as un message explicite en ce y compris libstdc++6) doivent être installées également depuis le dépôt “unstable”; dans le cas contraire, K3b ne s’installera pas.

plus d’infos sur les dépendances requises de K3b ici: packages.debian.org/unstable/otherosfs/k3b

en conclusion, pour installer K3b (depuis le dépôt unstable), libstdc++6 doit être la version 4.0.2-3 disponible également uniquement en unstable.

à nouveau, je conseille d’utiliser Synaptic … tout sera automatique; simple comme bonjour.

où alors tu attends tranquillement que tout ça soit résolu est passe en testing …

@+


#19

J’avais bien compris que libstdc++ devait être en 4.0.2-3, mais lorsque je veut l’installer il sort également en erreur :

Les paquets suivants contiennent des dépendances non satisfaites : libstdc++6: Dépend: gcc-4.0-base (= 4.0.2-3) mais 4.0.2-2 devra être installé

et en essayant de le forcer, il m’avait proposé de me retirer plus de 200 packages… donc j’ai préféré en rester là pour le moment :wink:


#20

[quote=“Jean-Francois”]J’avais bien compris que libstdc++ devait être en 4.0.2-3, mais lorsque je veut l’installer il sort également en erreur :

[code]

Les paquets suivants contiennent des dépendances non satisfaites :
libstdc++6: Dépend: gcc-4.0-base (= 4.0.2-3) mais 4.0.2-2 devra être installé[/code]

et en essayant de le forcer, il m’avait proposé de me retirer plus de 200 packages… donc j’ai préféré en rester là pour le moment :wink:[/quote]

essaie avec Synaptic…