[resolu]postgres+phppgadmin


#1

Bonjour,

je viens installer postgresSQl +phppgadmin, mais apparament il accepte pas l’utilisateur root.
donc il faut que je créer des utilisateurs mais sans succes.

j’ai tester create user moi width password ‘hgd’

reate user  moi width password 'hgd'

#2

C’est normal root n’a aucun droit sur les bases de données postgresql essaye de te connecter sous postgres

et de créer un user

psql createuser burinho -d -r
ou alors connecte toi directement avec l’user postgres sur phppgadmin


#3

si j’utilise progres avec quel mot de passe


#4

Ben normalement tu devrais avoir un utilisateur posgres de créer avec un mot de passe déjà donné.
Si ce n’est pas le cas tu le créé ensuite tu lui affecte un mot de passe. (a faire en tant que root)

passwd postgres su postgres psql createuser ....


#5

a quoi cela correspond cette ligne surtout le su

[code]

su postgres
psql
createuser


#6

en fait postgres est le superadmin de ta base de données mais il lui faut certains droits

ensuite il faut te connecter donc

su postgres te connecte en tant qu’utilsateur postgres sur le terminal
tu lui donne le mot de passe que tu a créé par la commande passwd (celle avant)

ensuite tu lance psql pour te connecter a postgresql et ainsi faire les modifs des utilisateurs du SGBDR et enfin tu crée un utilisateur sur lequel tu pourra te connecter avec phppgadmin.


#7

bon ok j’ai créer un user avec createuser mais comment je l’attribue le mot de passe de mon nouveau utilisateur postgres


#8

quand tu utilise la commande create user il te demande, il créer un utilisateur mais pas son mot de passe.


#9

Ben tu as des options pour CREATE USER il suffit de lui préciser l’option password avec le mot de passe derriere

plus d’info voir postgresql.org/docs/8.1/stat … euser.html

Ce qui donne donc pour la creation d’un user avec mot de passe


#10

il faut mettre le point virgule dans tu créer ça sur console.

sinon comment donner un mot de passe à user qui est déjà créer, faut il le supprimer


#11

j’ai essaye la commande et il la reconnait pas


#12

Lorsque tu te trouve dans l’interface console de postgresql c’est a dire apres t’etre connecté en tant qu’user postgres et avoir lancé la commange psql, oui il ne faut surtout pas oublier le ; c’est ce qui finit la commande, fait quelques tests et tu verra des changements au niveau du prompt (=/-)

Pour la modification d’un user déjà créé je ne sais pas le plus simple c’est de le supprimer et de le recréer.


#13

[quote=“burinho”]j’ai essaye la commande et il la reconnait pas[/quote]Ca passe chez moi as tu bien fait tout ca

su postgres password: ********* psql CREATE USER burinho WITH ENCRYPTED PASSWORD 'motdepasse'; \q
Puis ensuite essayer de te connecter?


#14

quand je passe en su postgres il me demande pas de mot de passe

après quand je fais psql il me balance ceci

psql (pg_wrapper): No database specified


#15

que te renvois la commande psql -l


#16

ceci

Liste des bases de données Nom | Propriétaire | Encodage -----------+--------------+---------- template0 | postgres | LATIN9 template1 | postgres | LATIN9 (2 lignes)


#17

avant psql mais toujours sous l’utilisateur postgres tu crée une base de donnéescreatedb essaiet ensuite tu te connectepsql essai


#18

base bien crééer


#19

donc normalement tu devrais pouvoir te connecter maintenant avec la commande psql et apres créer l’user d’apres les posts précédents.

Une fois l’user créer reessaye de te connecter avec phppgadmin


#20

je comprend pas, j’arrive toujours pas a créer mon user, regarde les étapes que j’ai fais[code]

postgres@debian64:/$ psql
psql (pg_wrapper): No database specified
postgres@debian64:/$ CREATE USER burinho WITH ENCRYPTED PASSWORD ‘motdepasse’;
bash: CREATE: command not found
postgres@debian64:/$ psql -l
Liste des bases de données
Nom | Propriétaire | Encodage
-----------±-------------±---------
essai | postgres | LATIN9
template0 | postgres | LATIN9
template1 | postgres | LATIN9
(3 lignes)

postgres@debian64:/$
[/code]