[Resolu] Tout cassé!


#1

Par ordre chrono

J’ai donné une priorité de 50 supplementaire au dépot “deb backports.debian.org/debian/ sarge-backports main contrib non-free” pour avoir la version 2 de open office.

Je me suis retrouvé avec plein de paquets a mettre à jour mais comme je n’avais pas le temps j’ai repoussé à plus tard.

En cherchant à resoudre un problème avec kino j’ai voulu mettre udev à jour. Pendant l’installation je crois qu’il m’a virer gnome ou des paquets de gnome (genre gnome desktop…). Puis il m’a demandé mon avis pour installer un paquet kernel quelque chose en me precisant que dans le doute il fallait répondre non, ce que j’ai fait.

Message d’erreur il n’a pas fini l’installation, dépendances non satisfaites etc…

Au reboot serveur x en rade!
Il ne peut pas charger le module fglrx et plein d’autre chose.

J’essaye de reinstaller gnome apt-get… Impossible problème de dépendences non satisfaites…

La je suis sous win et je sais pas du tout quoi faire

:cry:


#2

Tu as fait un apt-get dist-upgrade et un apt-get install -f ?


#3

J’ai fait un apt-get install -f car le systeme me le proposais, mais il n’a pas fonctionné car il ne trouvait pas le depot backports.debian.org/debian/.

Je n’ai pas fait de apt-get dist-upgrade.

Je ne connais pas ces commandes, à quoi servent-elles?


#4

man apt-get devrait répondre à ce genre de questions, mais ‘install -f’ c’est pour forcer la résolution d’inconsistances dans la bdd d’apt, et dist-upgrade, contrairement au simple upgrade qui fait juste la mise à jour des paquets obsolètes, te propose une solution cohérente pour mettre à jour le maximum de paquets, même si la manip doit en désinstaller quelques uns.
De toutes les manières, avant de faire un (dist-)upgrade, il faut d’abord mettre à jour la liste des paquets dispos avec un update.
Et si tu as un problême avec une source, tu la commentes dans le fichier /etc/apt/sources.list en mettant un # en début de ligne.


#5

sinon, pour ton problême, si flgrx ne démarre pas, c’est parcequ’il n’est pas encore construit pour ton nouveau noyau.
Redémarre sur l’ancien, et tu devrais te retrouver sous X.


#6

apt-get dist-upgrade est une mise à jour “intelligente” qui met à jour la distribution en fonction de ce qui est dans le source.list (sar, etch, sid ou les combinaisons des 3) et du fichier préférence déclaré aussi dans /etc/apt.

Mais je ne sais pas ce qui peut se passer avec un “backport” c’est à dire un dépôt non-officiel. Il doit falloir générer finement les priorités. Dans un premier temps je commenterai ces lignes, remettrai le système d’équerre, puis ne ferai mon marché dans les backports qu’au coup par coup : j’ai lu sur cr site que les problèmes de dépendances avec une utilisation massive des backports ne sont pas rares … :wink: :unamused:

Bon courage

désolé, Matt est plus rapide …


#7

[quote]sinon, pour ton problême, si flgrx ne démarre pas, c’est parcequ’il n’est pas encore construit pour ton nouveau noyau.
Redémarre sur l’ancien, et tu devrais te retrouver sous X.[/quote]

Je n’ai pas changé de noyau, je suis toujours sous 2.6.8.

C’est que je voudrais faire, mais puis-je revenir en arrière.

Je me proposais

1 de redonner une valeur de priorité inferieur au depot backport puis de désinstaller et reinstaller udev. Etant donné que je n’ai rien modifié au kernel cela peut il fonctionner?

Si cela ne suffit pas

2 De relancer l’installation de udev et de répondre oui à la question pour laisser faire apt après avoir redonné un priorité au dépot backport.

Si cela ne suffit pas

3 De faire un update.

Si cela ne suffit pas

4 De faire un dist-upgrade

Cependant je voudrais rester sous sarge, pourquoi la mise à jour avec un backport pour sarge provoque tout ce bor…?

A quoi ressemblerai mon systeme après un dist-upgrade sur un backport?

Il y aurait peut etre une reconfiguration de x à tenter aussi, mais quand?


#8

Un petit avis?


#9

1/ton noyau, c’est pas parceque tu ne l’as pas mis à jour qu’il ne s’est pas mis à jour tout seul lors de l’upgrade. Tu utilises peut être un 2.6.8-10 avec un flgrx compilé pour 2.6.8-2, par exemple.
Vérifies que tu n’as qu’un 2.6.8 dans /boot

2/ginkgo biloba a raison: tu peux te remettre d’equerre avec un fichier preferences correct. Par exemple:

[code]Package: *
Pin: release o=volatile.debian.net,a=stable,l=debian-volatile
Pin-Priority: 1002

Package: *
Pin: release o=Debian,a=stable,l=Debian-Security
Pin-Priority: 1001

Package: *
Pin: release o=Debian,a=stable,l=Debian
Pin-Priority: 1000
[/code]
Avec un dist-upgrade, ça devrait normalement te reinstaller en stable (en privilègiant les volatiles et les update de sécurité) pour tous les paquets qui ne le sont plus, même si ça doit les faire régresser.
Si par exemple tu veux supprimmer en plus tous les paquets qui reste et qui ne sont pas en sarge officielle (pour ne garder QUE les pkt sarge), tu rajoutes un truc genrePackage: * Pin: version * Pin-Priority: -1
Bien sûr, à ne pas mettre tout seul, car ca désinstallerait tous les paquets.

D’ailleurs pour vérifier que ça fait bien ce que tu veux, tu peux vérifier avec ‘apt-get dist-upgrade -s’

Et une fois cleané, tu reprends les prefs d’origine, tu commentes tes lignes de backport, puis tu les intègres une à une, en vérifiant que les priorités que tu donnes sont bonnes, avec ‘apt-cache policy’

Et il est de bonne pratique d’imprimer et de relire ‘man apt_preferences’ :wink:


#10

Voila le message que j’ai lorsque je lance un dist-uprgade

[quote]Enregistrement invalide dans votre fichier “preferences” Aucune entrée “Package”[/quote] :imp:

Alors que j’ai juste commenté les lignes du backport!

[code]Package: *
Pin: release o=volatile.debian.net,a=stable,l=debian-volatile
Pin-Priority: 1002

Package: *
Pin: release o=Debian,a=stable,l=Debian-Security
Pin-Priority: 1001
[/code]

Je n’ai pas mis de majuscules a debian.


#11

bonsoir,
j’ai déjà eu ce message, pour différentes raisons, dont deux :

  • il y a un caractère, un espace, un retour à la ligne, quelquechose … qui ne devrait pas se trouver dans le fichier …
  • il y a une erreur de syntaxe dans un fichier du répertoire /etc/apt/apt.conf.d/ … pour ce cas, si tu n’as pas toi même rajouté un fichier de config dans ce dit répertoire, mieux vaut ne pas y toucher …
    A+

#12

Doit il y avoir un retour à la ligne à la fin du fichier?

Le caractere * est il bien celui du clavier numerique?

Est-ce que la caste à une influence?


#13

Preferences n’accepte pas les commentaires.
Il faut suprimmer les lignes, ou mettre un “Explanation:” devant (mais ça n’est pas vraiment un commentaire).


#14

J’ai viré les lignes commentées, ca marche presque mieux!
apt-get ne trouve aucun dépot… donc la connexion internet doit etre out.
(J’utilise une connexion ethernet)

J’ai essayé de remplacer le driver fglrx par ati, mais il n etrouve pas non plus le module ati.

J’ai un cdrom debian de la 3.1rc3 mais je ne sais pas comment l’ajouter à mon source.list

Je vais aller faire un tour dans truc et astuces mais je ne me souvient pas d’avoir vu cela.


#15

man apt-cdrom
T’as vu Mat je t’ai devancé :laughing:

Arrgl! “Failed to mount the cdrom”

man abracadabra?


#16

man apt-cdrom
mais à priori, ca va t’installer des paquets obsolètes que tu devras de toutes les manières mettre à jour immédiatement pour des raisons de sécurité.
Donc, je te conseilles de réparer en premier ta connection, ce qui ne devrait pas être trés difficile, vu que tu es en ethernet.


#17

Non sauf si je ne sais pas du tout comment faire…
Est-ce que je peux commencer par un dpkg-reconfigure eth0 (je ne sais meme pas si cela existe)?
Quel paquet permet de naviguer en console?


#18

ifconfig
inet adresse 127 0 0 1 masque 255 0 0 0
rx…12…0…0…0
tx…12…0…0…0

ifconfig eth0
Peripherique non trouvé

ifup eth0
Failed to bring et0

Bof…

A chaque fois j’ai des messages d’erreur me renvoyant au kernel. Je vais essayer de vous en recopier un.


#19

C’est quoi ta carte réseau?
Pour le savoir:

burp:/etc/network# lspci | grep net 0000:00:0d.0 Ethernet controller: ALi Corporation: Unknown device 5263 (rev 40) 0000:02:06.0 Ethernet controller: 3Com Corporation 3c905C-TX/TX-M [Tornado] (rev 78) burp:/etc/network#
Chez moi, j’utilise la 3Com listée ci-dessus, donc:

burp:/etc/network# modprobe -l | grep 3c /lib/modules/2.6.14perso-20-12-05/kernel/drivers/net/3c59x.ko burp:/etc/network#
Ca me dit que le module est bien présent sur mon système, donc ensuite tu fais un modprobe le_nom_du_module.
Ensuite il faut configurer ton interface réseau, c’est là que ca se passe:

burp:/etc/network# pwd
/etc/network
burp:/etc/network# cat interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet static
        address 192.168.0.2
        netmask 255.255.255.0
        network 192.168.0.0
        broadcast 192.168.0.255
        gateway 192.168.0.1
        # dns-* options are implemented by the resolvconf package, if installed
        dns-nameservers 192.168.0.1
        dns-search cave.maison
burp:/etc/network#

Tu renseigne le fichier interfaces et seulement ensuite tu peux faire un ifup.


#20

Que du bonheur…

carte VIA TECHNOLOGIES Inc VT 6102 Rhine-2 (rev 64)

lsmod
QM MODULES Fonction not implemented

Aïe! Je crois que j’ai trouvé le coeur du problème.

modprobe via-rhine
Can’t locate module via-rhine

Pour la suite j’utilise le dhcp de mon modem, et je pense que je suis correctement configurer d’après la doc trouvée sur le net. Cependant je ne suis pas sur pour le parametre gateway, qu’est-ce que c’est?