Retour d’expérience d’un dual boot debian W10 en RAID ON ?


#82

J’ai essayé deux fois avec la méthode pH en appliquant bien toutes les recommandations et résultat idem : echec.
Je suis vraiment désolé de vous embêter avec ce problème. Je vais reprendre avec le tuto


#83

Echec à quel niveau ?


#84

Je crois que c’est ça:

Il me semble que c’est Ctrl+X pour lancer le boot.
Aprés, ça doit être indiqué en bas de l’écran.
[edit: ah ben non, aprés coup d’oeil sur les screens, les deux fonctionnent.]


#85

Oui, et j’utilise toujours F10. Il me semble que c’est sur les claviers particuliers de Mac qu’une des deux ne marche pas.


#86

J’ai utilisé F10 et debian a bien démarré. Je me suis placé dans la console non graphique (CTRL+ALT+F4) car toute frappe est impossible ailleurs. Je me suis logué en tant qu’utilisateur et cela a bien marché. Après avoir fait su - et entré le nouveau mot de passe qu’il y a eu l’échec d’authentification.


#87

Tu sautes des étapes entre F10 et le redémarrage normal. Comment s’est passé passwd en root ?


#88

Il n’y a pas eu de problème: après passwd il y a eu “enter new password” puis “retype” et enfin un message disant qu’il y avait identité entre les deux entrées.


#89

Alors je sèche.

EDIT : en contournement tu peux refaire la procédure en remplaçant passwd par la commande pour ajouter ton compte utilisateur au groupe sudo :

adduser <identifiant> sudo

#90

J’ai commencé à utiliser le tuto.
L’écran grub contient 3 lignes, la dernière étant une ligne de setup ramenant à un écran BIOS.
La deuxième est labellée “recovery”. Je l’ai activée et me suis retrouvé évidemment avec une demande de mot de passe root. J’ai entré le dernier créé et tout aussi évidemment cela n’a pas marché.

N’y aurait il pas un lien avec la particularité de cette distribution qui ne voit toujours pas le disque système ? ce qui voudrait dire in fine que cette opération n’est pas possible et qu’il faut vraiment passer en AHCI pour que linux ait une vision complète du système ?


#91

Non, aucun rapport.
Tu peux activer sudo comme solution de repli, mais ça ne remplace pas complètement le mot de passe root, rendant le mode recovery inutilisable.


#92

L’activation de sudo passant par le mode root je continue à tourner en rond.


#93

Je pensais que tu aurais compris que quand tu démarres après avoir mis

rw init=/bin/bash

dans la ligne de commande du noyau dans l’éditeur de GRUB, tu es root sans saisir de mot de passe.


#94

Ce qui veut dire que tant que je n’ai pas changé le mot de passe dans cette session j’ai les privilèges root après ma connexion en tant qu’utilisateur ? ce qui veut dire aussi qu’il faudra recommencer la manipulation chaque fois que je voudrai utiliser debian et que ce problème d’authentification n’aura pas été réglé, si tant est qu’il le soit.

Je n’avais compris et je suis sûr que c’est encore le cas. Désolé encore pour la perte de temps.
Bien cordialement
gerod


#95

??? Le changement de mot de passe n’a rien à voir là-dedans.
Ça veut dire qu’en démarrant de cette façon tu es root mais dans un système très minimal, avec clavier QWERTY, sans réseau… et rien que la racine montée donc on ne peut pas y faire grand-chose. Tu peux y exécuter adduser pour te donner le droit d’utiliser sudo dans une session normale. C’est plus clair ?


#96

Effectivement c’est plus clair. Sous root j’ai donc fait la double manipulation “apt-get install sudo” puis “adduser user sudo”. Avec le mot de passe user j’ai donc une partie des droits su et pourrais alors faire la plupart des apt-get et des copies dans boot (notamment custom.cfg).

I l est quand même anormal que l’initialisation n’ait pas marchée: je l’ai pourtant reprise avec seulement des lettres en minuscule du mode commun qwerty-azerty pour éviter les frappes acrobatiques (sous ubuntu avec mon autre portable mon mot de passe comporte des caractères spéciaux, des minuscules, des majuscules et des chiffres et cela ne m’a jamais posé de problème et c’est ce que j’ai fait initialement avec debian !).
Peut être une solution bientôt ?
Bien cordialement
gerod


#97

Maintenant que tu peux utiliser sudo en session normale avec le clavier azerty, tu peux retenter de changer le mot de passe root avec

sudo passwd

à sudo tu tapes le mot de passe utilisateur et à passwd le nouveau mot de passe root.
Ensuite tu peux le tester avec su ou en ouverture de session dans une console virtuelle (ctrl+alt+F4 par exemple).

Si ça ne passe toujours pas, ma seule idée serait une anomalie dans la ligne root: du fichier /etc/passwd ou /etc/shadow. Mais cette partie du système n’est pas ma spécialité.


#98

Bonsoir,
Ce fut effectivement laborieux mais le sudo passwd a permis le changement effectif du mot de passe root : la commande su - avec fourniture du nouveau mot de passe root m’a connecté dans root.

J’ai pu lancer la commande lspci pour identifier le processeur graphique et il s’avère qu’il s’agit d’une puce Optimus. Les paquets bumblebee et primus ne sont évidemment disponibles dans ma distribution.

Ce sera pour demain. Il doit y avoir de nombreux topics sur le sujet dans le forum.
Bien cordialement et merci encore.
gerod


#99

Bonsoir,
Un petit complément. En raison du crash survenu après l’installation des paquets Optimus j’ai repris toute l’installation et ai observé :

  1. les problèmes d’authentification avaient disparu;
  2. la frappe au terminal graphique était possible (pas de multiplication de caractères) sans être fluide.
    Concernant le point 1) j’ai évité les mots de passe acrobatiques.
    Y a t’il une explication ?
    Bien cordialement.
    gerod

#100

Pour ma part j’évite les caractères non ASCII dans les identifiants et mots de passe pour éviter que ça passe mal avec tel ou tel jeu de caractères.

Sans transition, tu as pu tester le fichier custom.cfg ?


#101

Bonjour,
Donc tu penses que les problèmes rencontrés précedemment étaient une conséquence de mots de passe trop alambiqués ?

J’ai copié le fichier custom.cfg dans /boot/efi/EFI/debian et j’ai vérifié qu’il y était bien. Pas de changement au démarrage : il n’y a toujours que debian. Pour le moment ce n’est pas gênant car je peux toujours aller sur W en changeant l’ordre de boot.
Bien cordialement
gerod