Thunderbird n'est plus en français

Tags: #<Tag:0x00007f78b2db18c0>

Bonjour,

Je suis sur Stretch 9.5. Avant Hier j’ai fait une mise à jour qui a modifié thunderbird:
/var/log/apt/history : thunderbird:amd64 (1:52.9.1-1~deb9u1, 1:60.0-3~deb9u1)
L’interface est désormais en anglais, et je cherche à la remettre en français.

  • J’ai réinstallé thunderbird-l10n-fr.

  • J’ai consulté le fichier /usr/share/doc/thunderbird.README qui précise l’utilisation de la variable intl.locale.requested - que j’ai testée dans les sens y compris en modifiant directement /etc/thunderbird/prefs/thunderbird.js ou à travers l’éditeur de conf de thunderbird. Sans succès.

  • J’ai même contacté le mainteneur du paquet qui m’a d’ailleurs répondu très rapidement et très gentiment, qui me renvoie sur ce que j’avais déjà fait, mais qui me précise quand même que :

    I just now realize that the README.Debian file was not updated while the packages for stretch-security got prepared, means the information within this file is outdated. So again, you normally don’t need to edit anything within your local Thunderbird profile as it’s pulled from thunderbird.js!

  • Et bien entendu j’ai fait des recherches sur le Net - qui n’ont rien donné

Alors à moins de réinstaller complètement Thunderbird - et à supposer que cela change quelque chose - si l’un d’entre vous avait une idée, bah elle serait super bienvenue…
Merci d’avance

Pierre

1 J'aime

Aucun pb de langue française

apt list thunderbird
En train de lister… Fait
thunderbird/stable,now 1:60.0-3~deb9u1 amd64 [installé]

apt list thunderbird-l10n-fr
En train de lister… Fait
thunderbird-l10n-fr/stable,stable,now 1:60.0-3~deb9u1 all [installé]

As tu verifié que c’est activé

3 J'aime

C’est connu, deux notes de mise à jour a été publiées à ce sujet :

Bingo!!
Tout d’abord merci pour cette réponse - qui a résolu le problème.
Je ne connaissais pas le dispositif via les addons.
Effectivement le module courant était désactivé parce que incompatible avec la version 60.
La réinstallation du paquet thunderbird-l10n-fr ne suffisait pas.
Il fallait supprimer le module courant dans les addons, fermer et relancer Thunderbird… qui est à nouveau en français. Ouf!!
Merci encore pour cette réponse rapide et efficace.

1 J'aime

Bonjour,

Oui j’avais bien vu ces informations lors de la mise à jour, mais je n’ai pas vu - ou pas compris - dans le contenu des liens fournis, la solution de correction via les addons; je n’avais trouvé que la modif du fichier thunderbird.js ou bien en passant par l’éditeur de conf.

Mais c’est bon, le problème est résolu; Merci pour cette contribution.

ce que tu appelles module courant, tu l’avais téléchargé toi même sur le site Thunderbird?
parce que je n’utilise que les paquets de langue Thunderbird Debian et je n’ai pas eu ce problème

pour info

debian:/etc/thunderbird/pref$ cat thunderbird.js
// This is the Debian specific preferences file for Mozilla Thunderbird
// You can make any change in here, it is the purpose of this file.
// You can, with this file and all files present in the directory
//
//      /etc/thunderbird/pref directory
//
// override any preference that is present in the directory
//
//      /usr/lib/thunderbird/defaults/pref
//
// While your changes will be kept on upgrade if you modify files in
// /etc/thunderbird/pref, please note that they won't be kept if you
// do them in /usr/lib/thunderbird/defaults/pref.

pref("extensions.update.enabled", true);

// Use LANG environment variable to choose locale from system
// The old environment setting 'pref("intl.locale.matchOS", true);' is
// currently not working anymore. The new introduced setting
// 'intl.locale.requested' is now used for this. Setting an empty string is
// pulling the system locale into Thunderbird.
pref("intl.locale.requested", "");

// Disable default mail checking (gnome).
pref("mail.shell.checkDefaultMail", false);

// Disable default mail client check
pref("mail.shell.checkDefaultClient", false);

// if you are not using gnome
pref("network.protocol-handler.app.http", "x-www-browser");
pref("network.protocol-handler.app.https", "x-www-browser");

// This setting is a workaround for some crashes inside the JS engine.
// By this Thunderbird will use more memory and acting slower as the sharing
// memory between interacting JS files is disabled.
pref ("javascript.options.baselinejit", false);

// Uncomment the follwing setting if you want to have a extra mail header field
// for X-Debbugs-Cc, only needed in case you have to work with the Debian
// Bug Tracking System more deeply
//pref("mail.compose.other.header", "X-Debbugs-Cc");

Capture%20d%E2%80%99%C3%A9cran%20du%202018-09-19%2016-48-36

L’installation de la machine remonte à presque 9 mois.
Je ne crois pas - mais je ne suis pas formel - être intervenu sur la francisation de Thunderbird (je peux aussi l’avoir fait et l’avoir oublié…).
Et je n’ai pas non plus de certitude sur la façon dont j’ai installé Thunderbird. A priori : apt-get install, mais je me souviens aussi avoir testé “logiciels” inclus dans gnome, histoire de voir, et peut-être que j’ai utilisé cet outil pour installer Thunderbird.
Donc je ne suis pas catégorique sur l’origine du pack de francisation déjà présent.

Côté source, j’ai bien un ‘deb http://deb.debian.org/debian stretch-backports main’ mais c’était pour un besoin bien particulier - Non hélas je ne sais plus lequel… VirtualBox ? Owncloud ? ou autre… - mais sans relation avec Thunderbird.

Pour info je joins quelques captures de la config actuelle, et qui fonctionne désormais parfaitement bien.
A noter que le pack de francisation actuel - issu de le réinstallation de thunderbird-l10n-fr je présume - s’est réinstallé tout seul après que j’ai supprimé le précédent, qui était donc incompatible avec la version 60.

Capture%20du%202018-09-19%2018-50-01

Pour être plus complet :
Capture%20du%202018-09-19%2019-20-08

Et ceci qui peut, peut-être, donner une idée de l’historique :
Capture%20du%202018-09-19%2019-27-00

Merci ! J’avais le même souci, et j’ai également supprimé le module de langue de la version 59 (incompatible), puis redémarré mon TB, et là tout est ok, content d’avoir retrouvé le français <3

Bonjour
même en supprimant le pack language et en relancant, la version reste en Anglais
Dans l éditeur de config, j ai bien la clé intl.locale.requested, (valeur=vide) mais je ne trouve pas comment la supprimer
Quelqu’un peut il m aider ?
Merci

Bonjour,
Je suis loin, très loin, d’être un spécialiste de Thunderbird.
Mais pour ma part la chaîne intl.locale.requested est bien renseignée à ‘fr’ - ce qui me paraît assez logique.
Quid de la commande apt list -a thunderbird-l10n-fr ? (histoire de vérifier que la réinstallation s’est bien déroulée).
Quid de l’Addon Français Langage Pack - en principe version 60 - (Regarde la réponse de grandtoubab - deuxième message) ?
Peut-être désactiver et réactiver ?

Ok Merci de ta réponse
J avais cru comprendre qu il fallait supprimer le language pack des modules complémentaires, celui que j avais jusqu’alors n’étant plus compatible
J ai réinstallé ce pack a partir de mon gestionnaire de paquets (linux mint) et c’est rentré dans l’ordre. Ouf ! :wink:
Thx

merci phdb44, et les autres, ça fait une semaine que je cherchais la solution et elle était là… pourquoi ne suis-je pas venu ici tout de suite ?
:o) belle soirée ou autre - pat