Xorg en question


#1

Bonjour tout le monde les gens :slightly_smiling:

Pour faire des tests, j’ai eu besoin d’installer un double boot Suse / Debian sur une machine DELL :imp:

J’ai commencé par installer Sarge, mais je n’arrivai pas à configurer mon Xfree. Suse fonctionnant sous xorg, je me suis dis que j’allais installer xorg puis copier / coller la config de Suse. Pour cela, je suis passé en Etch en modifiant mon source.list, j’ai remplacé les “stable” par des “testing” puis apt-get update, apt-get upgrade (j’aurais peut etre pas du… mais bon) et pour finir, avec aptitude, j’ai désinstallé xfree et installé xorg.

Tout ceci fais, j’ai fais tenté de lancer mon serveur X, mais rien… il me répondait qu’il n’arrivait pas à démarer le serveur X. dans le fichier de log auto-généré, j’ai vu “screen not found”, j’ai alors fais un backup de mon fichier de conf et je l’ai remplacé par celui de la Suse pensant que ca démarerait.

En effet, avec ce fichier de conf j’arrive à lancer gdm et me logguer, mais j’ai de suite un message d’erreur du style “votrer session X a durer - de 10s, il y a 1 pb. voir l’erreur ? Oui / Non” en répondant “oui”, il m’indique :

[quote]~/.x-session-errors
x-session-manager : error while loading shared libraries : libhowl.so.0 : cannot open shared object file : no such file or directory[/quote]

je me suis donc mis à la recherche de ce fameux libhowl.so.0 mais apt-cache ne trouve pas de libhowl*

et la je bloque…

avez vous une idée de ce que je pourrai faire d’autre ?


#2

j’ai oublié de dire que j’ai essayé dpkg-reconfigure avec les différents fichiers xorg.conf dont je dispose, rien n’y fais.

de plus, je n’ai plus d’accès physique à la machine pour le moment, je m’y connecte en ssh -X


#3

Si ça peut t’aider :

dlocate libhowl
libavahi-compat-howl0: /usr/lib/libhowl.so.0.0.0
libavahi-compat-howl0: /usr/lib/libhowl.so.0

#4

je viens de remarquer qu’en lancant startx il m’indique une autre erreur :

[quote]# startx
xauth: creating new authority file /root/.serverauth.1898

X: warning; process set to priority -1 instead of requested priority 0

X Window System Version 6.9.0 (Debian 6.9.0.dfsg.1-4 20060114230205 David Nusinow dnusinow@debian.org)
Release Date: 21 December 2005
X Protocol Version 11, Revision 0, Release 6.9
Build Operating System: Linux 2.6.15-1-686 i686 [ELF]
Current Operating System: Linux debian-guillaume 2.6.8-2-386 #1 Tue Aug 16 12:46:35 UTC 2005 i686
Build Date: 14 January 2006
Before reporting problems, check wiki.X.Org
to make sure that you have the latest version.
Module Loader present
OS Kernel: Linux version 2.6.8-2-386 (horms@tabatha.lab.ultramonkey.org) (gcc version 3.3.5 (Debian 1:3.3.5-13)) #1 Tue Aug 16 12:46:35 UTC 2005
Markers: (–) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: “/var/log/Xorg.0.log”, Time: Mon Mar 20 15:43:13 2006
(==) Using config file: "/etc/X11/xorg.conf"
b VESA(0): No matching modes
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found[/b]

Please consult the The X.Org Foundation support
at wiki.X.Org
for help.
Please also check the log file at “/var/log/Xorg.0.log” for additional information.

XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0"
after 0 requests (0 known processed) with 0 events remaining.
[/quote]

j’ai donc comparé à ce que j’avais ailleurs et sur une autre machine Suse identique, il utilise i810 au lieu de vesa, lancement de dpkg-reconfigure, changement du vesa en i810, re startx et :

[quote]# startx
xauth: creating new authority file /root/.serverauth.2307

X Window System Version 6.9.0 (Debian 6.9.0.dfsg.1-4 20060114230205 David Nusinow dnusinow@debian.org)
Release Date: 21 December 2005
X Protocol Version 11, Revision 0, Release 6.9
Build Operating System: Linux 2.6.15-1-686 i686 [ELF]
Current Operating System: Linux debian-guillaume 2.6.8-2-386 #1 Tue Aug 16 12:46:35 UTC 2005 i686
Build Date: 14 January 2006
Before reporting problems, check wiki.X.Org
to make sure that you have the latest version.
Module Loader present
OS Kernel: Linux version 2.6.8-2-386 (horms@tabatha.lab.ultramonkey.org) (gcc version 3.3.5 (Debian 1:3.3.5-13)) #1 Tue Aug 16 12:46:35 UTC 2005
Markers: (–) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: “/var/log/Xorg.0.log”, Time: Mon Mar 20 15:50:43 2006
(==) Using config file: “/etc/X11/xorg.conf”

b GARTInit: Unable to open /dev/agpgart (No such file or directory)
(EE) I810(0): No Video BIOS modes for chosen depth.
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found[/b]

Please consult the The X.Org Foundation support
at wiki.X.Org
for help.
Please also check the log file at “/var/log/Xorg.0.log” for additional information.

XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0"
after 0 requests (0 known processed) with 0 events remaining.
[/quote]

c’est une vidéo intégrée mais n’ayant pas d’accès physique je ne peux vérifier les “choix” possible du BIOS (pour essayer de résoudre l’'erreur i810).


#5

merci BobX :slightly_smiling:
je vais revenir à ma conf précédente et voir ca.


#6

Si tu lances startx à partir d’une connexion ssh, je doute qu’il puisse trouver un screen valable pour se lancer.


#7

hum… :’(

j’ai regardé dans aptitude et libavahi-compat-howl0 est déjà installé :exclamation:

je comprend pu trop la…


#8

Et /usr/lib/libhowl.so.0 existe ou pas?


#9

euuu ben j’ai mis X11forward = yes sur le serveur et je me connecte avec l’option -X, je devrai donc avoir la possiblité de lancer X, non ?

edit :

[quote]# ll /usr/lib/libhowl*
lrwxrwxrwx 1 root root 16 2006-03-17 16:48 /usr/lib/libhowl.so.0 -> libhowl.so.0.0.0
-rw-r–r-- 1 root root 47872 2006-02-15 21:44 /usr/lib/libhowl.so.0.0.0
[/quote]

il existe donc bel et bien ce fichier !!
les erreurs énoncé au début de ce topic (notemment lihowl no found) était lors d’un accès physique à la machine.


#10

[quote=“Twistophe”]euuu ben j’ai mis X11forward = yes sur le serveur et je me connecte avec l’option -X, je devrai donc avoir la possiblité de lancer X, non ?
[/quote]

Non, le ssh -X permet aux applications clientes de X de discuter avec ton serveur X local, donc de s’afficher localement. Le lancement d’un serveur X demande lui un accés physique à certains périphérique de la machine, notament à un screen (écran+clavier+souris+CG) donc je doute que ça puisse marcher à partir d’un ssh.

Lorsque tu te connectes en ssh -X sur une machine, tu as donc juste besoin d’un serveur X localement, mais pas sur la machine distante.

Pour tin soucis de libhowl, je cherche… :wink:


#11

haaaaaa oki doki !
merci pour ce point info sur le fonctionnement de ssh -X :slightly_smiling:

merki 8)

ps : merci doit etre le mot le + utilisé sur ce forum ^^
comme quoi, l’informatique rend (aussi) aimable et poli :wink:


#12

ce matin, je me connect en ssh sur la machine, je lance un petit aptitude pour mettre a jour le systeme et il me répond :

“Certains paquets cassés n’ont pas pu être réparés !”

:-/

pourtant le source.list est on ne peu + simple :

[quote]# cat /etc/apt/sources.list
#deb file:///cdrom/ sarge main

deb debian.ens-cachan.fr/ftp/debian/ testing main contrib non-free
deb-src debian.ens-cachan.fr/ftp/debian/ testing main contrib non-free

deb security.debian.org/ testing/updates main[/quote]

[quote]# apt-get update
Atteint debian.ens-cachan.fr testing/main Packages
Atteint debian.ens-cachan.fr testing/main Release
Atteint debian.ens-cachan.fr testing/contrib Packages
Atteint debian.ens-cachan.fr testing/contrib Release
Atteint debian.ens-cachan.fr testing/non-free Packages
Atteint debian.ens-cachan.fr testing/non-free Release
Atteint debian.ens-cachan.fr testing/main Sources
Atteint debian.ens-cachan.fr testing/main Release
Atteint debian.ens-cachan.fr testing/contrib Sources
Atteint debian.ens-cachan.fr testing/contrib Release
Atteint security.debian.org testing/updates/main Packages
Réception de : 1 security.debian.org testing/updates/main Release [98B]
Atteint debian.ens-cachan.fr testing/non-free Sources
Atteint debian.ens-cachan.fr testing/non-free Release
98o réceptionnés en 0s (200o/s)
Lecture des listes de paquets… Fait[/quote]

[quote]# apt-get upgrade
Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances… Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
gnome: Dépend: rhythmbox (>= 0.9.2) mais 0.8.8-13 est installé
gnome-desktop-environment: Dépend: gnome-volume-manager (>= 1.4.0-2) mais 1.2.0-2 est installé
Dépend: gnomemeeting (>= 1.2.3-1experimental1) mais 1.2.1-1 est installé
Dépend: sound-juicer (>= 2.12.3) mais il n’est pas installé
Dépend: vino (>= 2.12.0) mais 2.8.1-1.1 est installé
Dépend: zenity (>= 2.12.1) mais 2.8.2-1 est installé
hal: Dépend: udev (>= 0.065) mais 0.056-3 est installé
Dépend: dbus (>= 0.60-1) mais il n’est pas installé
kcalc: Dépend: libgmp3c2 mais il n’est pas installé
ksim: Dépend: libsnmp9 (>= 5.2.1.2-3) mais il n’est pas installé
udev: Dépend: hotplug (>= 0.0.20040329-17)
E: Dépendances manquantes. Essayez d’utiliser l’option -f.[/quote]

cette option -f tente de poursuivre si le contrôle d’intégrité échoue.


#13

tu es sûr que tu n’as rien mis dans tes préfèrences ?
Ou bien tu as peut être un “Default-release=stable” quelque part dans ta config apt ?
parcequ’en regardant par exemple udev:

console@routeur:~$ apt-cache policy udev udev: Installé : (aucun) Candidat : 0.056-3 Table de version : 0.087-2 0 96 http://ftp2.fr.debian.org sid/main Packages 0.085-1 0 98 http://ftp2.fr.debian.org etch/main Packages 0.056-3 0 990 http://ftp2.fr.debian.org sarge/main Packages
je vois bien que la version en testing (=etch) est la 0.085-1, qui devrait s’installer d’elle même chez toi.

Essayes de remplacer “testing” par “etch” dans tes sources, pour voir et recommences.
Au passage, rajoutes contrib et non-free sur ta ligne d’updates.
Sinon, si tu ne compiles pas de paquets, commentes ta ligne deb-src, car elle ralentit tes update pour rien.

Une solution, c’est d’installer de force la version qui t’interresse de chaque paquet posant problême. apt-cache policy pour voir quel choix tu as. Puis apt-get install =.
ex: apt-get install udev=0.085-1

Tu sera peut être obligé d’installer tout un lot de paquets d’un coup de cette manière s’ils ne passent pas individuellement.


#14


en modifiant les testing par des etch, les paquets cassés n’existent plus !
j’aimerais bien comprendre pourquoi tout de meme…

j’espère que cela va résoudre mon pb de xorg… :unamused:


#15

c’est un mirroir mal entretenu ou le lien symbolique “testing” pointe encore sur “sarge” (un an que ca aurait dû changer !!!).
remplaces l’ens cachan par un mirroir officiel, ca me parait plus fiable.
Pourquoi pas ftp.fr.debian.org (peut être plus rapide sur ftp2.fr.debian.org) ?


#16

bon je me suis réjouit un peu trop vite…

après dépaquetage, il me dit :

[quote]# aptitude
Extraction des modèles depuis les paquets : 100%
Préconfiguration des paquets…
(sic)
Dépaquetage de la mise à jour de lsb-base …
Paramétrage de lsb-base (3.0-16) …
(Lecture de la base de données… 81738 fichiers et répertoires déjà installés.)Préparation du remplacement de udev 0.056-3 (en utilisant …/archives/udev_0.085-1_i386.deb) …
This version of udev requires a kernel >= 2.6.12, upgrade aborted.
dpkg : erreur de traitement de /var/cache/apt/archives/udev_0.085-1_i386.deb (–unpack) :
le sous-processus pre-installation script a retourné une erreur de sortie d’état 1
Des erreurs ont été rencontrées pendant l’exécution :
/var/cache/apt/archives/udev_0.085-1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Ouille ! Quelque chose ne s’est pas bien passé lors de l’installation des paquets. Tentative de réparation :
Paramétrage de cpp-4.0 (4.0.3-1) …
Paramétrage de libc6-dev (2.3.6-3) …
dpkg : des problèmes de dépendances empêchent la configuration de gnome-desktop-environment :
gnome-desktop-environment dépend de gnome-volume-manager (>= 1.4.0-2) ; cependant :
La version de gnome-volume-manager sur le système est 1.2.0-2.
gnome-desktop-environment dépend de gnomemeeting (>= 1.2.3-1experimental1) ; cependant :
La version de gnomemeeting sur le système est 1.2.1-1.
gnome-desktop-environment dépend de sound-juicer (>= 2.12.3) ; cependant :
Paquet sound-juicer n’est pas installé.
gnome-desktop-environment dépend de vino (>= 2.12.0) ; cependant :
La version de vino sur le système est 2.8.1-1.1.
gnome-desktop-environment dépend de zenity (>= 2.12.1) ; cependant :
La version de zenity sur le système est 2.8.2-1.
dpkg : erreur de traitement de gnome-desktop-environment (–configure) :
problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de hal :
hal dépend de udev (>= 0.065) ; cependant :
La version de udev sur le système est 0.056-3.
hal dépend de dbus (>= 0.60-1) ; cependant :
Paquet dbus n’est pas installé.
dpkg : erreur de traitement de hal (–configure) :
problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de kcalc :
kcalc dépend de libgmp3c2 ; cependant :
Paquet libgmp3c2 n’est pas installé.
dpkg : erreur de traitement de kcalc (–configure) :
problèmes de dépendances - laissé non configuré

Paramétrage de portmap (5-17) …
Installation de la nouvelle version du fichier de configuration /etc/init.d/portmap …
Starting portmap daemon: portmap.
Restoring old RPC service information…done.

Paramétrage de libhal1 (0.5.7-1) …

dpkg : des problèmes de dépendances empêchent la configuration de ksim :
ksim dépend de libsnmp9 (>= 5.2.1.2-3) ; cependant :
Paquet libsnmp9 n’est pas installé.
dpkg : erreur de traitement de ksim (–configure) :
problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de gnome :
gnome dépend de gnome-desktop-environment (= 1:2.12.2.2) ; cependant :
Paquet gnome-desktop-environment n’est pas encore configuré.
gnome dépend de rhythmbox (>= 0.9.2) ; cependant :
La version de rhythmbox sur le système est 0.8.8-13.
dpkg : erreur de traitement de gnome (–configure) :
problèmes de dépendances - laissé non configuré

Paramétrage de fam (2.7.0-9) …
Installation de la nouvelle version du fichier de configuration /etc/init.d/fam …
Starting file alteration monitor: FAM.

Des erreurs ont été rencontrées pendant l’exécution :
gnome-desktop-environment
hal
kcalc
ksim
gnome
Appuyez sur Entrée pour continuer.
[/quote]

et je me retrouve encore une fois avec des paquets cassés :frowning:


#17

lis les messages d’erreurset corriges les une à une : installes d’abord un autre noyau, c’est ça qui semble bloquer.


#18

Matt, Ô mon grand Matt ^^

[quote]$ apt-cache search kernel-image-2.6
kernel-image-2.6-386 - Linux kernel 2.6 image on 486-class machines - transition package
kernel-image-2.6-686 - Linux kernel 2.6 image on PPro/Celeron/PII/PIII/P4 machines - transition package
kernel-image-2.6-686-smp - Linux kernel 2.6 image on PPro/Celeron/PII/PIII/P4 SMP machines - transition package
kernel-image-2.6-k7 - Linux kernel 2.6 image on AMD K7 machines - transition package
kernel-image-2.6-k7-smp - Linux kernel 2.6 image on AMD K7 SMP machines - transition package
ndiswrapper-modules-2.6.8-2-386 - Ndiswrapper linux kernel module
ndiswrapper-modules-2.6.8-2-686 - Ndiswrapper linux kernel module
ndiswrapper-modules-2.6.8-2-686-smp - Ndiswrapper linux kernel module
ndiswrapper-modules-2.6.8-2-k7 - Ndiswrapper linux kernel module
ndiswrapper-modules-2.6.8-2-k7-smp - Ndiswrapper linux kernel module
kernel-image-2.6.8-2-386 - Linux kernel image for version 2.6.8 on 386.

$ uname -r
2.6.8-2-386[/quote]

je dois faire un “apt-get install kernel-image-2.6-686” ?
où je dois suivre ca : forum.debian-fr.org/viewtopic.php?t=1806 ?

sachant que je ne me sent pas chaud pour la 2ème solution.


#19

pour ton noyau il demande au minimum la version 2.6.12 donc il faut que tu fasse une rechercher non pas sur kernel-image mais linux-image qui te donnera les derniers noyaux

Apres je n’ai pas tout lu donc tu peux refaire une config en suivant mon post ou alors tu reinstall directement une image

apt-cache search linux-image alsa-base - ALSA driver configuration files linux-headers-2.6.15-1-486 - Header files for Linux kernel 2.6.15 on 486-class machines linux-headers-2.6.15-1-686 - Header files for Linux kernel 2.6.15 on PPro/Celeron/PII/PIII/P4 machines linux-headers-2.6.15-1-686-smp - Header files for Linux kernel 2.6.15 on PPro/Celeron/PII/PIII/P4 SMP machines linux-headers-2.6.15-1-k7 - Header files for Linux kernel 2.6.15 on AMD K7 machines linux-headers-2.6.15-1-k7-smp - Header files for Linux kernel 2.6.15 on AMD K7 SMP machines linux-image-2.6-486 - Linux kernel 2.6 image on 486-class machines linux-image-2.6-686 - Linux kernel 2.6 image on PPro/Celeron/PII/PIII/P4 machines linux-image-2.6-686-smp - Linux kernel 2.6 image on PPro/Celeron/PII/PIII/P4 SMP machines linux-image-2.6-k7 - Linux kernel 2.6 image on AMD K7 machines linux-image-2.6-k7-smp - Linux kernel 2.6 image on AMD K7 SMP machines linux-image-2.6.15-1-486 - Linux kernel 2.6.15 image on 486-class machines linux-image-2.6.15-1-686 - Linux kernel 2.6.15 image on PPro/Celeron/PII/PIII/P4 machines linux-image-2.6.15-1-686-smp - Linux kernel 2.6.15 image on PPro/Celeron/PII/PIII/P4 SMP machines linux-image-2.6.15-1-k7 - Linux kernel 2.6.15 image on AMD K7 machines linux-image-2.6.15-1-k7-smp - Linux kernel 2.6.15 image on AMD K7 SMP machines linux-image-486 - Linux kernel image on 486-class machines linux-image-686 - Linux kernel image on PPro/Celeron/PII/PIII/P4 machines linux-image-686-smp - Linux kernel image on PPro/Celeron/PII/PIII/P4 SMP machines linux-image-k7 - Linux kernel image on AMD K7 machines linux-image-k7-smp - Linux kernel image on AMD K7 SMP machines linux-tree-2.6.15 - Linux kernel source tree for building Debian kernel images


#20

merci Ash :slightly_smiling:

donc un simple “apt-get install linux-image-2.6.15-1-686” suivit d’un reboot devrait suffire pour avoir un nouveau noyau, non ?