Vous avez un scanner ou une imprimante qui marche ? Dites-le


#1

Vous avez trouvé un scanner ou une imprimante qui fonctionne bien avec les paquets officiels de Debian ?

Dites-le !

Les contraintes : pour qu’un scanner ou une imprimante puisse figurer dans ce fil, il faut que le périphérique fonctionne bien uniquement en installant des paquets binaires avec aptitude depuis l’archive officielle Debian située à l’adresse [mono]http://ftp.fr.debian.org/debian/[/mono]. Aucune manipulation en dehors d’[mono]aptitude[/mono] ne doit être nécessaire pour faire fonctionner le matériel. De plus, vous devez avoir testé le matériel vous-même personnellement.

Dans le cas d’un scanneur-imprimante combiné, précisez si les deux fonctions sont opérationnelles, ou s’il n’y en a qu’une.

N’oubliez pas d’indiquer les références précises du scanner ou de l’imprimante, ainsi que votre configuration en fournissant le résultat de ces commandes :

$ uname -a $ apt-cache policy libc6 $ vrms -s

Précisez aussi si vous avez dû installer des paquets en dehors de votre dépôt par défaut pour faire fonctionner le matériel (par exemple, si vous êtes en [mono]stable[/mono], précisez si vous avez dû piocher dans [mono]oldstable[/mono], [mono]backports[/mono], [mono]testing[/mono], [mono]sid[/mono] ou [mono]experimental[/mono]).

Voici un modèle à copier-coller :

[code][size=150]Canon CanoScan LiDE 20[/size]

Type : scanner
Marque : Canon
Modèle : CanoScan LiDE 20
Lien : Référence constructeur
Format scanner : A4 (216 x 297 mm)
Résolution scanner : 600 x 1200 dpi

Date du test : 01 janvier 1970
Fonctions opérationnelles : scanner seul

Version du noyau :

$ uname -a Linux nommachine 3.2.0-4-amd64 #1 SMP Debian 3.2.57-3+deb7u2 x86_64 GNU/Linux

Version de debian :

$ apt-cache policy libc6 libc6: Installé : 2.13-38+deb7u1 Candidat : 2.13-38+deb7u1 Table de version : *** 2.13-38+deb7u1 0 500 http://ftp.fr.debian.org/debian/ wheezy/main amd64 Packages 100 /var/lib/dpkg/status

Paquets non-free et contrib installés :

[code]$ vrms -s
unrar

flashplugin-nonfree
phoronix-test-suite[/code]

Autres dépôts dans lesquels il a fallut piocher pour faire fonctionner le périphérique (backports ? testing ? unstable ?) : aucun.[/code]


Installer imprimante Epson AcuLaser CX17
#2

Euh, je n’ai pas souvenirs d’avoir eu de soucis avec mon imprimante HP F2280 tout en un.
Le scanner fonctionne avec Xsane sans soucis.
La partie impression, avec cups, j’ai pas de soucis, je n’arrive toutefois pas à gérer comme il faut l’impression en mode “brouillon” notamment avec une utilisation en imprimante partagée (sous un windows). Du coup une cartouche n’a pas durée longtemps… :s. Au final, j’ai branché l’imprimante sur le pc windows, ca m’a fait faire des économies…
C’est le seul regret/soucis que j’ai.


#3

Grâce à tes critères éclairants, je découvre que ma ML-2165W de chez Samsung (petite imprimante laser monochrome) ne fonctionne pas.
En effet, il a fallu installer le pilote officiel depuis les dépôts de Samsung :
bchemnet.com/suldr/index.html
Et pire que tout, j’ai installé ce pilote avec apt-get sans me rendre compte que j’invalidais le fonctionnement de mon imprimante en n’utilisant pas aptitude !


#4

puis, j’ai tout fait avec apt-get et pas aptitude… :smiling_imp: :blush:


#5

Et si j’ai pas envie, tu passera à la brutalité :whistle:

Blague à part des fils on l’on parle de problème d’imprimante sont légions et in fine ce sont souvent les mêmes marques qui posent de réelles problèmes (qui ne sont jamais vraiment insurmontables à qui veux faire fonctionner son imprimante).


#6

En fait, dites-le plutôt là-bas : openprinting.org/printers, c’est fait pour ça.


#7

Salut,

C’est grave docteur, j’ai été obligé de déclarer mon imprimante par localhost:631 ?
Et pour que mon scanner fonctionne il faut qu’il soit mis sous tension AVANT l’ordinateur ?


#8

Rien de plus normal.

Là par contre, c’est un comportement un peu plus étrange.
Probablement une histoire du côté d’udev.


#9

[quote=“rod”]Vous avez trouvé un scanner ou une imprimante qui fonctionne bien avec les paquets officiels de Debian ?

Dites-le !
[/quote]
Oui j’avoue avoir une imprimante/fax/scanner qui fonctionne, elle est…ouf…cette question :083

Salut à dans trois mois


#10

Bonjour !
j’ai une HP Officejet 6600 (H711a)

achetée récemment qui fonctionne sur Wheezy

ldlc.com/fiche/PB00127685.html

s’installe seule sans problème


#11

[quote=“vv222”]je découvre que ma ML-2165W de chez Samsung (petite imprimante laser monochrome) ne fonctionne pas.
En effet, il a fallu installer le pilote officiel depuis les dépôts de Samsung :
bchemnet.com/suldr/index.html[/quote]
Le but n’est pas de dire que les imprimantes ou les scanners qui ne répondent pas à ces critères sont mauvais ou ne fonctionnent pas. Le but est de trouver les quelques perles qui ont juste besoin d’être branchées pour pouvoir être utilisées avec Debian (à la limite en utilisant un coup d’aptitude, mais pas plus). Ceci afin de savoir quoi conseiller comme achat de matériel aux amis auxquels on a installé Debian, pour qu’ils restent autonomes au maximum.

Si le pilote de l’imprimante se trouve sur les serveurs de Samsung, que se passera-t-il pour ces amis si dans deux ans il n’est plus disponible ou plus à jour ? Si le pilote est sur les serveurs de Debian (dans la branche main de préférence), il sera probablement adapté aux prochaines versions stables de Debian.

Installer le pilote avec apt-get ou aptitude, ça ne change pas grand chose. J’aurais pu dire “avec apt-get ou avec aptitude”, mais ça revient au même tout en étant plus long.

Le but est d’indiquer à ceux qui vont acheter du matériel les références idéales. Un fonctionnement automatique des périphériques est un atout considérable pour éviter un abandon de Debian et/ou des allers-retours pour ceux qui assurent le support.

Il existe des paquets qui permettent à certaines imprimantes de fonctionner sans rien faire. C’est l’idéal. Si l’on doit faire l’acquisition d’un nouveau matériel, autant choisir parmi ceux qui peuvent fonctionner automatiquement.
Par ailleurs, nous sommes dans pause café, tu peux faire une fiche sur ton imprimante si ça te chante, même si elle se configure depuis localhost:631 et doit être branchée avant l’ordinateur

Dans la base de données de h-node, je ne vois que 5 références de scanners (qui sont d’ailleurs introuvables) ayant la propriété de fonctionner parfaitement avec du logiciel libre.

Que veux-tu dire ?

[quote=“rafix”]j’ai une HP Officejet 6600 (H711a)

achetée récemment qui fonctionne sur Wheezy

ldlc.com/fiche/PB00127685.html

s’installe seule sans problème[/quote][quote=“chuck_73”]Euh, je n’ai pas souvenirs d’avoir eu de soucis avec mon imprimante HP F2280 tout en un.
Le scanner fonctionne avec Xsane sans soucis.
La partie impression, avec cups, j’ai pas de soucis, je n’arrive toutefois pas à gérer comme il faut l’impression en mode “brouillon” notamment avec une utilisation en imprimante partagée (sous un windows). Du coup une cartouche n’a pas durée longtemps… :s. Au final, j’ai branché l’imprimante sur le pc windows, ca m’a fait faire des économies…
C’est le seul regret/soucis que j’ai.[/quote]
Merci pour vos retours :023 . Si possible, pensez à inclure le retour de la commande [mono]vrms -s[/mono].


#12

Grâce à tes critères éclairants, je découvre que ma ML-2165W de chez Samsung (petite imprimante laser monochrome) ne fonctionne pas.
En effet, il a fallu installer le pilote officiel depuis les dépôts de Samsung :
bchemnet.com/suldr/index.html
Et pire que tout, j’ai installé ce pilote avec apt-get sans me rendre compte que j’invalidais le fonctionnement de mon imprimante en n’utilisant pas aptitude ![/quote]
Tu peut l’ajouter là : les-depots-t48299.html

Et c’est simple, mais c’est une histoire de confiance. Quelle est la licence de ce qui est proposée là dessus ?


#13

:~$ uname -a
Linux moi 3.2.0-4-686-pae #1 SMP Debian 3.2.57-3+deb7u2 i686 GNU/Linux
:~$ apt-cache policy libc6
libc6:
Installé : 2.13-38+deb7u1
Candidat : 2.13-38+deb7u1
Table de version :
*** 2.13-38+deb7u1 0
500 ftp.fr.debian.org/debian/ wheezy/main i386 Packages
100 /var/lib/dpkg/status
:~$ vrms -s
bash: vrms : commande introuvable

Je tourne actuellement sur un vieille machine, avec peu de ressources, pas de flash installé

l’imprimante s’installe pour ainsi dire seul , sans ajout de quoi que ce soit

Xsane fonctionne sans aucune intervention


#14

Salut vv222,

[quote]
Là par contre, c’est un comportement un peu plus étrange.
Probablement une histoire du côté d’udev.[/quote]

Il s’agit du comportement normal des vrais SCSI qui possèdent leur propre système, déchargeant d’une partie du travail le CPU, qui se met en relation avec l’ordinateur à la mise sous tension.
Le prix de revient de ce type de matériel l’a fait progressivement abandonner pour un matériel avec la même interface mais sollicitant beaucoup plus nos CPU.


#15

Le but est d’indiquer à ceux qui vont acheter du matériel les références idéales. Un fonctionnement automatique des périphériques est un atout considérable pour éviter un abandon de Debian et/ou des allers-retours pour ceux qui assurent le support.[/quote]

L’abandon de Debian … pas grave, GNU/Linux ne peu pas plaire à tous le monde.
La compléxité du support … tout dépend de ta volonté à le faire et à t’y consacrer (pourquoi passer des gens à Debian si tu n’a pas le temps derrière).

En résumé je n’ai pas eu plus de souci à faire fonctionner une canon mp600, même si il m’a fallu bricoler, et une canon MP560 ne m’avait poser pas beaucoup plus de souci à l’époque pour la faire fonctionner.

De toute façon au vue du prix des cartouches et de l’obsolescence programmée, ma main coupé qu’avant que les pilotes ne soient plus disponible l’imprimante sera changé car trop à cher à entretenir ou à réparer.

Maintenant comme précisé si tu cherche à éviter les grosses bidouilles, commence par éviter toutes les marques du type Canon et autres consorts, ainsi que les dernières innovations et format.

En règle générale Brother, HP propose des imprimantes de très bon rapports qualité pris et avec des pilotes plus que corrects pour Linux … avantages à Brother pour le prix des cartouches dans le cas des jets d’encres.


#16

Je n’ai pas besoin de m’y consacrer s’il n’y a rien à faire (ce qui est le cas normalement après une installation bien faite et des périphériques “amicaux”).

Si je ne les passe pas à Debian, je suis sollicité beaucoup plus souvent pour du dépannage que si je les passe sous Debian.

[quote=“Clochette”]commence par éviter toutes les marques du type Canon et autres consorts, ainsi que les dernières innovations et format.

En règle générale Brother, HP propose des imprimantes de très bon rapports qualité pris et avec des pilotes plus que corrects pour Linux[/quote]
Merci du retour.


#17

je reviens sur ma HP

hplipopensource.com/hplip-web/mo … _6600.html


#18

[quote=“MisterFreez”][quote=“vv222”]le pilote officiel depuis les dépôts de Samsung :
bchemnet.com/suldr/index.html[/quote]
Quelle est la licence de ce qui est proposée là dessus ?[/quote]
Un mélange de licences pas claires, toutes non-libres bien sûr :
bchemnet.com/suldr/legal.html


[quote=“ggoodluck47”]Salut vv222,
(…)
Il s’agit du comportement normal des vrais SCSI qui possèdent leur propre système, déchargeant d’une partie du travail le CPU, qui se met en relation avec l’ordinateur à la mise sous tension.
Le prix de revient de ce type de matériel l’a fait progressivement abandonner pour un matériel avec la même interface mais sollicitant beaucoup plus nos CPU.[/quote]
Ma culture de remercie :023


#19

j’ai depuis, oula… , une browser DCP-340CW
Elle fonctionne (bien c’est un autre problème) le scanner aussi, mais les paquets trouvé ne sont pas sur le dépôt debian.
installé avec dpkg (carrément! j’hésite pas, moi!!!) et en plus, les drivers ne sont pas pour cette imprimante, mas pour un modèle inférieur.
La doc sur le site Browser est bourrée de subtilités de ce genre!

Petit problème: à présent, je voudrai réinstaller sur une arhitecture arm, c’est mort! pas de source :frowning:


#20

Bonjour,

J’ai un scanner EPSON Perfection V30 qui fonctionne parfaitement après avoir installé, dans l’ordre, les 3 paquets fournis pas le constructeur :

  • iscan-data_1.29.0-2_all.deb
  • iscan_2.29.3-1~usb0.1.ltdl7_amd64.deb
  • esci-interpreter-gt-f720_0.1.1-2_amd64.deb
    (Cela fonctionne aussi, sur une Debian 32 bits avec les versions 32 bits qu’on trouve sur le site du constructeur Epson.
    Il faut ensuite :
  • dans /etc/sane.d/epson.conf, /etc/sane.d/epson2.conf et /etc/sane.d/epkowa.conf, ajouter la référence du scanner
usb 0x04b8 0x0131
  • dans /etc/sane.d/dll.conf, ajouter à la suite de epson et epson2
epkowa
  • éventuellement cocher/commenter epson2 dans la liste en faisant précéder son nom d’un #
    et surtout ne pas oublier, dans /lib/udev/rules.d/60-libsane.rules les 2 lignes suivantes :
# Epson Perfection V30
ATTRS{idVendor}=="04b8", ATTRS{idProduct}=="0131", ENV{libsane_matched}="yes"
  • on vérifie si la référence au scanner se retrouve également dans /lib/udev/rules.d/60-iscan.rules la ligne suivante

ATTRS{idVendor}=="04b8", ATTRS{idProduct}=="0131", ENV{libsane_matched}="yes"
mais normalement elle s’y trouve.
Le scanner allumé, on lance Xsane et … on attend une bonne minute avant de voir apparaître la fenêtre de sélection du scanner. ( Oui, c’est très très lent mais on ne sait pas pourquoi !) Il y est proposé un scanner “unknown” et un Perfection V30. On clique sur la ligne du V30 et on valide.
Les fenêtres de Xsane s’ouvrent et on peut - enfin - travailler.

J’ai également 2 imprimantes laser :

  • Samsung ML-1670 Imprimante laser noir qui s’installe facilement depuis CUPS à la seule condition de choisir le pilote conseillé : “Samsung CLP-310 Foomatic/foo2qpdl (recommended)” dans la liste des pilotes car il n’y a plus ml-1670 dans la liste. Néanmoins, avec ce pilote, l’imprimante fonctionne à merveille.
  • Samsung CLP-315 Imprimante laser couleur (4 cartouches séparées) qui s’installe facilement depuis CUPS en choisissant le pilote “Samsung CLP-315 Foomatic/foo2qpdl (recommended)

Ces 3 appareils fonctionnent très bien aussi bien sous Debian 6, 7.1 et maintenant 7.5 sur un ordi (une tour) de bureau et Mint 12 à 14, sans oublier Ubuntu que j’utilisais jusqu’à la version 1304 sur un portable HP530.

A+